[PATCH] gnu: copyq: Update to 6.3.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • kiasoc5
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221112081304.17017-1-kiasoc5@disroot.org
* gnu/packages/xdisorg (copyq): Update to 6.3.2.
[arguments]: Use g-expressions.
[inputs]: Add qtdeclarative-5, qtwayland-5, wayland, knotifications.
[native-inputs]: Add extra-cmake-modules, qttools-5.
---
gnu/packages/xdisorg.scm | 21 ++++++++++++++++-----
1 file changed, 16 insertions(+), 5 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index c4cc351cad..1d6d1a068b 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -111,6 +111,7 @@ (define-module (gnu packages xdisorg)
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
+ #:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages libevent)
#:use-module (gnu packages linux)
@@ -358,7 +359,7 @@ (define-public bemenu
(define-public copyq
(package
(name "copyq")
- (version "3.9.3")
+ (version "6.3.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -367,13 +368,23 @@ (define-public copyq
(file-name (git-file-name name version))
(sha256
(base32
- "0wlwq9xg8rzsbj0b29z358k4mbrqy04iraa8x0p26pa95yskgcma"))))
+ "0qdf7lr6bdmsnz1k5nnzmbv4h0xj8jqg92x6089qdaz5s87x7vqr"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DCMAKE_BUILD_TYPE=Release")
- #:tests? #f)) ; Test suite is a rather manual process.
+ (list
+ #:configure-flags #~(list "-DCMAKE_BUILD_TYPE=Release")
+ #:tests? #f)) ; Test suite is a rather manual process.
(inputs
- (list qtbase-5 qtscript qtsvg-5 qtx11extras))
+ (list qtbase-5
+ qtscript
+ qtsvg-5
+ qtx11extras
+ qtdeclarative-5
+ qtwayland-5
+ wayland
+ knotifications))
+ (native-inputs
+ (list extra-cmake-modules qttools-5))
(synopsis "Clipboard manager with advanced features")
(description "CopyQ is clipboard manager with editing and scripting
features. CopyQ monitors system clipboard and saves its content in customized

base-commit: ad03c2d461100539aec9a32de081a320dce4f50d
--
2.38.1
Efraim Flashner wrote 2 years ago
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 59211-done@debbugs.gnu.org)
Y3NZFweXTZIRLZX5@3900XT
Thanks. Patch pushed!

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmNzWRcACgkQQarn3Mo9
g1Fcxg/+LLMwxmSm+oev0JLn3yhEoO0bGrblcyXbf7kvsl5+oA/XNpGzmd6uhBAI
hTp52yTwSC5dtyIWqDtSjZCjBnD4bSQjGjD+1IaxA+DJVEDLhQb1gDzOqfq+XciD
hwCD2UgKq7Of5IXXqoEKSutXGS7uOMtCTWIRsBLa2YGlfGZNgPAET3K0O/+TRoM5
qzgePKy/F8QGk+iVu35DD4ahe3LIcaBQag2kBGoEPRZped8FPk7OgQohYWvhBwfK
kYmkR97TfEFdWs44TO7I8dAKhA4r8FSO5NYGF2IgvwlXvSevn5mWbkbBfPuSm5Cx
jsIBi9zUDqPezZi9tBd24SFaquJTbAB1Xi5yunBlsajoDFJEpLmfWw4acMUeqakS
adjoBrbVt3nKRSnPUifSZAiKwlsS7f7TcRmAXjRFE2QX8YANjoECAh3gP6QV07vE
f5W6k7XGfIVA0glxTGqnEuFdLm+qe36F5GRj7DzsLfHkXR0TeyiKirriFl2L17zb
pPbGnbiDi9kuwYp3KJ7KP4pfG8PD4ci9xCqi4Ea0Gmjyi0NEvv3oBFRFicjjVXoP
5hdwQdwHKYWZ4nqwztLDFunKPykzq5RB/BvkkEh6/hAP7OYM8hKRu/BmI+fHBIsD
tUSJCqAS1piwrtG9Cq3Mj2DZocNQjeo2mzYu8i8XTRfZT2cSe+Y=
=x4zu
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59211@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59211
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help