[PATCH 0/3] Add gojq and dependencies.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Ludovic Courtès
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
d7d56f78-2f4b-18b3-009a-960d57c629bd@disroot.org
gojq is a binary and a library so there is 1 package for each, like fzf.

kiasoc5 (3):
gnu: Add go-github-com-itchyny-timefmt-go.
gnu: Add go-github-com-itchyny-gojq.
gnu: Add gojq.

gnu/packages/web.scm | 63 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 63 insertions(+)


base-commit: ad03c2d461100539aec9a32de081a320dce4f50d
--
2.38.1
kiasoc5 wrote 2 years ago
[PATCH 1/3] gnu: Add go-github-com-itchyny-timefmt-go.
(address . 59210@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221112081554.17164-1-kiasoc5@disroot.org
* gnu/packages/web (go-github-com-itchyny-timefmt-go): New variable.
---
gnu/packages/web.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d2c406915c..7b45f8f841 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4896,6 +4896,29 @@ (define-public jq
you'd expect.")
(license (list license:expat license:cc-by3.0))))
+(define-public go-github-com-itchyny-timefmt-go
+ (package
+ (name "go-github-com-itchyny-timefmt-go")
+ (version "0.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/itchyny/timefmt-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0z5z8hy5lbjqdxp544mf238i77n7pf7bv3psgr5gffh0630dsyag"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/itchyny/timefmt-go"))
+ (home-page "https://github.com/itchyny/timefmt-go")
+ (synopsis "Efficient time formatting library (strftime, strptime) for Golang")
+ (description
+ "@code{timefmt-go} is a Go language package for formatting and parsing date
+time strings.")
+ (license license:expat)))
+
(define-public pup
(let ((revision "1")
(commit "681d7bb639334bf485476f5872c5bdab10931f9a"))
--
2.38.1
kiasoc5 wrote 2 years ago
[PATCH 2/3] gnu: Add go-github-com-itchyny-gojq.
(address . 59210@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221112081554.17164-2-kiasoc5@disroot.org
* gnu/packages/web (go-github-com-itchyny-gojq): New variable.
---
gnu/packages/web.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7b45f8f841..faaaf33f74 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4919,6 +4919,37 @@ (define-public go-github-com-itchyny-timefmt-go
time strings.")
(license license:expat)))
+(define-public go-github-com-itchyny-gojq
+ (package
+ (name "go-github-com-itchyny-gojq")
+ (version "0.12.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/itchyny/gojq")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1m4zchhhi2428r1v0qz08drac4s63mag1pwcqzsf6n495yc3g0h0"))))
+ (build-system go-build-system)
+ (inputs
+ (list go-github-com-google-go-cmp-cmp
+ go-github-com-itchyny-timefmt-go
+ go-github-com-mattn-go-isatty
+ go-github-com-mattn-go-runewidth
+ go-gopkg-in-yaml-v3))
+ (arguments
+ (list
+ #:import-path "github.com/itchyny/gojq/cmd/gojq"
+ #:unpack-path "github.com/itchyny/gojq"))
+ (home-page "https://github.com/itchyny/gojq")
+ (synopsis "Pure Go implementation of jq")
+ (description
+ "@command{gojq} is an Go implementation and library of the jq JSON
+processor.")
+ (license license:expat)))
+
(define-public pup
(let ((revision "1")
(commit "681d7bb639334bf485476f5872c5bdab10931f9a"))
--
2.38.1
kiasoc5 wrote 2 years ago
[PATCH 3/3] gnu: Add gojq.
(address . 59210@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221112081554.17164-3-kiasoc5@disroot.org
* gnu/packages/web (gojq): New variable.
---
gnu/packages/web.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index faaaf33f74..2014e7431b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4950,6 +4950,15 @@ (define-public go-github-com-itchyny-gojq
processor.")
(license license:expat)))
+(define-public gojq
+ (package
+ (inherit go-github-com-itchyny-gojq)
+ (name "gojq")
+ (arguments
+ (ensure-keyword-arguments
+ (package-arguments go-github-com-itchyny-gojq)
+ (list #:install-source? #f)))))
+
(define-public pup
(let ((revision "1")
(commit "681d7bb639334bf485476f5872c5bdab10931f9a"))
--
2.38.1
Ludovic Courtès wrote 2 years ago
Re: bug#59210: [PATCH 0/3] Add gojq and dependencies.
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 59210-done@debbugs.gnu.org)
878rju915u.fsf@gnu.org
Hi,

kiasoc5 <kiasoc5@disroot.org> skribis:

Toggle quote (4 lines)
> gnu: Add go-github-com-itchyny-timefmt-go.
> gnu: Add go-github-com-itchyny-gojq.
> gnu: Add gojq.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59210@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59210
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help