(address . bug-guix@gnu.org)
Hello!
So I was trying to mount /run/user/1000 in a container so it would have
access to all my wayland sockets and such when I got a very cryptic
error message.
I was trying something like this:
guix shell --share=/run/user/1000 -C coreutils
After far too long tracking down the issue, it turns out that the
directory had submounts within it meaning that the MS_REC flag is
required to bind mount it.
My /run/user/1000 only had a submount because xdg-document-portal was
making one. To test this yourself you can run `mount` to find something
with some submounts. I think /sys/fs might fail for me for the same
reason.
Now I have no clue what we should do to enable this use case. Maybe we
should allow users to specify mount options using something like this?
guix shell -C --mount=rbind,ro=/run/user/1000
Maybe we could always bind with the recursive flag?
Thanks,
Morgan