[berlin] configure mumi <- debbugs sync via an rsync service

  • Done
  • quality assurance status badge
Details
2 participants
  • Felix Lechner
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal

Debbugs page

Maxim Cournoyer wrote 2 years ago
(name . bug-guix)(address . bug-guix@gnu.org)
874jv6wunc.fsf@gmail.com
Hi,

Currently, the sync of issues with MUMI happen via a manually launched
rsync (by rekado). We should properly configure it in the berlin.scm
configuration file, so that it sticks after a reboot.

--
Thanks,
Maxim
Maxim Cournoyer wrote 2 years ago
(address . 59180@debbugs.gnu.org)
87fseqvc9p.fsf@gmail.com
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (6 lines)
> Hi,
>
> Currently, the sync of issues with MUMI happen via a manually launched
> rsync (by rekado). We should properly configure it in the berlin.scm
> configuration file, so that it sticks after a reboot.

From Ricardo:

We need the service to read a secret from a file, set an env var
(RSYNC_PASSWORD), and then keep doing this:

timeout --kill-after 5m 1h rsync --delete -av
--
Thanks,
Maxim
Maxim Cournoyer wrote 1 years ago
(name . Felix Lechner)(address . felix.lechner@lease-up.com)(address . 59180@debbugs.gnu.org)
8734ucowqt.fsf@gmail.com
Hi Felix,

Felix Lechner <felix.lechner@lease-up.com> writes:

Toggle quote (10 lines)
> Hi Maxim,
>
> Here is rsync service I use [1] in case that's helpful.
>
> Kind regards
> Felix
>
> [1]
> https://codeberg.org/lechner/system-config/src/commit/bf38906f52526d9d8a2bb92489b3bd51d0e7d713/host/wallace-server/operating-system.scm#L633-L651

Thanks.

This is how it is manually started, peeking at top:

Toggle snippet (3 lines)
bash -c while true; do timeout --kill-after 5m 1h rsync --delete -av debbugs-var@debbugs.gnu.org::var-lib-debbugs /var/mumi/data/; sleep 1; done

--
Thanks,
Maxim
Maxim Cournoyer wrote 1 years ago
(name . Felix Lechner)(address . felix.lechner@lease-up.com)
87v878nexh.fsf@gmail.com
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (20 lines)
> Hi Felix,
>
> Felix Lechner <felix.lechner@lease-up.com> writes:
>
>> Hi Maxim,
>>
>> Here is rsync service I use [1] in case that's helpful.
>>
>> Kind regards
>> Felix
>>
>> [1]
>> https://codeberg.org/lechner/system-config/src/commit/bf38906f52526d9d8a2bb92489b3bd51d0e7d713/host/wallace-server/operating-system.scm#L633-L651
>
> Thanks.
>
> This is how it is manually started, peeking at top:
>
> bash -c while true; do timeout --kill-after 5m 1h rsync --delete -av debbugs-var@debbugs.gnu.org::var-lib-debbugs /var/mumi/data/; sleep 1; done

I implemented the above reusing the shared mcron job almost as-is,
and it appears to work:

Toggle snippet (29 lines)
2024-02-01 20:46:00 90211 Rsync Debbugs data: running...
2024-02-01 20:46:01 90211 Rsync Debbugs data: receiving incremental file list
2024-02-01 20:46:01 90211 Rsync Debbugs data: spool/
2024-02-01 20:46:01 90211 Rsync Debbugs data: spool/by-affects.idx
2024-02-01 20:46:01 90211 Rsync Debbugs data: spool/by-correspondent.idx
2024-02-01 20:46:02 90211 Rsync Debbugs data: spool/by-message-id.idx
2024-02-01 20:46:02 90211 Rsync Debbugs data: spool/by-owner.idx
2024-02-01 20:46:02 90211 Rsync Debbugs data: spool/by-package.idx
[...]
2024-02-01 20:46:36 90211 Rsync Debbugs data: spool/rrd/org-mode_tag.rrd
2024-02-01 20:46:36 90211 Rsync Debbugs data: spool/rrd/parted.rrd
2024-02-01 20:46:36 90211 Rsync Debbugs data: spool/rrd/parted_tag.rrd
2024-02-01 20:46:36 90211 Rsync Debbugs data: spool/rrd/sed.rrd
2024-02-01 20:46:36 90211 Rsync Debbugs data: spool/rrd/sed_tag.rrd
2024-02-01 20:46:36 90211 Rsync Debbugs data: spool/rrd/skribilo.rrd
2024-02-01 20:46:36 90211 Rsync Debbugs data: spool/rrd/skribilo_tag.rrd
2024-02-01 20:46:36 90211 Rsync Debbugs data: spool/rrd/vc-dwim.rrd
2024-02-01 20:46:36 90211 Rsync Debbugs data: spool/rrd/vc-dwim_tag.rrd
2024-02-01 20:46:36 90211 Rsync Debbugs data: spool/rrd/woodchuck.rrd
2024-02-01 20:46:36 90211 Rsync Debbugs data: spool/rrd/woodchuck_tag.rrd
2024-02-01 20:46:36 90211 Rsync Debbugs data: www/db/
2024-02-01 20:46:39 90211 Rsync Debbugs data: www/db/ix/
2024-02-01 20:46:39 90211 Rsync Debbugs data: www/db/ix/zstamp.html
2024-02-01 20:46:40 90211 Rsync Debbugs data:
2024-02-01 20:46:40 90211 Rsync Debbugs data: sent 161,909 bytes received 8,905,931 bytes 223,897.28 bytes/sec
2024-02-01 20:46:40 90211 Rsync Debbugs data: total size is 18,780,129,589 speedup is 2,071.07
2024-02-01 20:46:40 90211 Rsync Debbugs data: completed in 40.293s

Thanks a lot, Felix!

--
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59180@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59180
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help