[PATCH] gnu: Add cl-nsymbols.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Artyom Bologov
Owner
unassigned
Submitted by
Artyom Bologov
Severity
normal

Debbugs page

Artyom Bologov wrote 2 years ago
(address . guix-patches@gnu.org)
87zgcz55m8.fsf@aartaka.me
Hello Guix,

This adds cl-nsymbols
From 58caa7d89223e80032606a99b35bd6221152c4bd Mon Sep 17 00:00:00 2001
From: Artyom Bologov <mail@aartaka.me>
Date: Thu, 10 Nov 2022 16:53:09 +0400
Subject: [PATCH] gnu: Add cl-nsymbols.

* gnu/packages/lisp-xyz.scm (sbcl-nsymbols, cl-nsymbols, ecl-nsymbols): New
variables.
---
gnu/packages/lisp-xyz.scm | 50 +++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b3c5eec050..259c13affd 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -22637,6 +22637,56 @@ (define-public cl-nactivitypub
(define-public ecl-nactivitypub
(sbcl-package->ecl-package sbcl-nactivitypub))
+(define-public sbcl-nsymbols
+ (package
+ (name "sbcl-nsymbols")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/atlas-engineer/nsymbols")
+ (commit version)))
+ (file-name (git-file-name "cl-nsymbols" version))
+ (sha256
+ (base32
+ "1nks5v2l6vf0kwiyv3r2lickp3xhyi0ck33y1l08crmwhn097hpd"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs (list sbcl-lisp-unit2 sbcl))
+ (synopsis
+ "Functions to search, filter, and group symbols in chosen packages")
+ (home-page "https://github.com/atlas-engineer/nsymbols")
+ (description "Nsymbols extends the regular package API of ANSI CL with more
+operations, allowing one to list:
+
+@itemize
+@item @code{package-symbols}.
+@item @code{package-variables}.
+@item @code{package-functions}.
+@item @code{package-generic-functions}.
+@item @code{package-macros}.
+@item @code{package-classes}.
+@item @code{package-structures}.
+@item And other symbol types, given code@{define-symbol-type} for those.
+@end itemize
+
+Nsymbols can also find symbols by their name/matching symbol with
+@code{resolve-symbol}. All these operations are aware of symbol
+visibility in the given packages, due to a @code{symbol-visibility}
+function.
+
+An additional @code{nsymbols/star} system has a set of function
+mirroring the regular Nsymbols ones, but using @code{closer-mop} to
+provide better results and returning structured data instead of
+symbols.")
+ (license license:bsd-3)))
+
+(define-public cl-nsymbols
+ (sbcl-package->cl-source-package sbcl-nsymbols))
+
+(define-public ecl-nsymbols
+ (sbcl-package->ecl-package sbcl-nsymbols))
+
(define-public sbcl-utils-kt
(let ((commit "4adfe2889036ab5ffdd3cc2182ca2cc692bf11ff"))
(package
--
2.37.1
Thanks,
--
Artyom Bologov.
Guillaume Le Vaillant wrote 2 years ago
(name . Artyom Bologov)(address . mail@aartaka.me)(address . 59170-done@debbugs.gnu.org)
87leoic46d.fsf@kitej
Patch pushed as 1f5e8ef14ffa385907fc94a754cfff7a45fee50c.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY20A2g8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8HDwD+Pqs6rsPb9HY7NNWabYje5Arl3j+izQ7aIrV8
O5Ey4W0BAKABXnLok6S6S1mEj/L5rGr0aon5YJsRi3Wy2v7hWQRM
=78Nw
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59170@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59170
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help