[PATCH] snippets: yas: Add snippets for vc.el

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Ludovic Courtès
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 2 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163CE2FE05B4A85C63CB4AEC53E9@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* etc/snippets/yas/log-edit-mode/guix-vc-commit-message-add-package:
* etc/snippets/yas/log-edit-mode/guix-vc-commit-message-remove-package:
* etc/snippets/yas/log-edit-mode/guix-vc-commit-message-rename-package:
* etc/snippets/yas/log-edit-mode/guix-vc-commit-message-update-package:
* etc/snippets/yas/log-edit-mode/guix-vc-commit-message-use-https-home-page:
New file
---

This recreates the magit snippets but with the builtin Emacs vc stuff. It
shouldn't conflict with the magit snippets since it will only active in
log-edit-mode (which magit doesn't use).

I didn't really test the rename snippet because testing is hard and I have no
clue what the add-cl-package snippet does so I didn't try to recreate that one.


.../guix-vc-commit-message-add-package | 9 +++++++++
.../guix-vc-commit-message-remove-package | 9 +++++++++
.../guix-vc-commit-message-rename-package | 14 ++++++++++++++
.../guix-vc-commit-message-update-package | 12 ++++++++++++
.../guix-vc-commit-message-use-https-home-page | 9 +++++++++
5 files changed, 53 insertions(+)
create mode 100644 etc/snippets/yas/log-edit-mode/guix-vc-commit-message-add-package
create mode 100644 etc/snippets/yas/log-edit-mode/guix-vc-commit-message-remove-package
create mode 100644 etc/snippets/yas/log-edit-mode/guix-vc-commit-message-rename-package
create mode 100644 etc/snippets/yas/log-edit-mode/guix-vc-commit-message-update-package
create mode 100644 etc/snippets/yas/log-edit-mode/guix-vc-commit-message-use-https-home-page

Toggle diff (85 lines)
diff --git a/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-add-package b/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-add-package
new file mode 100644
index 0000000000..cc2dddb1e0
--- /dev/null
+++ b/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-add-package
@@ -0,0 +1,9 @@
+# -*- mode: snippet -*-
+# name: guix-vc-commit-message-add-package
+# key: add
+# --
+gnu: Add ${1:`(when (string-match "\\+(define-public \\(\\S-+\\)" vc-patch-string)
+ (match-string-no-properties 1 vc-patch-string))`}.
+
+* `(car (log-edit-files))` ($1): New variable.
+`(mapconcat (lambda (file) (concat "* " file)) (cdr (log-edit-files)) "\n")`
diff --git a/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-remove-package b/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-remove-package
new file mode 100644
index 0000000000..9ab4ce6156
--- /dev/null
+++ b/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-remove-package
@@ -0,0 +1,9 @@
+# -*- mode: snippet -*-
+# name: guix-vc-commit-message-remove-package
+# key: remove
+# --
+gnu: Remove ${1:`(when (string-match "\\-(define-public \\(\\S-+\\)" vc-patch-string)
+ (match-string-no-properties 1 vc-patch-string))`}.
+
+* `(car (log-edit-files))` ($1): Delete variable.
+`(mapconcat (lambda (file) (concat "* " file)) (cdr (log-edit-files)) "\n")`
diff --git a/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-rename-package b/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-rename-package
new file mode 100644
index 0000000000..89c85f8016
--- /dev/null
+++ b/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-rename-package
@@ -0,0 +1,14 @@
+# -*- mode: snippet -*-
+# name: guix-vc-commit-message-rename-package
+# key: rename
+# --
+gnu: ${1:`(when (string-match "\\-(define-public \\(\\S-+\\)" vc-patch-string)
+ (match-string-no-properties 1 vc-patch-string))
+ `}: Rename package to ${2:`
+ (when (string-match "\\+(define-public \\(\\S-+\\)" vc-patch-string)
+ (match-string-no-properties 1 vc-patch-string))`}.
+
+* `(car (log-edit-files))` ($1): Define in terms of
+'deprecated-package'.
+($2): New variable, formerly known as "$1".
+`(mapconcat (lambda (file) (concat "* " file)) (cdr (log-edit-files)) "\n")`
diff --git a/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-update-package b/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-update-package
new file mode 100644
index 0000000000..b5e41709f5
--- /dev/null
+++ b/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-update-package
@@ -0,0 +1,12 @@
+# -*- mode: snippet -*-
+# name: guix-vc-commit-message-update-package
+# key: update
+# --
+
+gnu: ${1:`(when (string-match "^[ ]*(define-public \\(\\S-+\\)" vc-patch-string)
+ (match-string-no-properties 1 vc-patch-string))`}: Update to ${2:`
+ (when (string-match "^\\+[ ]*(version \"\\(.*\\)\"" vc-patch-string)
+ (match-string-no-properties 1 vc-patch-string))`}.
+
+* `(car (log-edit-files))` ($1): Update to $2.$0
+`(mapconcat (lambda (file) (concat "* " file)) (cdr (log-edit-files)) "\n")`
diff --git a/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-use-https-home-page b/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-use-https-home-page
new file mode 100644
index 0000000000..e0f170b015
--- /dev/null
+++ b/etc/snippets/yas/log-edit-mode/guix-vc-commit-message-use-https-home-page
@@ -0,0 +1,9 @@
+# -*- mode: snippet -*-
+# name: guix-vc-commit-message-use-https-home-page
+# key: https
+# --
+gnu: ${1:`(when (string-match "^[ ]*(define-public \\(\\S-+\\)" vc-patch-string)
+ (match-string-no-properties 1 vc-patch-string))`}: Use HTTPS home page URI.
+
+* `(car (log-edit-files))` ($1)[home-page]: Use HTTPS URI.
+`(mapconcat (lambda (file) (concat "* " file)) (cdr (log-edit-files)) "\n")`
--
2.38.0
Ludovic Courtès wrote 2 years ago
(address . Morgan.J.Smith@outlook.com)(address . 59157-done@debbugs.gnu.org)
87sfi2922u.fsf@gnu.org
Hi,

Morgan.J.Smith@outlook.com skribis:

Toggle quote (17 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * etc/snippets/yas/log-edit-mode/guix-vc-commit-message-add-package:
> * etc/snippets/yas/log-edit-mode/guix-vc-commit-message-remove-package:
> * etc/snippets/yas/log-edit-mode/guix-vc-commit-message-rename-package:
> * etc/snippets/yas/log-edit-mode/guix-vc-commit-message-update-package:
> * etc/snippets/yas/log-edit-mode/guix-vc-commit-message-use-https-home-page:
> New file
> ---
>
> This recreates the magit snippets but with the builtin Emacs vc stuff. It
> shouldn't conflict with the magit snippets since it will only active in
> log-edit-mode (which magit doesn't use).
>
> I didn't really test the rename snippet because testing is hard and I have no
> clue what the add-cl-package snippet does so I didn't try to recreate that one.

Alright. I didn’t test it but it looks reasonable and safe, so I went
ahead and applied it.

Thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59157@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59157
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help