[PATCH] gnu: python-mdurl: Enable tests

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221109195951.30629-1-sharlatanus@gmail.com
* gnu/packages/python-xyz.scm (python-mdurl): Enable tests.
[source]: Use git checkout with tests.
[build-system]: Use pyproject-build-system.
[native-inputs]: Add python-pytest.
---
gnu/packages/python-xyz.scm | 33 +++++++++++----------------------
1 file changed, 11 insertions(+), 22 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b2fb101409..9c7874e576 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -783,28 +783,17 @@ (define-public python-mdurl
(package
(name "python-mdurl")
(version "0.1.2")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "mdurl" version))
- (sha256
- (base32
- "1fn1hy35h9grggwqax90zcb52inlfxrxsm27vlqqz8zfyllkshdv"))))
- (build-system python-build-system)
- (arguments
- (list
- #:tests? #f ;pypi source does not contain tests
- #:phases
- #~(modify-phases %standard-phases
- (replace 'build
- (lambda _ (invoke "flit" "build")))
- (replace 'install
- (lambda _
- (for-each
- (lambda (wheel)
- (invoke "python" "-m" "pip" "install"
- wheel (string-append "--prefix=" #$output)))
- (find-files "dist" "\\.whl$")))))))
- (native-inputs (list python-flit))
+ (source
+ (origin
+ (method git-fetch) ; no tests data in PyPi package
+ (uri (git-reference
+ (url "https://github.com/executablebooks/mdurl")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0csc777q42jzv4zgdzxmwp8xqlb92ws1jvj09m2smh4klw67q5f3"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit python-pytest))
(home-page "https://github.com/executablebooks/mdurl")
(synopsis "Markdown URL utilities")
(description
--
2.38.0
Efraim Flashner wrote 2 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59156-done@debbugs.gnu.org)
Y3Nqg9b+wqMebzuw@3900XT
Thanks! Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmNzaoMACgkQQarn3Mo9
g1FFqg//UxpSR0s2kgaqU/W2rNiv4ijZHMfwtjdS4phzx7v0amIj1W+tAMDAlB0I
W0kMxCLlmPgllK4fdu72Op4Mpr9snFXCiJ4ombtAXdK37egTWbqkqKndKADiC9MM
4wBw5aOoV3d6RjU5R+ZLKz0huHnZF3MC29jquYGYam9c0Ioiq/ETmoLxCSuMQHeY
W4UbP8YD4SYs68jErxzHRGU41PqKxOXpgWU0RxD4zd8Df0cnIOuyXIWoAYg5z5fc
wCPfzX6DHeLeCSPRyxnP1E+DepYIwuO6zDqrMqdEjw2CJZuOToJoGATtSU2NaKJt
wKHF2F23HEM9bqm8wo2QYOGbtgkfSUF/DyT8PbgU4ALaBUyXIdeHct/I8DvTUNp6
/ezq07VsknUi4lZPu7LMyLzE3lAT+GnMZgy9PmgPNBnmRafuCA24MvsOVNwc/auu
CEIVLawJyjB6toIQIxtqnpiZ05tvhpHXJkwrTU/+072QUEnf6rAAZNRJ/Nvk2ALd
iRl7YiPUarzfKiDxHIk1FNioP2BU3NqdOOwWhMp10USm9hkPyaTbJ+7rVRBwB8IL
GeaiLPnbQo2q5DSCrM/UTC3XOCi7PgmuOjx25eJG4D9fe+66IsEHM0mbkTjHKJse
tN5LN9l+4R3tLdLMhBmWGUf6jGerKL2iGwgSHPcPrZaMMWwLQcY=
=NMvc
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59156@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59156
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help