[PATCH] gnu: python-colorful: Enable tests

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221109194831.27968-1-sharlatanus@gmail.com
* gnu/packages/python-xyz.scm (python-colorful): Enable tests.
[source]: Use git checkout which has tests.
[build-system]: Use pyproject-build-system.
---
gnu/packages/python-xyz.scm | 16 +++++++---------
1 file changed, 7 insertions(+), 9 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e26656fa32..b2fb101409 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -677,16 +677,14 @@ (define-public python-colorful
(version "0.5.4")
(source
(origin
- (method url-fetch)
- (uri
- (pypi-uri "colorful" version))
+ (method git-fetch) ; no tests data in PyPi package
+ (uri (git-reference
+ (url "https://github.com/timofurrer/colorful")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1sh7g2cn1fyz2hzmzs933razdxi2bna9i1lxa790r9pdwba8m146"))))
- (build-system python-build-system)
- ;; FIXME: tests cannot be computed:
- ;; "Can't perform this operation for unregistered loader type"
- (arguments
- `(#:tests? #f))
+ (base32 "1fcz5v8b318a3dsdha4c874jsf3wmcw3f25bv2csixclyzacli98"))))
+ (build-system pyproject-build-system)
(native-inputs
(list python-coverage python-flake8 python-pytest))
(propagated-inputs
--
2.38.0
Efraim Flashner wrote 2 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59155-done@debbugs.gnu.org)
Y3NqfFOPbQLGJT3C@3900XT
Thanks! Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmNzansACgkQQarn3Mo9
g1GDEQ/+KVUNd8QgNNiCtf9h1WyYrhxyul9xFYrpE1wyrZuwkYOeg+nKLCw5Wf8c
tFos9du0kGhZjzDn7s686AeltQZdI9yZgc9I0Ia6TobD654EZ8fMg8ePXvXRp6Gj
IUxtUt2pRufL/1LKZzA1SKZx/U3l+RYFyX1c6WAaZK7sbj6gtlC8SC+tVT11qdFY
JYg6OJOh43YAky3kAB4t3/VXh5uCgbRbYLOPaoa0LJziNXnEDQwqeDXH1kvF7WY0
nnL9hi0koNcQ+iNs1wCD8nVh6jXcTEujZuLTt4R/pEjPrRdlSSvuNFxeCyQNe7ud
BLcriZzS+Q8XXYhI5q8UXt1cMzcvdhpc3LzWJZXQPv1thV+bVLrZgJp4Jg6T5qk2
vpsoLPQd1VKLMAxcEJztHtq8NKkd6D0y5WGIl5xRATa9eG5EM9iJZyoyDOWIupMF
ND/f5C7I8A5zC8+YZdeiuRL5nmqgRkwKqVsU2s154wsKI8OohsM72QOM7YX2FlYz
pILYfzsK67/3AAuHo6lo1fHu0hHnhUitnBeEJOvsySj6RJ+HNUlQag0xZVANCVVi
NyQM2CVlUt1qiesaYbHPcot+imXO2eDsIl0vB9ygPer9mUXfbhdH2QXIVx3foxAZ
elBODoc6PtscmZMcEtKRpmp57cPcd8eVpTEAKtNFtB0HNWQL7/8=
=eGsJ
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59155@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59155
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help