[PATCH] gnu: Add cl-lass.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Artyom Bologov
Owner
unassigned
Submitted by
Artyom Bologov
Severity
normal

Debbugs page

Artyom Bologov wrote 2 years ago
(address . guix-patches@gnu.org)
87leokmfqs.fsf@aartaka.me
Hello Guix,

This add LASS, a Common Lisp library for CSS generation.
From 15f475e66aecb429e9113fb410d2f800cf6225ba Mon Sep 17 00:00:00 2001
From: Artyom Bologov <mail@aartaka.me>
Date: Wed, 9 Nov 2022 17:09:14 +0400
Subject: [PATCH] gnu: Add cl-lass.

* gnu/packages/lisp-xyz.scm (sbcl-lass, cl-lass, ecl-lass): New variables.
---
gnu/packages/lisp-xyz.scm | 43 +++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index cc19efec25..cd012e21bb 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -8583,6 +8583,49 @@ (define-public cl-array-utils
(define-public ecl-array-utils
(sbcl-package->ecl-package sbcl-array-utils))
+(define-public sbcl-lass
+ (let ((commit "a7a4452f6a670b8fb01a73d3007030d16bd1ec2c")
+ (revision "0"))
+ (package
+ (name "sbcl-lass")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/Shinmera/LASS")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06wds1qzj8s862pmmza1427n7gdpplqplxqnxyqkrr0hgxdl4xbf"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-trivial-indent sbcl-trivial-mimes cl-base64))
+ (synopsis "LASS (Lisp Augmented Style Sheets) compiles Lisp to CSS.")
+ (description
+ "With lispy syntax, shortcuts, and improvements, LASS aims to help you
+out in writing CSS quick and easy. LASS was largely inspired by SASS. LASS
+supports two modes, one being directly in your lisp code, the other in pure
+LASS files.
+
+LASS works on the following simple principles: A list is a block. The first
+argument in the list is a selector. The body of the list makes up the
+properties and sub-blocks. A property is started with a keyword that is used
+as the property name. Following is a bunch of property arguments until a new
+keyword, list, or the end is reached. A list inside a block is, again, a block
+with the twist that the parent block's selector is prepended to the
+sub-block's selector.")
+ (home-page "https://shinmera.github.io/LASS/")
+ (license license:zlib))))
+
+(define-public cl-lass
+ (sbcl-package->cl-source-package sbcl-lass))
+
+(define-public ecl-lass
+ (sbcl-package->ecl-package sbcl-lass))
+
(define-public sbcl-plump
(let ((commit "3584275f0be9d06c0c51b5c08f89005deafc4ada")
(revision "2"))
--
2.37.1
Thanks,
--
Artyom Bologov.
Guillaume Le Vaillant wrote 2 years ago
(name . Artyom Bologov)(address . mail@aartaka.me)(address . 59148-done@debbugs.gnu.org)
87tu37azf9.fsf@kitej
Patch pushed as a6d6a48b15d1303a31f9a5ea9fe4d28ac294dd86 with some minor
modifications. Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY2zPKg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/qrQD+Ije9Rxxg95Ww5+U7lXSbWBujechDBcgUQ6Ep
SqBexyEA/3liiHPp64usAsM4xSJU2HSuoSzxxqddU5Df7wFhjbFP
=L3fh
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59148@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59148
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help