[PATCH] gnu: emacs-magit: Fix tests.

  • Done
  • quality assurance status badge
Details
One participant
  • (
Owner
unassigned
Submitted by
(
Severity
normal
(
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20221109080420.4799-1-paren@disroot.org
* gnu/packages/patches/emacs-magit-use-old-git-behaviour.patch: New
patch.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/emacs-xyz.scm (emacs-magit)[source]<patches>: Use it.
---
gnu/local.mk | 1 +
gnu/packages/emacs-xyz.scm | 3 +++
.../emacs-magit-use-old-git-behaviour.patch | 24 +++++++++++++++++++
3 files changed, 28 insertions(+)
create mode 100644 gnu/packages/patches/emacs-magit-use-old-git-behaviour.patch

Toggle diff (68 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 9e5c6bfe9d..5dc07aaf03 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1063,6 +1063,7 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
%D%/packages/patches/emacs-libgit-use-system-libgit2.patch \
%D%/packages/patches/emacs-lispy-fix-thread-last-test.patch \
+ %D%/packages/patches/emacs-magit-use-old-git-behaviour.patch \
%D%/packages/patches/emacs-native-comp-driver-options.patch \
%D%/packages/patches/emacs-polymode-fix-lexical-variable-error.patch \
%D%/packages/patches/emacs-source-date-epoch.patch \
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4bbebd3cd6..4b57eb8e05 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -117,6 +117,7 @@
;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1001,6 +1002,8 @@ (define-public emacs-magit
(uri (git-reference
(url "https://github.com/magit/magit")
(commit (string-append "v" version))))
+ (patches
+ (search-patches "emacs-magit-use-old-git-behaviour.patch"))
(file-name (git-file-name name version))
(sha256
(base32 "0cxyvp2aav27znc7mf6c83q5pddpdniaqkrxn1r8dbgr540qmnpn"))))
diff --git a/gnu/packages/patches/emacs-magit-use-old-git-behaviour.patch b/gnu/packages/patches/emacs-magit-use-old-git-behaviour.patch
new file mode 100644
index 0000000000..1f28d23cd2
--- /dev/null
+++ b/gnu/packages/patches/emacs-magit-use-old-git-behaviour.patch
@@ -0,0 +1,24 @@
+This patch fixes two of Magit's tests when used with Git 2.38.1. Git commit
+a1d4f67c12 (transport: make `protocol.file.allow` be "user" by default) had
+broken them, so this cherry-pick of Magit 36059e0b sets it "protocol.file.allow"
+back to "always".
+
+Author: Kyle Meyer <kyle@kyleam.com>
+Added by: ( <paren@disroot.org>
+
+diff --git a/t/magit-tests.el b/t/magit-tests.el
+index 523cc519..bc556d17 100644
+--- a/t/magit-tests.el
++++ b/t/magit-tests.el
+@@ -24,7 +24,10 @@
+ (declare (indent 0) (debug t))
+ (let ((dir (make-symbol "dir")))
+ `(let ((,dir (file-name-as-directory (make-temp-file "magit-" t)))
+- (process-environment process-environment))
++ (process-environment process-environment)
++ (magit-git-global-arguments
++ (nconc (list "-c" "protocol.file.allow=always")
++ magit-git-global-arguments)))
+ (push "GIT_AUTHOR_NAME=A U Thor" process-environment)
+ (push "GIT_AUTHOR_EMAIL=a.u.thor@example.com" process-environment)
+ (condition-case err
\ No newline at end of file

base-commit: 96ae718c516a289124a0b91ceeef78b20d187825
--
2.38.1
(
[PATCH v2] gnu: emacs-magit: Fix tests.
(address . 59145@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20221109080524.5089-1-paren@disroot.org
* gnu/packages/patches/emacs-magit-use-old-git-behaviour.patch: New
patch.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/emacs-xyz.scm (emacs-magit)[source]<patches>: Use it.
---
gnu/local.mk | 1 +
gnu/packages/emacs-xyz.scm | 3 +++
.../emacs-magit-use-old-git-behaviour.patch | 24 +++++++++++++++++++
3 files changed, 28 insertions(+)
create mode 100644 gnu/packages/patches/emacs-magit-use-old-git-behaviour.patch

Toggle diff (67 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 9e5c6bfe9d..5dc07aaf03 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1063,6 +1063,7 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
%D%/packages/patches/emacs-libgit-use-system-libgit2.patch \
%D%/packages/patches/emacs-lispy-fix-thread-last-test.patch \
+ %D%/packages/patches/emacs-magit-use-old-git-behaviour.patch \
%D%/packages/patches/emacs-native-comp-driver-options.patch \
%D%/packages/patches/emacs-polymode-fix-lexical-variable-error.patch \
%D%/packages/patches/emacs-source-date-epoch.patch \
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4bbebd3cd6..4b57eb8e05 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -117,6 +117,7 @@
;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1001,6 +1002,8 @@ (define-public emacs-magit
(uri (git-reference
(url "https://github.com/magit/magit")
(commit (string-append "v" version))))
+ (patches
+ (search-patches "emacs-magit-use-old-git-behaviour.patch"))
(file-name (git-file-name name version))
(sha256
(base32 "0cxyvp2aav27znc7mf6c83q5pddpdniaqkrxn1r8dbgr540qmnpn"))))
diff --git a/gnu/packages/patches/emacs-magit-use-old-git-behaviour.patch b/gnu/packages/patches/emacs-magit-use-old-git-behaviour.patch
new file mode 100644
index 0000000000..669cf0486d
--- /dev/null
+++ b/gnu/packages/patches/emacs-magit-use-old-git-behaviour.patch
@@ -0,0 +1,24 @@
+This patch fixes two of Magit's tests when used with Git 2.38.1. Git commit
+a1d4f67c12 (transport: make `protocol.file.allow` be "user" by default) had
+broken them, so this cherry-pick of Magit 36059e0b sets it "protocol.file.allow"
+back to "always".
+
+Author: Kyle Meyer <kyle@kyleam.com>
+Added by: ( <paren@disroot.org>
+
+diff --git a/t/magit-tests.el b/t/magit-tests.el
+index 523cc519..bc556d17 100644
+--- a/t/magit-tests.el
++++ b/t/magit-tests.el
+@@ -24,7 +24,10 @@
+ (declare (indent 0) (debug t))
+ (let ((dir (make-symbol "dir")))
+ `(let ((,dir (file-name-as-directory (make-temp-file "magit-" t)))
+- (process-environment process-environment))
++ (process-environment process-environment)
++ (magit-git-global-arguments
++ (nconc (list "-c" "protocol.file.allow=always")
++ magit-git-global-arguments)))
+ (push "GIT_AUTHOR_NAME=A U Thor" process-environment)
+ (push "GIT_AUTHOR_EMAIL=a.u.thor@example.com" process-environment)
+ (condition-case err

base-commit: 96ae718c516a289124a0b91ceeef78b20d187825
--
2.38.1
(
(address . 59145-done@debbugs.gnu.org)
CO80YGDPRCNO.2NCW304PR0IR7@guix-framework
Looks like Andrew Tropin updated emacs-magit to that commit to fix it. I think
it would have been better to use a cherry-picked patch, but oh well :)

-- (
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59145@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59145
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch