[PATCH] gnu: Add r-pals, r-glmnetutils and r-pando.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
444bff8aed1f443896b5f3ced07297fa@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-pando): New variable.

* gnu/packages/cran.scm (r-glmnetutils and r-pals): New variables.
Attachment: file
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 1/3] gnu: Add r-pals.
(address . 59142@debbugs.gnu.org)
20221109031331.12487-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-pals): New variable.
---
gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index eff789ba8d..7f5ad1faf3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1661,6 +1661,31 @@ (define-public r-pacman
functions which can speed up workflow.")
(license license:gpl2)))
+(define-public r-pals
+ (package
+ (name "r-pals")
+ (version "1.7")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "pals" version))
+ (sha256
+ (base32
+ "18pbivmqs9yqsb6p8anv42alny0njaq3dajibhzysax0b7rsk2js"))))
+ (properties `((upstream-name . "pals")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-colorspace
+ r-dichromat
+ r-mapproj
+ r-maps))
+ (native-inputs (list r-knitr))
+ (home-page "https://kwstat.github.io/pals/")
+ (synopsis "Color palettes, color maps, and tools to evaluate them")
+ (description
+ "This package provides a comprehensive collection of color palettes, color
+maps, and tools to evaluate them.")
+ (license license:gpl3)))
+
(define-public r-paralleldist
(package
(name "r-paralleldist")

base-commit: 7de6aa8a0abdb54727e1dd8f775802284b99e707
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 3/3] gnu: Add r-pando.
(address . 59142@debbugs.gnu.org)
20221109031331.12487-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-pando): New variable.
---
gnu/packages/bioinformatics.scm | 50 +++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 47f5574eeb..87c93bab4d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7600,6 +7600,56 @@ (define-public r-chromunity
Pore-C concatemers.")
(license license:gpl3))))
+(define-public r-pando
+ (package
+ (name "r-pando")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/quadbiolab/Pando")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0c83anzdrbvg47p9xns2bxpjlx5z328can3jmzilw6rygwp7hyii"))))
+ (properties `((upstream-name . "Pando")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-bayestestr
+ r-brms
+ r-foreach
+ r-genomicranges
+ r-ggplot2
+ r-ggpointdensity
+ r-ggraph
+ r-glmnetutils
+ r-iranges
+ r-irlba
+ r-matrix
+ r-motifmatchr
+ r-pals
+ r-patchwork
+ r-seurat
+ r-signac
+ r-sparsematrixstats
+ r-tfbstools
+ r-tidygraph
+ r-tidyverse
+ r-uwot
+ r-xgboost))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/quadbiolab/Pando")
+ (synopsis
+ "Inferring regulomes from multi-modal single-cell genomics data")
+ (description
+ "@code{Pando} leverages multi-modal single-cell measurements to infer gene
+regulatory networks using a flexible linear model-based framework. By modeling
+the relationship between TF-binding site pairs with the expression of target
+genes, @code{Pando} simultaneously infers gene modules and sets of regulatory
+regions for each transcription factor.")
+ (license license:expat)))
+
(define-public r-presto
(let ((commit "052085db9c88aa70a28d11cc58ebc807999bf0ad")
(revision "0"))
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 2/3] gnu: Add r-glmnetutils.
(address . 59142@debbugs.gnu.org)
20221109031331.12487-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-glmnetutils): New variable.
---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7f5ad1faf3..71843a8cb6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4153,6 +4153,32 @@ (define-public r-glue
Docstrings (PEP-0257) and Julia's Triple-Quoted String Literals.")
(license license:expat)))
+(define-public r-glmnetutils
+ (package
+ (name "r-glmnetutils")
+ (version "1.1.8")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "glmnetUtils" version))
+ (sha256
+ (base32
+ "1k8ivzjgpkm2a948qxx3wmkhlppbk31qc76spv2pscmp24x0lxyn"))))
+ (properties `((upstream-name . "glmnetUtils")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-glmnet
+ r-matrix))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/hongooi73/glmnetUtils")
+ (synopsis
+ "Streamline the process of fitting elastic net models with glmnet")
+ (description
+ "This package provides a collection of tools to streamline the process of
+fitting elastic net models with @code{glmnet}. In addition to providing a formula
+interface, it also features a function @code{cva.glmnet} to do crossvalidation
+for both α and λ, as well as some utility functions.")
+ (license license:gpl2)))
+
(define-public r-paletteer
(package
(name "r-paletteer")
--
2.38.1
Ricardo Wurmus wrote 2 years ago
Re: [bug#59142] [PATCH 1/3] gnu: Add r-pals.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 59142-done@debbugs.gnu.org)
87iljo3393.fsf@elephly.net
I applied this series with minor indentation changes. Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59142@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59142
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help