[PATCH 0/9] gnu: gwcs: Fix build, update to 0.18.12

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 8 Nov 2022 00:02
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221107230238.27936-1-sharlatanus@gmail.com
Hi Guix team!

This is the last series of patches fixing the issue

Thanks to Christopher who pushed https://issues.guix.gnu.org/58530I am about
to prepare SunPy. I've got in my Sourcehut repository and it passed lint,
build and most of the tests (99.9%)!

Toggle quote (6 lines)
> ./pre-inst-env guix build python-asdf python-asdf-astropy python-asdf-standard python-gwcs --rounds=2
> /gnu/store/42js0gh3lbab0b3vjnx5w8dhw73lbjw2-python-gwcs-0.18.2
> /gnu/store/8b9fgspqxri2gcybsmh71mwji8p1ldnf-python-asdf-standard-1.0.3
> /gnu/store/n615wfm08i4yv17ggvl6il7v12k1p12w-python-asdf-astropy-0.2.2
> /gnu/store/y423ky9wgn0470x7rsqddkgly3cjl158-python-asdf-2.13.0

Sharlatan Hellseher (9):
gnu: Add asdf-standard
gnu: Add asdf-unit-schemas
gnu: Add asdf-fits-schemas
gnu: Add asdf-time-schemas
gnu: asdf-transform-schemas: Update to 0.3.0
gnu: python-asdf: Update to 2.13.0
gnu: python-asdf: Sync test disable comment
gnu: asdf-astropy: Update to 0.2.2
gnu: gwcs: Fix build, update to 0.18.2

gnu/packages/astronomy.scm | 226 +++++++++++++++++++++++++++++--------
1 file changed, 178 insertions(+), 48 deletions(-)


base-commit: 8e54584d4448d37ddf8ae995bb545a181ba2493c
--
2.38.0
S
S
Sharlatan Hellseher wrote on 8 Nov 2022 00:06
[PATCH 1/9] gnu: Add asdf-standard
(address . 59113@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221107230656.28187-1-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-asdf-standard): New variable.
---
gnu/packages/astronomy.scm | 42 ++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index dd27f4e530..92a807a9a5 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -73,6 +73,7 @@ (define-module (gnu packages astronomy)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix git-download)
@@ -1945,6 +1946,47 @@ (define-public python-asdf
implementation of the ASDF Standard.")
(license license:bsd-3)))
+(define-public python-asdf-standard
+ (package
+ (name "python-asdf-standard")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "asdf_standard" version))
+ (sha256
+ (base32
+ "0i7xdjwn5prg2hcnf1zhw57mszc68jjr5sv4rimpzcg7f2dgzn5g"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'remove-blocking-tests
+ (lambda _
+ ;; Remove tests require python-asdf where
+ ;; python-asdf require python-asdf-standard,
+ ;; break circular dependencies.
+ (for-each delete-file
+ (list "tests/test_manifests.py"
+ "tests/test_integration.py")))))))
+ (native-inputs (list python-astropy
+ python-jsonschema-next
+ python-pypa-build
+ python-pytest-7.1
+ python-packaging
+ python-setuptools-scm))
+ (propagated-inputs (list python-importlib-resources))
+ (home-page "https://asdf-standard.readthedocs.io/")
+ (synopsis "ASDF standard schemas")
+ (description
+ "This package provides Python implementation of @acronym{ASDF, Advanced
+Scientific Data Format} - a proposed next generation interchange format for
+scientific data. ASDF aims to exist in the same middle ground that made FITS
+so successful, by being a hybrid text and binary format: containing human
+editable metadata for interchange, and raw binary data that is fast to load
+and use. Unlike FITS, the metadata is highly structured and is designed
+up-front for extensibility.")
+ (license license:bsd-3)))
+
(define python-asdf-transform-schemas
(package
(name "python-asdf-transform-schemas")
--
2.38.0
S
S
Sharlatan Hellseher wrote on 8 Nov 2022 00:06
[PATCH 2/9] gnu: Add asdf-unit-schemas
(address . 59113@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221107230656.28187-2-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-asdf-unit-schemas): New variable.
---
gnu/packages/astronomy.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 92a807a9a5..56eb9143b1 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2052,6 +2052,28 @@ (define python-asdf-coordinates-schemas
install an implementation package such as asdf-astropy.")
(license license:bsd-3)))
+(define python-asdf-unit-schemas
+ (package
+ (name "python-asdf-unit-schemas")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "asdf_unit_schemas" version))
+ (sha256
+ (base32
+ "16grpx3a9h0v1wirp0zqrfsxm867v5c0xyr98pylzziy45kqvds2"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; Dependencies cycle with python-asdf
+ (list #:tests? #f))
+ (native-inputs (list python-setuptools-scm))
+ (propagated-inputs (list python-asdf-standard python-importlib-resources))
+ (home-page "https://asdf-unit-schemas.readthedocs.io/")
+ (synopsis "ASDF serialization schemas for the units defined by @code{astropy.units}")
+ (description "This package provides ASDF schemas for validating unit tags.")
+ (license license:bsd-3)))
+
(define-public python-asdf-astropy
(package
(name "python-asdf-astropy")
--
2.38.0
S
S
Sharlatan Hellseher wrote on 8 Nov 2022 00:06
[PATCH 3/9] gnu: Add asdf-fits-schemas
(address . 59113@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221107230656.28187-3-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-asdf-fits-schemas): New variable.
---
gnu/packages/astronomy.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 56eb9143b1..b07bef73b8 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2052,6 +2052,40 @@ (define python-asdf-coordinates-schemas
install an implementation package such as asdf-astropy.")
(license license:bsd-3)))
+(define python-asdf-fits-schemas
+ ;; TODO: No release, change to tag when it's ready.
+ (let ((commit "572bb370d777f3a325b25c1af9d76e1b7d27dcea")
+ (revision "0"))
+ (package
+ (name "python-asdf-fits-schemas")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/asdf-format/asdf-fits-schemas")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yqnzd0gcrdfl0jqm8m8kz5fd36i8lgh7xkglmp1chsi1cc6mkz2"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; Dependencies cycle with python-asdf
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-version
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" "0.0.1"))))))
+ (native-inputs (list python-setuptools-scm))
+ (propagated-inputs (list python-asdf-standard python-importlib-resources))
+ (home-page "https://github.com/asdf-format/asdf-fits-schemas")
+ (synopsis "ASDF schemas to support the FITS format")
+ (description "This package provides ASDF schemas for validating FITS tags.")
+ (license license:bsd-3))))
+
(define python-asdf-unit-schemas
(package
(name "python-asdf-unit-schemas")
--
2.38.0
S
S
Sharlatan Hellseher wrote on 8 Nov 2022 00:06
[PATCH 4/9] gnu: Add asdf-time-schemas
(address . 59113@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221107230656.28187-4-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-asdf-time-schemas): New variable.
---
gnu/packages/astronomy.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b07bef73b8..ca1740f852 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2086,6 +2086,42 @@ (define python-asdf-fits-schemas
(description "This package provides ASDF schemas for validating FITS tags.")
(license license:bsd-3))))
+(define python-asdf-time-schemas
+ ;; TODO: No release, change to tag when it's ready.
+ (let ((commit "e9174083d9cfd3c6f7ded9eeb360d99ccb8d9d18")
+ (revision "2"))
+ (package
+ (name "python-asdf-time-schemas")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/asdf-format/asdf-time-schemas")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1i40hcxp8sds2zq939fwczjlshfqb9r9pnzy3a44c3wqdbwhcbdb"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; Dependencies cycle with python-asdf
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-version
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" "0.0.1"))))))
+ (native-inputs (list python-setuptools-scm))
+ (propagated-inputs (list python-asdf-standard
+ python-asdf-unit-schemas
+ python-importlib-resources))
+ (home-page "https://github.com/asdf-format/asdf-fits-schemas")
+ (synopsis "Schemas for storing time in ASDF")
+ (description "This package provides ASDF schemas for validating time tags.")
+ (license license:bsd-3))))
+
(define python-asdf-unit-schemas
(package
(name "python-asdf-unit-schemas")
--
2.38.0
S
S
Sharlatan Hellseher wrote on 8 Nov 2022 00:06
[PATCH 5/9] gnu: asdf-transform-schemas: Update to 0.3.0
(address . 59113@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221107230656.28187-5-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-asdf-transform-schemas): Update to 0.3.0.
[build-system]: Use new pyproject-build-system
[tests]: Disable tests, to prevent cycle with python-asdf package.
[native-inputs]: Remove python-pytest and python-semantic-version.
[propagated-inputs]: Remove python-asdf. Add python-asdf-standard,
python-importlib-resources.
---
gnu/packages/astronomy.scm | 23 +++++++----------------
1 file changed, 7 insertions(+), 16 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index ca1740f852..a8c51338ac 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1990,28 +1990,19 @@ (define-public python-asdf-standard
(define python-asdf-transform-schemas
(package
(name "python-asdf-transform-schemas")
- (version "0.2.0")
+ (version "0.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "asdf_transform_schemas" version))
(sha256
- (base32 "1gmzd81hw4ppsvzrc91wcbjpcw9hhv9gavllv7nyi7qjb54c837g"))))
- (build-system python-build-system)
+ (base32 "1midgn575970p5cnsh9y6bz77fjr392b5nfxb3z0id6c49xzzwhc"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "-m" "pytest")))))))
- (native-inputs
- (list python-pytest
- python-semantic-version
- python-setuptools-scm))
- (propagated-inputs
- (list python-asdf))
+ ;; Dependencies cycle with python-asdf
+ (list #:tests? #f))
+ (native-inputs (list python-setuptools-scm))
+ (propagated-inputs (list python-asdf-standard python-importlib-resources))
(home-page "https://github.com/asdf-format/asdf-transform-schemas")
(synopsis "ASDF schemas for transforms")
(description
--
2.38.0
S
S
Sharlatan Hellseher wrote on 8 Nov 2022 00:06
[PATCH 6/9] gnu: python-asdf: Update to 2.13.0
(address . 59113@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221107230656.28187-6-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-asdf): Update to 2.13.0
[build-system]: Use pyproject-build-system
[native-inputs]: Add python-astropy, python-psutil, python-pytest,
python-pytest-doctestplus, python-pytest-openfiles,
python-pytest-remotedata, python-semantic-version
[propagated-inputs]: Add python-asdf-standard,
python-asdf-transform-schemas, python-asdf-unit-schemas
python-importlib-metadata, python-jsonschema-next, python-lz4.
Remove python-jsonschema.
---
gnu/packages/astronomy.scm | 26 +++++++++++++++++++-------
1 file changed, 19 insertions(+), 7 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a8c51338ac..a9bd687e66 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -55,6 +55,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
+ #:use-module (gnu packages python-compression)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
@@ -1916,26 +1917,37 @@ (define-public python-suntime
(define-public python-asdf
(package
(name "python-asdf")
- (version "2.8.3")
+ (version "2.13.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "asdf" version))
(sha256
- (base32 "0i4vq1hsympjgb1yvn4ql0gm8j1mki9ggmj03533kmg0nbzp03yy"))))
- (build-system python-build-system)
+ (base32 "1zixzv4n2fryaszsfchqh2nvp0gzvarhz03fc721yw6iafdadqij"))))
+ (build-system pyproject-build-system)
(arguments
;; NOTE: (Sharlatan-20211229T201059+0000): Tests depend on astropy and
;; gwcs, astropy gwcs depend on asdf. Disable circular dependence.
`(#:tests? #f))
(native-inputs
- (list python-setuptools-scm
+ (list python-astropy
+ python-packaging
+ python-psutil
+ python-pytest
+ python-pytest-doctestplus
+ python-pytest-openfiles
+ python-pytest-remotedata
python-semantic-version
- python-packaging))
+ python-setuptools-scm))
(propagated-inputs
- (list python-importlib-resources
- python-jsonschema
+ (list python-asdf-standard
+ python-asdf-transform-schemas
+ python-asdf-unit-schemas
+ python-importlib-metadata
+ python-importlib-resources
python-jmespath
+ python-jsonschema-next
+ python-lz4
python-numpy
python-pyyaml))
(home-page "https://github.com/asdf-format/asdf")
--
2.38.0
S
S
Sharlatan Hellseher wrote on 8 Nov 2022 00:06
[PATCH 7/9] gnu: python-asdf: Sync test disable comment
(address . 59113@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221107230656.28187-7-sharlatanus@gmail.com
* gnu/packages/astronomy (python-asdf): Sync comments emailing the
reason of disabled tests. python-astropy does not depends on python-asdf
any longer but test keep failing due to multiple reasons.
---
gnu/packages/astronomy.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a9bd687e66..cc46006865 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1926,8 +1926,11 @@ (define-public python-asdf
(base32 "1zixzv4n2fryaszsfchqh2nvp0gzvarhz03fc721yw6iafdadqij"))))
(build-system pyproject-build-system)
(arguments
- ;; NOTE: (Sharlatan-20211229T201059+0000): Tests depend on astropy and
- ;; gwcs, astropy gwcs depend on asdf. Disable circular dependence.
+ ;; FIXME: Tests fail a lot with
+ ;;
+ ;; ERROR - _pytest.pathlib.ImportPathMismatchError:
+ ;; ('asdf.conftest', '/gnu/sto...
+ ;;
`(#:tests? #f))
(native-inputs
(list python-astropy
--
2.38.0
S
S
Sharlatan Hellseher wrote on 8 Nov 2022 00:06
[PATCH 8/9] gnu: asdf-astropy: Update to 0.2.2
(address . 59113@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221107230656.28187-8-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-asdf-astropy): Update to 0.2.0.
[build-system]: Use pyproject-build-system.
[arguments]: Remove redundant.
---
gnu/packages/astronomy.scm | 20 +++++++++-----------
1 file changed, 9 insertions(+), 11 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index cc46006865..ead5c39f46 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2153,22 +2153,20 @@ (define python-asdf-unit-schemas
(define-public python-asdf-astropy
(package
(name "python-asdf-astropy")
- (version "0.1.2")
+ (version "0.2.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "asdf_astropy" version))
(sha256
- (base32 "0bzgah7gskvnz6jcrzipvzixv8k2jzjkskqwxngzwp4nxgjbcvi4"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "-m" "pytest")))))))
+ (base32 "1b0v4cl7xvly3x1k5k2rvc2l32jqgqp0iyf1j20fkvj450sx74f2"))))
+ (build-system pyproject-build-system)
+ ;; Starting from v0.2.0 the test suite contains massive set of unit tests.
+ ;; It takes 4+ minutes to pass all of them with a lot of warnings
+ ;; but tests are completed successfully in the end:
+ ;;
+ ;; 4065 passed, 8146 warnings in 271.78s (0:04:31)
+ ;;
(native-inputs
(list python-coverage
python-h5py
--
2.38.0
S
S
Sharlatan Hellseher wrote on 8 Nov 2022 00:06
[PATCH 9/9] gnu: gwcs: Fix build, update to 0.18.2
(address . 59113@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221107230656.28187-9-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-gwcs): Fix build and update to 0.18.2.
[build-system]: Use pyproject-build-system.
[arguments]: Remove redundant.
[native-inputs]: Use python-jsonschema-next over python-jsonschema to
fix tests failing to run due to python-asdf issue with low version of
---
gnu/packages/astronomy.scm | 16 ++++------------
1 file changed, 4 insertions(+), 12 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index ead5c39f46..b820494407 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2226,24 +2226,16 @@ (define python-asdf-wcs-schemas
(define-public python-gwcs
(package
(name "python-gwcs")
- (version "0.18.0")
+ (version "0.18.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "gwcs" version))
(sha256
- (base32 "194j49m8xjjzv9pp8cnj06igz8sdxb0nphyybcc7mhigw0f0kr30"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "-m" "pytest")))))))
+ (base32 "0v9qcq6zl74d6s882s6xmas144jfalvll6va8rvrxmvpx4vqjzhg"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-jsonschema
+ (list python-jsonschema-next
python-jmespath
python-pytest
python-pytest-doctestplus
--
2.38.0
S
S
Sharlatan Hellseher wrote on 18 Nov 2022 23:50
(address . 59113@debbugs.gnu.org)
CAO+9K5r827SXRcFi=R+BGvuTQP1az41X29KSBF9Trrt+7Xm39A@mail.gmail.com
Hi Guix team!
Just a gentle ping on the status of this issue. It solving build for a long
chain of packages which introduced during recent staging->merge.
Regards,
Oleg
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
C
C
Christopher Baines wrote on 20 Nov 2022 11:02
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59113@debbugs.gnu.org)
877czqx7mm.fsf@cbaines.net
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (3 lines)
> Just a gentle ping on the status of this issue. It solving build for a long
> chain of packages which introduced during recent staging->merge.

I did see this, although the information on [1] is a bit confused by the
protobuf-2 problem (that's now been fixed).


I think there is a significant change though, as it looks like while
this fixes things on x86_64-linux, python-asdf no longer builds on other
architectures due to dependencies failing to build, e.g. python-sgp4 on
aarch64-linux.

I'm still happy to look at merging these changes, but I thought I'd
raise the non x86_64-linux failures with you.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN5/CFfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeghRAAoowTF661z0US/Z9xLdUtYGr05C4wIQvp
3m/ddFeko8liaRJiVEpl3Kwl+ohZaQvwxjV2b3ux6kgJSYpCfwCRsy4p+2D7Vsld
1t6g/vklRZoFIOeWcLvexHI9qikq4plq6hb/lU94q+PbGvKhFnDCJWkGWAUNiIHp
6FiyJyHw0Jezo4y/GXakGvZ1vrCBteYre/Aqrjv79zVui8enf+5W+/1lQM4B3ZBj
BNLfc2YtmsXbArWrmMzs/5F1cq7+ajtj6Q5Ad9f4tkjYYiGUtRusbQPili0rvhfa
P8G6W4lUja6eK2HDJPhVxDPQJ/4aaOV0Y5YhCHgIT7mf6MhNqECggg2W2mUf2tJC
uMWDxa3GCNiDlbvMC2Wun5Faaq19C+el+8UA1D97XhhF6ynqm8rCUpl/3o3nbOPy
DZJonsgVr0dIaQ+G72XgabHl1MSWyKhXzp1Gf2oR3C9lkyjF9+3KyRH+N7NCTqPZ
btBSMYPHX5hMkGfzo8B6Esr0wHWDM0NrtQ8ZF6OTEuf8QFqXUfyv2Ix6FuaUktCH
G8SMU6z8vNvGovJZ0n9zkHmlslvkKX+T8XOkrnNFnGtz+GG8KYVxrkDkFCs/ENWN
VSxG7xhMbGu8d5s5QBByLEcOtWKLQ+osX/6rfHtt2aaldhlSrwj6wBx/06U5tQ2H
AisZLm3qPBA=
=hdKX
-----END PGP SIGNATURE-----

S
S
Sharlatan Hellseher wrote on 20 Nov 2022 19:10
(name . Christopher Baines)(address . mail@cbaines.net)(address . 59113@debbugs.gnu.org)
CAO+9K5qd8H5gTS9ZD9W-fTRVjXg+QE2hMvpQs+JWDsKOm4STWA@mail.gmail.com
Hi Chris,

Thanks for checking it.

If it's posible to merge the chain for x86_64 it would be nice to have at
least one working architecture. Meanwhile I'll check builds for others and
open upstream issues if required.


Regards,
Oleg

On Sun, 20 Nov 2022, 10:06 Christopher Baines, <mail@cbaines.net> wrote:

Toggle quote (22 lines)
>
> Sharlatan Hellseher <sharlatanus@gmail.com> writes:
>
> > Just a gentle ping on the status of this issue. It solving build for a
> long
> > chain of packages which introduced during recent staging->merge.
>
> I did see this, although the information on [1] is a bit confused by the
> protobuf-2 problem (that's now been fixed).
>
> 1: https://qa.guix.gnu.org/issue/59113
>
> I think there is a significant change though, as it looks like while
> this fixes things on x86_64-linux, python-asdf no longer builds on other
> architectures due to dependencies failing to build, e.g. python-sgp4 on
> aarch64-linux.
>
> I'm still happy to look at merging these changes, but I thought I'd
> raise the non x86_64-linux failures with you.
>
> Chris
>
Attachment: file
S
S
Sharlatan Hellseher wrote on 20 Nov 2022 22:18
(name . Christopher Baines)(address . mail@cbaines.net)(address . 59113@debbugs.gnu.org)
CAO+9K5rG3bzFhYY5GDiPG3SxAtnq0VToyRFEegHv_2xTegphWg@mail.gmail.com
Hi,

I've checked current version of python-asdf@2.8.3 and it has no
python-sgp4 as inputs, but python-astropy does which might affect more
larger scale of packages.

Regards,
Oleg

On Sun, 20 Nov 2022 at 18:10, Sharlatan Hellseher <sharlatanus@gmail.com> wrote:
Toggle quote (36 lines)
>
> Hi Chris,
>
> Thanks for checking it.
>
> If it's posible to merge the chain for x86_64 it would be nice to have at least one working architecture. Meanwhile I'll check builds for others and open upstream issues if required.
>
>
> Regards,
> Oleg
>
> On Sun, 20 Nov 2022, 10:06 Christopher Baines, <mail@cbaines.net> wrote:
>>
>>
>> Sharlatan Hellseher <sharlatanus@gmail.com> writes:
>>
>> > Just a gentle ping on the status of this issue. It solving build for a long
>> > chain of packages which introduced during recent staging->merge.
>>
>> I did see this, although the information on [1] is a bit confused by the
>> protobuf-2 problem (that's now been fixed).
>>
>> 1: https://qa.guix.gnu.org/issue/59113
>>
>> I think there is a significant change though, as it looks like while
>> this fixes things on x86_64-linux, python-asdf no longer builds on other
>> architectures due to dependencies failing to build, e.g. python-sgp4 on
>> aarch64-linux.
>>
>> I'm still happy to look at merging these changes, but I thought I'd
>> raise the non x86_64-linux failures with you.
>>
>> Chris



--

… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
S
S
Sharlatan Hellseher wrote on 20 Nov 2022 23:42
(address . 59113@debbugs.gnu.org)
CAO+9K5qm4hCKjSOqfS8zW_Y=iDZ0pS3OEoddNC66VM9A+8Au-g@mail.gmail.com
Hi,
It might be a known issue in upstream:
I'll try to check what could be wrong.
Regards,
Oleg
On Sun, 20 Nov 2022 at 21:18, Sharlatan Hellseher <sharlatanus@gmail.com> wrote:
Toggle quote (52 lines)
>
> Hi,
>
> I've checked current version of python-asdf@2.8.3 and it has no
> python-sgp4 as inputs, but python-astropy does which might affect more
> larger scale of packages.
>
> Regards,
> Oleg
>
> On Sun, 20 Nov 2022 at 18:10, Sharlatan Hellseher <sharlatanus@gmail.com> wrote:
> >
> > Hi Chris,
> >
> > Thanks for checking it.
> >
> > If it's posible to merge the chain for x86_64 it would be nice to have at least one working architecture. Meanwhile I'll check builds for others and open upstream issues if required.
> >
> >
> > Regards,
> > Oleg
> >
> > On Sun, 20 Nov 2022, 10:06 Christopher Baines, <mail@cbaines.net> wrote:
> >>
> >>
> >> Sharlatan Hellseher <sharlatanus@gmail.com> writes:
> >>
> >> > Just a gentle ping on the status of this issue. It solving build for a long
> >> > chain of packages which introduced during recent staging->merge.
> >>
> >> I did see this, although the information on [1] is a bit confused by the
> >> protobuf-2 problem (that's now been fixed).
> >>
> >> 1: https://qa.guix.gnu.org/issue/59113
> >>
> >> I think there is a significant change though, as it looks like while
> >> this fixes things on x86_64-linux, python-asdf no longer builds on other
> >> architectures due to dependencies failing to build, e.g. python-sgp4 on
> >> aarch64-linux.
> >>
> >> I'm still happy to look at merging these changes, but I thought I'd
> >> raise the non x86_64-linux failures with you.
> >>
> >> Chris
>
>
>
> --
>
> … ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
> ????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
> ?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
C
C
Christopher Baines wrote on 21 Nov 2022 15:27
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59113-done@debbugs.gnu.org)
871qpwv0ti.fsf@cbaines.net
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (8 lines)
> Hi Chris,
>
> Thanks for checking it.
>
> If it's posible to merge the chain for x86_64 it would be nice to have
> at least one working architecture. Meanwhile I'll check builds for
> others and open upstream issues if required.

Sure, I've pushed to master now as
4d05c5fa57fe768e4d2ed760fa3aee05d72becb5 with a few minor changes.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN7ixlfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcsRxAAi59t3mq9g9a8XhN233kxJieiJhSaHZJ5
MO9xYo1+giraW1oHQDz1G50l6stSMRzc2trep8UWq56Pwe4bFdMky38Q/q0NH1dt
5zwQvdKUpb1B6vHxgI+sAtPTB9Mxo3STCva4Ydhl4VkIFDpIlUpLw6VtqvLLLJ7Q
v6TEpfXqkBBuuVNqXiwBjPmSwzBZRXcke7sfzPya4DLdCizV5OWUEZEhud7vzeIm
SMIp8CS1c/OvVjx/eSVoqzbV1htvZ4AwPbTxWieBvd8vTqIuBC7qFWZWwlo7SN3e
kLdUlg0Akk0jZ4L2eXrqvHjK6dUpJQljxa0T0/USalHr+CVLsq3YCjRBcuqsXN2r
Ohy8I2LbV+qMc3iIySM2ahhgOLyOE+bKgs4EeCUxQZ3Iqcn2a3GYKoTm3CGbfP6m
lux17wBfl1uoZat2y3WqoouHoTH3JP/V6kDCcSy0/6DEzWyXnL8jQO7d9rzB88Er
14c8juLmV1Gir4enCrWZqVa2+fCG5KPBmkNALEHYS6jBJoRI5dd7Qs1uVaT/20Sm
YrloT9UjQJKn3YaJxgzTvVWDEucp0ADZ2zOT+TJ0ZlwT4LEy5dAwGQlB6w2kzoCN
2OWSg6S/JGo+55KpAu4ZY+G4UXoTLdvegcuYqfephvYqDKi+5xr3BX6Ob0VdeNLV
huFhpr2Cf6Q=
=Jp/s
-----END PGP SIGNATURE-----

Closed
?