[PATCH] Add nemo and dependencies

  • Done
  • quality assurance status badge
Details
2 participants
  • Florian
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Florian
Severity
normal
F
F
Florian wrote on 7 Nov 2022 15:53
[PATCH] Add nemo and dependencies
(address . guix-patches@gnu.org)
87o7ti7r4x.fsf@posteo.net

F
F
florhizome wrote on 13 Nov 2022 20:21
[PATCH 2/3] gnu: Add xapp
(address . 59105@debbugs.gnu.org)(name . florhizome)(address . florhizome@posteo.net)
b7c00be7c82e9b49e114e7263b24b0451074facc.1668366634.git.florhizome@posteo.net
From: florhizome <florhizome@posteo.net>

* gnu/packages/cinnamon.scm (xapp): New variable.
---
gnu/packages/cinnamon.scm | 60 +++++++++++++++++++++++++++++++++++++++
1 file changed, 60 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/cinnamon.scm b/gnu/packages/cinnamon.scm
index 0087a41839..8af2075596 100644
--- a/gnu/packages/cinnamon.scm
+++ b/gnu/packages/cinnamon.scm
@@ -83,3 +83,63 @@ (define-public cinnamon-desktop
as well as some desktop-wide documents.")
(license (list license:gpl2+ license:lgpl2.0+
license:expat)))) ;display-name.c , edid-parse.c
+
+(define-public xapp
+ (package
+ (name "xapp")
+ (version "2.2.15")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linuxmint/xapp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rjlrbaf4c02viwbp1vxhh4nsv9zbvlsmrvry3af9grz0rfv3xsz"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:glib-or-gtk? #t
+ #:configure-flags
+ #~(list (string-append "-Dpy-overrides-dir="
+ #$(this-package-input "python")
+ "/lib/python3.9/site-packages/gi/overrides"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'patch-source-shebangs 'fix-build
+ (lambda _
+ (substitute*
+ "./libxapp/meson.build"
+ (("gtk3_dep\\.get_pkgconfig_variable\\('libdir'\\)")
+ (string-append "'" #$output "/lib'")))
+ (substitute*
+ "./pygobject/meson.build"
+ (("install_dir: override_dir,")
+ (string-append
+ "install_dir: '" #$output
+ "/lib/python3.9/site-packages/gi/overrides',")))
+ #t)))))
+ (inputs
+ (list atk
+ glib
+ gtk+
+ gnome-menus
+ libdbusmenu
+ libgnomekbd
+ python
+ python-pygobject))
+ (native-inputs
+ (list gettext-minimal
+ (list glib "bin")
+ gobject-introspection
+ libxml2
+ pkg-config
+ python
+ vala))
+ (propagated-inputs (list libgnomekbd))
+ (home-page "https://github.com/linuxmint/xapp")
+ (synopsis "Libraries and common resources of the Mint project")
+ (description "This project gathers the components which are common to the
+ projects of the Linux Mint project.")
+ (license license:expat)))
+
--
2.38.1
F
F
florhizome wrote on 13 Nov 2022 20:21
[PATCH 1/3] gnu: cinnamon: upgrade cinnamon-desktop
(address . 59105@debbugs.gnu.org)(name . florhizome)(address . florhizome@posteo.net)
79af977f96c3628451bc191a52529a6e354e5e5c.1668366634.git.florhizome@posteo.net
From: florhizome <florhizome@posteo.net>

Updates cinnamon-desktop to new version and meson-build-system, adds alsa support, moves gobject-introspection to native-inputs, removes python-2

* gnu/packages/cinnamon.scm (cinnamon-desktop): Upgrade package.
[arguments] configure-flags: enable alsa-support
[inputs] remove python-2, remove gobject-introspection, add libext, alsa-lib
[native-inputs] remove gnu-build-system related packages, add gobject-introspection

---
gnu/packages/cinnamon.scm | 37 +++++++++++++++++++++----------------
1 file changed, 21 insertions(+), 16 deletions(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/cinnamon.scm b/gnu/packages/cinnamon.scm
index fe33e797e4..0087a41839 100644
--- a/gnu/packages/cinnamon.scm
+++ b/gnu/packages/cinnamon.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022 florhizome <florhizome@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,9 +23,12 @@ (define-module (gnu packages cinnamon)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix utils)
+ #:use-module (guix build utils)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages freedesktop)
@@ -32,44 +36,45 @@ (define-module (gnu packages cinnamon)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages photo)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
(define-public cinnamon-desktop
(package
(name "cinnamon-desktop")
- (version "3.4.2")
- (source (origin
- (method git-fetch)
+ (version "5.4.2")
+ (source
+ (origin
+ (method git-fetch)
(uri (git-reference
(url "https://github.com/linuxmint/cinnamon-desktop")
(commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "18mjy80ly9361npjhxpm3n0pkmrwviaqr2kixjb7hyxa6kzzh5xw"))))
- (build-system gnu-build-system)
- ;; TODO: package 'libgsystem'.
+ (sha256
+ (base32 "03yfh1fhcs9g4qxczq1k2fi0c9354ryapvhg24210scgds4ljkjk"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:glib-or-gtk? #t
+ #:configure-flags #~(list "-Dalsa=true")))
(inputs
(list accountsservice
+ alsa-lib
gtk+
glib
- gobject-introspection
gnome-common
libxkbfile
libxrandr
- python-2
+ libxext
pulseaudio
xkeyboard-config))
(native-inputs
- (list autoconf
- automake
+ (list gobject-introspection
+ (list glib "bin")
gettext-minimal
- `(,glib "bin") ; glib-gettextize
- intltool
- libtool
pkg-config))
(home-page "https://github.com/linuxmint/cinnamon-desktop/")
(synopsis "Library for the Cinnamon Desktop")
--
2.38.1
F
F
florhizome wrote on 13 Nov 2022 20:21
[PATCH 3/3] gnu: Add nemo
(address . 59105@debbugs.gnu.org)(name . florhizome)(address . florhizome@posteo.net)
25721b7688e974e66a7414645177689faf7a6fa4.1668366634.git.florhizome@posteo.net
From: florhizome <florhizome@posteo.net>

* gnu/packages/cinnamon.scm (nemo): New variable.
---
gnu/packages/cinnamon.scm | 61 +++++++++++++++++++++++++++++++++++++++
1 file changed, 61 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/cinnamon.scm b/gnu/packages/cinnamon.scm
index 8af2075596..74bf125820 100644
--- a/gnu/packages/cinnamon.scm
+++ b/gnu/packages/cinnamon.scm
@@ -143,3 +143,64 @@ (define-public xapp
projects of the Linux Mint project.")
(license license:expat)))
+(define-public nemo
+ (package
+ (name "nemo")
+ (version "5.4.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/linuxmint/nemo")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1r3zjkpmisdi54kkq6fvaslagzpbbz4swjlali90lwsfbb9cwykz"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:glib-or-gtk? #t
+ #:tests? #f ;tests stall
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'patch-source-shebangs 'adjust-prefix
+ (lambda _
+ (substitute*
+ (find-files "meson.build")
+ (("'data_dir")
+ (string-append "'" #$output "/share")))) #t)
+ (add-before 'check 'pre-check
+ (lambda _
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ (setenv "HOME" "/tmp") ;some tests require a writable HOME
+ (setenv "XDG_DATA_DIRS"
+ (string-append (getenv "XDG_DATA_DIRS")
+ ":" #$output "/share")))))))
+ (inputs
+ (list atk
+ cinnamon-desktop
+ libnotify
+ libgsf
+ libx11
+ libxml2
+ gtk+
+ gsettings-desktop-schemas
+ libxkbfile
+ libexif
+ exempi
+ xapp
+ xkeyboard-config))
+ (native-inputs
+ (list pkg-config
+ (list gtk+ "bin")
+ gettext-minimal
+ intltool
+ (list glib "bin")
+ gobject-introspection
+ xorg-server-for-tests))
+ (home-page "https://github.com/linuxmint/nemo")
+ (synopsis "File browser for Cinnamon")
+ (description "Nemo is the file manager for the Cinnamon desktop
+ environment.")
+ (license license:expat)))
--
2.38.1
N
N
Nicolas Goaziou wrote on 22 Apr 2023 12:01
Re: [bug#59105] [PATCH 1/3] gnu: cinnamon: upgrade cinnamon-desktop
(address . florhizome@posteo.net)(address . 59105-done@debbugs.gnu.org)
87edoc2q2f.fsf@nicolasgoaziou.fr
Hello,

florhizome@posteo.net writes:

Toggle quote (10 lines)
> From: florhizome <florhizome@posteo.net>
>
> Updates cinnamon-desktop to new version and meson-build-system, adds alsa support, moves gobject-introspection to native-inputs, removes python-2
>
> * gnu/packages/cinnamon.scm (cinnamon-desktop): Upgrade package.
> [arguments] configure-flags: enable alsa-support
> [inputs] remove python-2, remove gobject-introspection, add libext, alsa-lib
> [native-inputs] remove gnu-build-system related packages, add
> gobject-introspection

Thank you. I updated cinnamon-destkop to 5.6.2, dropped your second
patch as libxapp is already provided in Guix, updated nemo to 5.6.5 and
applied your patch set.

Regards,
--
Nicolas Goaziou
Closed
?