[PATCH 2/2] gnu: Add mogan.

  • Done
  • quality assurance status badge
Details
2 participants
  • Zhu Zihao
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Zhu Zihao
Severity
normal
Z
Z
Zhu Zihao wrote on 7 Nov 2022 11:58
(address . guix-patches@gnu.org)(name . Zhu Zihao)(address . all_but_last@163.com)
20221107105827.10327-2-all_but_last@163.com
* gnu/packages/text-editors.scm (mogan): New variable.
---
gnu/packages/text-editors.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index ca502994c5..cddbf06c90 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -59,6 +59,7 @@ (define-module (gnu packages text-editors)
#:use-module (gnu packages code)
#:use-module (gnu packages cpp)
#:use-module (gnu packages crates-io)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
@@ -895,6 +896,39 @@ (define-public texmacs
(license license:gpl3+)
(home-page "https://www.texmacs.org/tmweb/home/welcome.en.html")))
+(define-public mogan
+ (package
+ (inherit texmacs)
+ (name "mogan")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/XmacsLabs/mogan")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "04wz6xmimjv2l6baxgzm8vyq5grg102m3l4wq8i6bglv529yp4ff"))))
+ (inputs
+ (modify-inputs (package-inputs texmacs)
+ ;; Replaced by S7 scheme
+ ;; TODO: Maybe unbundle S7
+ (delete "guile")
+ (prepend curl)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texmacs)
+ ((#:phases orig)
+ #~(modify-phases #$orig
+ ;; The non-deterministic compression issue is solved in Mogan.
+ (delete 'gzip-flags)))))
+ (synopsis "Structural editor delivered by Xmacs Labs")
+ (description
+ "Mogan is a fork of GNU TeXmacs created by Xmacs Labs. Its goal is
+make everyone to enjoy it fluently and develop new feature for everyone to learn
+and create science and technology.")
+ (license license:gpl3+)
+ (home-page "https://gitee.com/XmacsLabs/mogan")))
+
(define-public textpieces
(package
(name "textpieces")
--
2.38.0
N
N
Nicolas Goaziou wrote on 8 Nov 2022 22:01
(name . Zhu Zihao)(address . all_but_last@163.com)(address . 59102@debbugs.gnu.org)
87iljpkvoh.fsf@nicolasgoaziou.fr
Hello,

Zhu Zihao <all_but_last@163.com> writes:

Toggle quote (2 lines)
> * gnu/packages/text-editors.scm (mogan): New variable.

Thank you. I applied the first patch of the set. Some comments about
this one follow.

Toggle quote (7 lines)
> + (arguments
> + (substitute-keyword-arguments (package-arguments texmacs)
> + ((#:phases orig)
> + #~(modify-phases #$orig
> + ;; The non-deterministic compression issue is solved in Mogan.
> + (delete 'gzip-flags)))))

Unlike TeXmacs, Mogan ships with tests. Could you also run them?

Toggle quote (2 lines)
> + (synopsis "Structural editor delivered by Xmacs Labs")

I don't think the ads is warranted here. Maybe "Scientific text editor"
is better.

Toggle quote (5 lines)
> + (description
> + "Mogan is a fork of GNU TeXmacs created by Xmacs Labs. Its goal is
> +make everyone to enjoy it fluently and develop new feature for everyone to learn
> +and create science and technology.")

This description is not very descriptive. I don't have any good idea,
the repository is not very helpful for that matter. At a minimum,
I suggest to remove "created by Xmacs Labs" and separate sentences with
two spaces. The second should also be replaced.

Toggle quote (2 lines)
Could you move home-page above synopsis?

Regards,
--
Nicolas Goaziou
Z
Z
Zhu Zihao wrote on 23 Nov 2022 11:42
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 59102@debbugs.gnu.org)
86leo2t0ee.fsf@163.com
Sorry for the late reply! I missed this mail in my mailbox :(


Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (2 lines)
> Unlike TeXmacs, Mogan ships with tests. Could you also run them?

The "tests" folder in mogan is inherited from TeXmacs, I think it's OK
to not run them if we don't run the test of TeXmacs.

Toggle quote (20 lines)
>
>> + (synopsis "Structural editor delivered by Xmacs Labs")
>
> I don't think the ads is warranted here. Maybe "Scientific text editor"
> is better.
>
>> + (description
>> + "Mogan is a fork of GNU TeXmacs created by Xmacs Labs. Its goal is
>> +make everyone to enjoy it fluently and develop new feature for everyone to learn
>> +and create science and technology.")
>
> This description is not very descriptive. I don't have any good idea,
> the repository is not very helpful for that matter. At a minimum,
> I suggest to remove "created by Xmacs Labs" and separate sentences with
> two spaces. The second should also be replaced.
>
>> + (home-page "https://gitee.com/XmacsLabs/mogan")))
>
> Could you move home-page above synopsis?

fixed in new patch.

I also make Mogan use qt-build-system because Mogan cannot find the
breeze icon without XDG environment variables wrapping.
-----BEGIN PGP SIGNATURE-----

iIsEARYIADMWIQT4UAIrVkIEZilSHr2K2nJqP6LM8gUCY335uRUcYWxsX2J1dF9s
YXN0QDE2My5jb20ACgkQitpyaj+izPJQZQEA2glbvhtFA12VU+LWi+abw8ttK5qP
bsH+68LqsdAP1ykBAIen+Sbce35LkuI7nySjMiQcFGwdC0rk6Daeah8shtYB
=FoPi
-----END PGP SIGNATURE-----

From c7d14125e93c497a15c27fb4ac90e1d33efc698c Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 14 May 2022 22:19:06 +0800
Subject: [PATCH] gnu: Add mogan.

* gnu/packages/text-editors.scm (mogan): New variable.
---
gnu/packages/text-editors.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index ed77113726..57341cd198 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -49,6 +49,7 @@ (define-module (gnu packages text-editors)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
+ #:use-module (guix build-system qt)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages aspell)
@@ -59,6 +60,7 @@ (define-module (gnu packages text-editors)
#:use-module (gnu packages code)
#:use-module (gnu packages cpp)
#:use-module (gnu packages crates-io)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
@@ -895,6 +897,39 @@ (define-public texmacs
(license license:gpl3+)
(home-page "https://www.texmacs.org/tmweb/home/welcome.en.html")))
+(define-public mogan
+ (package
+ (inherit texmacs)
+ (name "mogan")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/XmacsLabs/mogan")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04wz6xmimjv2l6baxgzm8vyq5grg102m3l4wq8i6bglv529yp4ff"))))
+ (build-system qt-build-system)
+ (inputs
+ (modify-inputs (package-inputs texmacs)
+ ;; Replaced by S7 scheme
+ ;; TODO: Maybe unbundle S7
+ (delete "guile")
+ (prepend curl)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texmacs)
+ ((#:phases orig)
+ #~(modify-phases #$orig
+ ;; The non-deterministic compression issue is solved in Mogan.
+ (delete 'gzip-flags)))))
+ (home-page "https://github.com/XmacsLabs/mogan")
+ (synopsis "Scientific structural text editor")
+ (description
+ "Mogan is a scientific structural text editor, a fork of GNU TeXmacs.")
+ (license license:gpl3+)))
+
(define-public textpieces
(package
(name "textpieces")
--
2.38.1
--
Retrieve my PGP public key:

gpg --recv-keys B3EBC086AB0EBC0F45E0B4D433DB374BCEE4D9DC

Zihao
N
N
Nicolas Goaziou wrote on 26 Nov 2022 12:03
(name . Zhu Zihao)(address . all_but_last@163.com)(address . 59102-done@debbugs.gnu.org)
87h6ymnfk5.fsf@nicolasgoaziou.fr
Hello,

Zhu Zihao <all_but_last@163.com> writes:

Toggle quote (2 lines)
> Sorry for the late reply! I missed this mail in my mailbox :(

No problem.

Toggle quote (3 lines)
> The "tests" folder in mogan is inherited from TeXmacs, I think it's OK
> to not run them if we don't run the test of TeXmacs.

Fair enough.

Toggle quote (5 lines)
> fixed in new patch.
>
> I also make Mogan use qt-build-system because Mogan cannot find the
> breeze icon without XDG environment variables wrapping.

OK. Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59102@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59102
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch