[PATCH] build-system/linux-module: Add #:source-directory to linux-module-build-cross.

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 2 years ago
(address . guix-patches@gnu.org)
20221106091317.27635-1-mail@cbaines.net
Otherwise computing cross-compilation derivations for packages (e.g. xpadneo)
using the #:source-directory argument fails with this error:

Unrecognized keyword: #:source-directory

* guix/build-system/linux-module.scm (linux-module-build-cross): Support
#:source-directory.
---
guix/build-system/linux-module.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (22 lines)
diff --git a/guix/build-system/linux-module.scm b/guix/build-system/linux-module.scm
index 94a293da13..d6c369d65d 100644
--- a/guix/build-system/linux-module.scm
+++ b/guix/build-system/linux-module.scm
@@ -210,6 +210,7 @@ (define* (linux-module-build-cross
(tests? #f)
(phases '%standard-phases)
(system (%current-system))
+ (source-directory ".")
(substitutable? #t)
(imported-modules
%linux-module-build-system-modules)
@@ -229,6 +230,7 @@ (define %build-target-inputs
(linux-module-build #:name #$name
#:source #+source
+ #:source-directory #$source-directory
#:system #$system
#:target #$target
#:arch #$(system->arch (or target system))
--
2.37.3
Christopher Baines wrote 2 years ago
(name . Christopher Baines)(address . mail@cbaines.net)
87mt92o7nr.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (11 lines)
> Otherwise computing cross-compilation derivations for packages (e.g. xpadneo)
> using the #:source-directory argument fails with this error:
>
> Unrecognized keyword: #:source-directory
>
> * guix/build-system/linux-module.scm (linux-module-build-cross): Support
> #:source-directory.
> ---
> guix/build-system/linux-module.scm | 2 ++
> 1 file changed, 2 insertions(+)

I've gone ahead and pushed this as
da21c5d45f418103bb39061787c90920ee3f36d8.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNpZDhfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcqjQ//ZBd93EtPBGyMAVHPFDNnK+Y3CCbF6r4C
N8FqJLbL3/k29K6i7OO55Bboo+JZ7JHVRo+ifCk6u/dFw7zvbzHD69RTRuMA5/Mx
ghwurBlGT0r99i+gZozSryDKPz7PiwHtOneLHW2wv6RdehsDf8NjkJ57Ob67KgPI
4UNgtR6N3odMitgpyVgom6XdHEi6PrHktQFAzNVL6FbFl3m89v4DajU/L0b3Sctc
msQ0cszxhNdwX/sDCluzttaH+9SSR4hp98gb1zOS3UM502pa55TqvVsyGj4abDO5
0xHXIGJuZpSPeLAA5p5i4fWQ8DPzH7MPiMEDkln7OWBFMo4RcAa+ggB+o7KlgNuE
OyQXVyJaWnUYD+b8nchPqxvS1a0xCdSBhGrb6V5Mtl92wCf0Fsdw/IrAJJ5kc0z9
sIlIAZlz1ay2EZru4WTzx0FVCQ51AMzBXr428igRdsy6IfMQplNxKipGAI2qHap6
UgBRMjbfsbsNptiOF4t0gjQqc6xeUGdKOl7ICgyo/FbUuJVddwAaolA2OSquDZp5
2SgFxS9urbGYqgsJ6vOXIhn6ERSjxqyw8y7bcJHIDF7xQeID7b8ZpMfl5LKeftRo
fsCXNLWhhDK2BcIX8DXn/qABDRlmbvt9mlKwhGQRb0KbeIHL/IoinHKbBEhGowvI
t6JrLFUMH6U=
=H0TV
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 59074@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59074
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help