[PATCH] gnu: Add cl-seria.

  • Open
  • quality assurance status badge
Details
2 participants
  • jgart
  • Christopher Baines
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 5 Nov 2022 21:25
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20221105202541.9438-1-jgart@dismail.de
* gnu/packages/lisp-xyz.scm (cl-seria, ecl-seria, sbcl-seria): New variables.
---
gnu/packages/lisp-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 01dcf4f46d..676db6308d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -24666,6 +24666,38 @@ (define-public cl-smug
(define-public ecl-smug
(sbcl-package->ecl-package sbcl-smug))
+(define-public sbcl-seria
+ (let ((commit "2bba04dc6abdc0b85a511cae9c460942e2ad305a")
+ (revision "0"))
+ (package
+ (name "sbcl-seria")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Izaakwltn/seria")
+ (commit commit)))
+ (file-name (git-file-name "cl-seria" version))
+ (sha256
+ (base32 "04igpj7y4g5qi4f6fa0shkmywlg1zvhlhhzwy83nni0xxb4xibm5"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs (list sbcl-alexandria))
+ (arguments
+ `(#:tests? #f)) ; There are no tests.
+ (synopsis "Module for exploring twelve-tone serialism")
+ (description
+"@code{cl-seria} provides a module for exploring twelve-tone serialism
+in Common Lisp.")
+ (home-page "https://github.com/Izaakwltn/seria/")
+ (license license:expat))))
+
+(define-public cl-seria
+ (sbcl-package->cl-source-package sbcl-seria))
+
+(define-public ecl-seria
+ (sbcl-package->ecl-package sbcl-seria))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
--
2.38.1
J
C
C
Christopher Baines wrote on 17 Nov 2022 12:27
tag 59060 moreinfo
(address . control@debbugs.gnu.org)
8735ahstwb.fsf@cbaines.net
tags 59060 + moreinfo
quit
?