[PATCH] gnu: terminator: Renamed to "gnome-terminator" and update to 2.1.2

  • Done
  • quality assurance status badge
Details
4 participants
  • Andy Tai
  • ???
  • Andy Tai
  • zimoun
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 5 Nov 2022 20:45
(address . guix-patches@gnu.org)
CAJsg1E_OjaReYXyX_VvgCjQaJoi8w0-2AszFQYGdSyHJi4ecXw@mail.gmail.com

From f163a30edb7d0ed40c0e27eae4ee403c1970c091 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Fri, 4 Nov 2022 22:58:08 -0700
Subject: [PATCH] gnu: terminator: Renamed to "gnome-terminator" and update to
2.1.2
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/gnome.scm (gnome-terminator): Rename variable from
(terminator(: …this. Redefine using DEPRECATED-PACKAGE.
Update to 2.1.2
---
gnu/packages/gnome.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1246ac22b3..59f1e72679 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11779,18 +11779,18 @@ (define-public gthumb
advanced image management tool")
(license license:gpl2+)))
-(define-public terminator
+(define-public gnome-terminator
(package
- (name "terminator")
- (version "2.1.1")
+ (name "gnome-terminator")
+ (version "2.1.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/gnome-terminator/terminator/"
"releases/download/v" version "/"
- name "-" version ".tar.gz"))
+ "terminator" "-" version ".tar.gz"))
(sha256
- (base32 "0xdgmam7ghnxw6g38a4gjw3kk3rhga8c66lns18k928jlr9fmddw"))))
+ (base32 "10shpn8id7z43d4dpx16x76mgxnk4mr976j5cg28icjiiaidyfc2"))))
(build-system python-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -11852,6 +11852,9 @@ (define-public terminator
tabs, and it supports drag and drop re-ordering of terminals.")
(license license:gpl2)))
+(define-public terminator
+ (deprecated-package "terminator" gnome-terminator))
+
(define-public libhandy
(package
(name "libhandy")
--
2.38.0
A
A
Andy Tai wrote on 23 Dec 2022 07:43
ping
(address . 59059@debbugs.gnu.org)
CAJsg1E-ubjxcQQZEn8575-A=qtVjH5yf5mHpiocqkNTSsBKDbA@mail.gmail.com

Z
Z
zimoun wrote on 11 Jan 2023 23:09
Re: [bug#59059] [PATCH] gnu: terminator: Renamed to "gnome-terminator" and update to 2.1.2
86zgao206c.fsf@gmail.com
Hi,

This patch LGTM except two minor comments.

On Sat, 05 Nov 2022 at 12:45, Andy Tai <atai@atai.org> wrote:

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (gnome-terminator): Rename variable from
> (terminator(: …this. Redefine using DEPRECATED-PACKAGE.
--^
Here

Toggle quote (4 lines)
> +(define-public terminator
> + (deprecated-package "terminator" gnome-terminator))
> +

Incorrect indentation. Well, I noticed that it was also the case for
other of your submissions. Maybe, give a look at your editor settings –
if it is Emacs, the repository contains .dir-locals.el which implements
the convention.


Cheers,
simon
A
A
A
Andy Tai wrote on 17 Jan 2023 20:59
ping
(address . 59059@debbugs.gnu.org)
CAJsg1E8XHmKrLceMh8OcPzfLkopvr__+2exh_jVD7_uPzTYDPA@mail.gmail.com

A
A
Andy Tai wrote on 28 Jan 2023 10:25
[PATCH v2] gnu: terminator: Renamed to "gnome-terminator" and update to 2.1.2
(address . 59059@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230128092503.23970-1-atai@atai.org
* gnu/packages/gnome.scm (gnome-terminator): Rename variable from
(terminator): …this. Redefine using DEPRECATED-PACKAGE.
Update to 2.1.2
---
gnu/packages/gnome.scm | 123 ++++++++++++++++++++++-------------------
1 file changed, 67 insertions(+), 56 deletions(-)

Toggle diff (153 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index de5b5df450..1d64b106c4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11929,41 +11929,45 @@ (define-public gthumb
advanced image management tool")
(license license:gpl2+)))
-(define-public terminator
+(define-public gnome-terminator
(package
- (name "terminator")
- (version "2.1.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/gnome-terminator/terminator/"
- "releases/download/v" version "/"
- name "-" version ".tar.gz"))
- (sha256
- (base32 "0xdgmam7ghnxw6g38a4gjw3kk3rhga8c66lns18k928jlr9fmddw"))))
+ (name "gnome-terminator")
+ (version "2.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/gnome-terminator/terminator/"
+ "releases/download/v"
+ version
+ "/"
+ "terminator"
+ "-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "10shpn8id7z43d4dpx16x76mgxnk4mr976j5cg28icjiiaidyfc2"))))
(build-system python-build-system)
- (native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin") ; for glib-compile-resources
- ("gobject-introspection" ,gobject-introspection)
- ("intltool" ,intltool)
- ("pkg-config" ,pkg-config)
- ("python-psutil" ,python-psutil)
- ("python-pytest-runner" ,python-pytest-runner)
- ("python-pytest" ,python-pytest)))
- (inputs
- `(("cairo" ,cairo)
- ("dbus-glib" ,dbus-glib)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("gtk+" ,gtk+)
- ("python" ,python-wrapper)
- ("python-dbus" ,python-dbus)
- ("python-notify2" ,python-notify2)
- ("python-pycairo" ,python-pycairo)
- ("python-pygobject" ,python-pygobject)
- ("vte" ,vte)))
- (propagated-inputs
- (list python-configobj))
+ (native-inputs (list gettext-minimal
+ `(,glib "bin") ;for glib-compile-resources
+ gobject-introspection
+ intltool
+ pkg-config
+ python-psutil
+ python-pytest-runner
+ python-pytest))
+ (inputs (list bash-minimal
+ cairo
+ dbus-glib
+ gsettings-desktop-schemas
+ gtk+
+ python-wrapper
+ python-dbus
+ python-notify2
+ python-pycairo
+ python-pygobject
+ vte))
+ (propagated-inputs (list python-configobj))
(arguments
;; One test out of 28 fails due to dbus-python and python-notify; skip
;; tests.
@@ -11971,30 +11975,34 @@ (define-public terminator
#:imported-modules ((guix build glib-or-gtk-build-system)
,@%python-build-system-modules)
#:modules ((guix build python-build-system)
- ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
+ ((guix build glib-or-gtk-build-system)
+ #:prefix glib-or-gtk:)
(guix build utils))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'handle-dbus-python
- (lambda _
- ;; python-dbus cannot be found but it's really there. See
- ;; https://github.com/SpotlightKid/jack-select/issues/2
- (substitute* "setup.py"
- (("'dbus-python',") ""))))
- (add-after 'install 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((prog (string-append (assoc-ref outputs "out")
- "/bin/terminator"))
- (pylib (string-append (assoc-ref outputs "out")
- "/lib/python"
- ,(version-major+minor
- (package-version python))
- "/site-packages")))
- (wrap-program prog
- `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH") ,pylib))
- `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))
- (add-after 'wrap-program 'glib-or-gtk-wrap
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'handle-dbus-python
+ (lambda _
+ ;; python-dbus cannot be found but it's really there. See
+ ;; https://github.com/SpotlightKid/jack-select/issues/2
+ (substitute* "setup.py"
+ (("'dbus-python',")
+ ""))))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/terminator"))
+ (pylib (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor (package-version
+ python))
+ "/site-packages")))
+ (wrap-program prog
+ `("GUIX_PYTHONPATH" =
+ (,(getenv "GUIX_PYTHONPATH") ,pylib))
+ `("GI_TYPELIB_PATH" =
+ (,(getenv "GI_TYPELIB_PATH")))))))
+ (add-after 'wrap-program 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases
+ 'glib-or-gtk-wrap)))))
(home-page "https://gnome-terminator.org/")
(synopsis "Store and run multiple GNOME terminals in one window")
(description
@@ -12002,6 +12010,9 @@ (define-public terminator
tabs, and it supports drag and drop re-ordering of terminals.")
(license license:gpl2)))
+(define-public terminator
+ (deprecated-package "terminator" gnome-terminator))
+
(define-public libhandy
(package
(name "libhandy")
--
2.39.1
?
Re: bug#59059: [PATCH] gnu: terminator: Renamed to "gnome-terminator" and update to 2.1.2
(name . Andy Tai)(address . atai@atai.org)(address . 59059@debbugs.gnu.org)
87k015j21a.fsf_-_@envs.net
Andy Tai <atai@atai.org> writes:

Toggle quote (4 lines)
> * gnu/packages/gnome.scm (gnome-terminator): Rename variable from
> (terminator): …this. Redefine using DEPRECATED-PACKAGE.
> Update to 2.1.2

Hello, I have commit the 2.1.2 update.

Why rename it to gnome-terminator? I think terminator is fine, because
that in ArchLinux the package named so, and its executeble is
'terminator' not 'gnome-terminator'.
A
A
Andy Tai wrote on 29 Jan 2023 07:22
(name . ???)(address . iyzsong@envs.net)(address . 59059@debbugs.gnu.org)
CAJsg1E_wwuxZ0j6ut4D3c9_=LCSD+Hbm3VHKBxZmYKU7Mmme5A@mail.gmail.com
Hi, I saw there are other software packages named "terminator" (on Mac
OS, I think) and I am afraid of name collisions. Also the
maintainers of the terminator package use the term gnome-terminator in
their own documentation , website, etc. I guess it is better to be
specific as this is something in the GNOME ecosystem.

Thanks

On Sat, Jan 28, 2023 at 10:19 PM ??? <iyzsong@envs.net> wrote:
Toggle quote (12 lines)
>
> Andy Tai <atai@atai.org> writes:
>
> > * gnu/packages/gnome.scm (gnome-terminator): Rename variable from
> > (terminator): …this. Redefine using DEPRECATED-PACKAGE.
> > Update to 2.1.2
>
> Hello, I have commit the 2.1.2 update.
>
> Why rename it to gnome-terminator? I think terminator is fine, because
> that in ArchLinux the package named so, and its executeble is
> 'terminator' not 'gnome-terminator'.
A
A
Andy Tai wrote on 3 Feb 2023 23:53
(address . control@debbugs.gnu.org)
CAJsg1E9tk47xP2gg9A8HiY4jeEgp4BgNUe6cSHCOAKOLfO673w@mail.gmail.com
close 59059
thanks


since key change committed, closing
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59059@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59059
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch