[PATCH 0/3] gnu: Add glad-2.

  • Open
  • quality assurance status badge
Details
One participant
  • (
Owner
unassigned
Submitted by
(
Severity
normal
(
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20221105171427.17117-1-paren@disroot.org
Heya,

This patchset supersedes #56959. It adds the newly released version 2
of the GLAD OpenGL and Vulkan API generator.

( (3):
gnu: glad: Rename to GLAD-1.
gnu: openboardview: Pin to GLAD-1.
gnu: Add glad-2.

gnu/packages/electronics.scm | 3 +-
gnu/packages/gl.scm | 70 ++++++++++++++++++++++++------------
2 files changed, 50 insertions(+), 23 deletions(-)


base-commit: 3e259442e70eae0cee6d4ce67c2d2dab939b0eb7
--
2.38.0
(
[PATCH 1/3] gnu: glad: Rename to GLAD-1.
(address . 59056@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20221105171542.19571-1-paren@disroot.org
* gnu/packages/gl.scm (glad-1): New variable.
(glad): Define as GLAD-1.
---
gnu/packages/gl.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 68c751ace5..93524988a9 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -189,7 +190,7 @@ (define-public ftgl
Polygon meshes, and Extruded polygon meshes.")
(license license:x11)))
-(define-public glad
+(define-public glad-1
(package
(name "glad")
(version "0.1.36")
@@ -221,6 +222,8 @@ (define-public glad
generate a GL/GLES/EGL/GLX/WGL loader tailored for specific requirements.")
(license license:expat)))
+(define glad glad-1)
+
(define-public s2tc
(package
(name "s2tc")
--
2.38.0
(
[PATCH 2/3] gnu: openboardview: Pin to GLAD-1.
(address . 59056@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20221105171542.19571-2-paren@disroot.org
* gnu/packages/electronics.scm (openboardview): Pin to GLAD-1.
---
gnu/packages/electronics.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 15e7318926..c10177eb18 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -321,7 +322,7 @@ (define keep (list "." ".." "openboardview"))
(native-inputs
(list pkg-config
python
- glad
+ glad-1
stb-image
utf8-h))
(inputs
--
2.38.0
(
[PATCH 3/3] gnu: Add glad-2.
(address . 59056@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20221105171542.19571-3-paren@disroot.org
* gnu/packages/gl.scm (glad-2): New variable.
(glad-1): Inherit from GLAD-2.
(glad): Define as GLAD-2.
---
gnu/packages/gl.scm | 69 ++++++++++++++++++++++++++++++---------------
1 file changed, 46 insertions(+), 23 deletions(-)

Toggle diff (92 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 93524988a9..7a6e8d092c 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -190,39 +190,62 @@ (define-public ftgl
Polygon meshes, and Extruded polygon meshes.")
(license license:x11)))
-(define-public glad-1
+(define-public glad-2
(package
(name "glad")
- (version "0.1.36")
- (source
- (origin
- ;; We fetch the sources from the repository since the PyPI archive
- ;; doesn't contain the CMakeLists.txt file which is useful for
- ;; integration with other software, such as the openboardview package.
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Dav1dde/glad")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0m55ya1zrmg6n2cljkajy80ilmi5sblln8742fm0k1sw9k7hzn8n"))))
+ (version "2.0.2")
+ (source (origin
+ ;; We fetch the sources from the repository since the PyPI
+ ;; archive doesn't contain the CMakeLists.txt file, which is
+ ;; useful for integration with other software, such as the
+ ;; openboardview package.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Dav1dde/glad")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1s9l7ypdxqaqpgnvc1vjgc7zaazm0j7dbfyqw6hwbx99d2whb7ds"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-cmakelists.txt
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (share (string-append out "/share/" ,name)))
- (install-file "CMakeLists.txt" share)))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-cmakelists.txt
+ (lambda _
+ (install-file "cmake/CMakeLists.txt"
+ (string-append #$output "/share/glad")))))))
+ (native-inputs (list python-jinja2))
(home-page "https://github.com/Dav1dde/glad")
(synopsis "Multi-language GL/GLES/EGL/GLX/WGL loader generator")
(description "Glad uses the official Khronos XML specifications to
generate a GL/GLES/EGL/GLX/WGL loader tailored for specific requirements.")
(license license:expat)))
-(define glad glad-1)
+(define-public glad-1
+ (package
+ (inherit glad-2)
+ (name "glad")
+ (version "0.1.36")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Dav1dde/glad")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0m55ya1zrmg6n2cljkajy80ilmi5sblln8742fm0k1sw9k7hzn8n"))))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-cmakelists.txt
+ (lambda _
+ (install-file "CMakeLists.txt"
+ (string-append
+ #$output "/share/glad")))))))))
+
+(define glad glad-2)
(define-public s2tc
(package
--
2.38.0
(
[PATCH v2 1/3] gnu: glad: Rename to GLAD-1.
(address . 59056@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20230205114241.4370-1-paren@disroot.org
* gnu/packages/gl.scm (glad-1): New variable.
(glad): Define as GLAD-1.
---
gnu/packages/gl.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 01ab6135a4..c5c3f63aed 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -189,7 +190,7 @@ (define-public ftgl
Polygon meshes, and Extruded polygon meshes.")
(license license:x11)))
-(define-public glad
+(define-public glad-1
(package
(name "glad")
(version "0.1.36")
@@ -221,6 +222,8 @@ (define-public glad
generate a GL/GLES/EGL/GLX/WGL loader tailored for specific requirements.")
(license license:expat)))
+(define-public glad glad-1)
+
(define-public s2tc
(package
(name "s2tc")

base-commit: f912d5c740815bff89a70d54b592c6173519003c
--
2.39.1
(
[PATCH v2 2/3] gnu: openboardview: Pin to GLAD-1.
(address . 59056@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20230205114241.4370-2-paren@disroot.org
* gnu/packages/electronics.scm (openboardview): Pin to GLAD-1.
---
gnu/packages/electronics.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 15e7318926..c10177eb18 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -321,7 +322,7 @@ (define keep (list "." ".." "openboardview"))
(native-inputs
(list pkg-config
python
- glad
+ glad-1
stb-image
utf8-h))
(inputs
--
2.39.1
(
[PATCH v2 3/3] gnu: Add glad-2.
(address . 59056@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20230205114241.4370-3-paren@disroot.org
* gnu/packages/gl.scm (glad-2): New variable.
(glad-1): Inherit from GLAD-2.
(glad): Define as GLAD-2.
---
gnu/packages/gl.scm | 69 ++++++++++++++++++++++++++++++---------------
1 file changed, 46 insertions(+), 23 deletions(-)

Toggle diff (92 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index c5c3f63aed..c23b00bf70 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -190,39 +190,62 @@ (define-public ftgl
Polygon meshes, and Extruded polygon meshes.")
(license license:x11)))
-(define-public glad-1
+(define-public glad-2
(package
(name "glad")
- (version "0.1.36")
- (source
- (origin
- ;; We fetch the sources from the repository since the PyPI archive
- ;; doesn't contain the CMakeLists.txt file which is useful for
- ;; integration with other software, such as the openboardview package.
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Dav1dde/glad")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0m55ya1zrmg6n2cljkajy80ilmi5sblln8742fm0k1sw9k7hzn8n"))))
+ (version "2.0.2")
+ (source (origin
+ ;; We fetch the sources from the repository since the PyPI
+ ;; archive doesn't contain the CMakeLists.txt file, which is
+ ;; useful for integration with other software, such as the
+ ;; openboardview package.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Dav1dde/glad")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1s9l7ypdxqaqpgnvc1vjgc7zaazm0j7dbfyqw6hwbx99d2whb7ds"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-cmakelists.txt
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (share (string-append out "/share/" ,name)))
- (install-file "CMakeLists.txt" share)))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-cmakelists.txt
+ (lambda _
+ (install-file "cmake/CMakeLists.txt"
+ (string-append #$output "/share/glad")))))))
+ (native-inputs (list python-jinja2))
(home-page "https://github.com/Dav1dde/glad")
(synopsis "Multi-language GL/GLES/EGL/GLX/WGL loader generator")
(description "Glad uses the official Khronos XML specifications to
generate a GL/GLES/EGL/GLX/WGL loader tailored for specific requirements.")
(license license:expat)))
-(define-public glad glad-1)
+(define-public glad-1
+ (package
+ (inherit glad-2)
+ (name "glad")
+ (version "0.1.36")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Dav1dde/glad")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0m55ya1zrmg6n2cljkajy80ilmi5sblln8742fm0k1sw9k7hzn8n"))))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-cmakelists.txt
+ (lambda _
+ (install-file "CMakeLists.txt"
+ (string-append
+ #$output "/share/glad")))))))))
+
+(define-public glad glad-2)
(define-public s2tc
(package
--
2.39.1
(
[PATCH v3 1/3] gnu: glad: Rename to GLAD-1.
(address . 59056@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20230205114854.5212-1-paren@disroot.org
* gnu/packages/gl.scm (glad-1): New variable.
(glad): Define as GLAD-1.
---
gnu/packages/gl.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 01ab6135a4..c5c3f63aed 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -189,7 +190,7 @@ (define-public ftgl
Polygon meshes, and Extruded polygon meshes.")
(license license:x11)))
-(define-public glad
+(define-public glad-1
(package
(name "glad")
(version "0.1.36")
@@ -221,6 +222,8 @@ (define-public glad
generate a GL/GLES/EGL/GLX/WGL loader tailored for specific requirements.")
(license license:expat)))
+(define-public glad glad-1)
+
(define-public s2tc
(package
(name "s2tc")

base-commit: f912d5c740815bff89a70d54b592c6173519003c
--
2.39.1
(
[PATCH v3 2/3] gnu: openboardview: Pin to GLAD-1.
(address . 59056@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20230205114854.5212-2-paren@disroot.org
* gnu/packages/electronics.scm (openboardview): Pin to GLAD-1.
---
gnu/packages/electronics.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 15e7318926..c10177eb18 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -321,7 +322,7 @@ (define keep (list "." ".." "openboardview"))
(native-inputs
(list pkg-config
python
- glad
+ glad-1
stb-image
utf8-h))
(inputs
--
2.39.1
(
[PATCH v3 3/3] gnu: Add glad-2.
(address . 59056@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20230205114854.5212-3-paren@disroot.org
* gnu/packages/gl.scm (glad-2): New variable.
(glad-1): Inherit from GLAD-2.
(glad): Define as GLAD-2.
---
gnu/packages/gl.scm | 68 ++++++++++++++++++++++++++++++---------------
1 file changed, 45 insertions(+), 23 deletions(-)

Toggle diff (91 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index c5c3f63aed..195434f7c0 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -190,39 +190,61 @@ (define-public ftgl
Polygon meshes, and Extruded polygon meshes.")
(license license:x11)))
-(define-public glad-1
+(define-public glad-2
(package
(name "glad")
- (version "0.1.36")
- (source
- (origin
- ;; We fetch the sources from the repository since the PyPI archive
- ;; doesn't contain the CMakeLists.txt file which is useful for
- ;; integration with other software, such as the openboardview package.
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Dav1dde/glad")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0m55ya1zrmg6n2cljkajy80ilmi5sblln8742fm0k1sw9k7hzn8n"))))
+ (version "2.0.2")
+ (source (origin
+ ;; We fetch the sources from the repository since the PyPI
+ ;; archive doesn't contain the CMakeLists.txt file, which is
+ ;; useful for integration with other software, such as the
+ ;; openboardview package.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Dav1dde/glad")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1s9l7ypdxqaqpgnvc1vjgc7zaazm0j7dbfyqw6hwbx99d2whb7ds"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-cmakelists.txt
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (share (string-append out "/share/" ,name)))
- (install-file "CMakeLists.txt" share)))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-cmakelists.txt
+ (lambda _
+ (install-file "cmake/CMakeLists.txt"
+ (string-append #$output "/share/glad")))))))
+ (native-inputs (list python-jinja2))
(home-page "https://github.com/Dav1dde/glad")
(synopsis "Multi-language GL/GLES/EGL/GLX/WGL loader generator")
(description "Glad uses the official Khronos XML specifications to
generate a GL/GLES/EGL/GLX/WGL loader tailored for specific requirements.")
(license license:expat)))
-(define-public glad glad-1)
+(define-public glad-1
+ (package
+ (inherit glad-2)
+ (name "glad")
+ (version "0.1.36")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Dav1dde/glad")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0m55ya1zrmg6n2cljkajy80ilmi5sblln8742fm0k1sw9k7hzn8n"))))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-cmakelists.txt
+ (lambda _
+ (install-file "CMakeLists.txt"
+ (string-append #$output "/share/glad")))))))))
+
+(define-public glad glad-2)
(define-public s2tc
(package
--
2.39.1
?