[PATCH] gnu: Add guile-png.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 2 years ago
(address . guix-patches@gnu.org)
874jvd1h4c.fsf@gmail.com
Hello,

this patch adds Guile-PNG 0.1.0.
From 3ad8ae184ad83f6106cfec251468bcd822c09f78 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 5 Nov 2022 19:47:07 +0300
Subject: [PATCH] gnu: Add guile-png.

* gnu/packages/guile-xyz.scm (guile-png): New variable.
---
gnu/packages/guile-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 38a0b3e4cb..070ab40fe9 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3542,6 +3542,34 @@ (define-public guile-jpeg
perform geometrical transforms on JPEG images.")
(license license:gpl3+))))
+(define-public guile-png
+ (package
+ (name "guile-png")
+ (version "0.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/guile-png")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0ig58zjw60jg4bb4fzm22dqr5zksqpzimpfa8wcarv8gjp861cw5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+ (native-inputs (list autoconf automake pkg-config texinfo texlive))
+ (inputs (list bash-minimal guile-3.0 guile-lib guile-zlib))
+ (propagated-inputs (list guile-smc))
+ (home-page "https://github.com/artyom-poptsov/guile-png")
+ (synopsis "PNG file parsing library for Guile")
+ (description
+ "@code{guile-png} is a GNU Guile library for working with the
+@url{https://en.wikipedia.org/wiki/PNG, PNG format}. This library provides
+API for reading and writing PNG data, as well as some basic image processing
+filters.")
+ (license license:gpl3+)))
+
(define-public nomad
(package
(name "nomad")
--
2.34.1
- Artyom

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQFNBAEBCgA3FiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmNmlBMZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRDpxaLZCJigL9ZQB/wLWrlCdAlixiGWGvY4P0C0
EsoE9KY3WiBF/RC9vB1phym/E+LY9w+YWBfoDYJ8MDQCRPrY0U3r96zsQzh9QYW4
N92Z2BebkpWTtMwgKh1zyIBnzif5eCpxba7h7+Vr4YKrhyIMybgP12tu2SOn1jbJ
+svQ/uvGFvOc2a7ymriAgLK+s2WN6hOrV5njaDT01FhRY2Qovs7v8c/4mJr0H667
ZO4YGbOud4R66eoUle4Kh2ISht0jua+8HsIbIKzr3vdg5LwzkpB3sGri0HDUVtQR
odcEGZ4Oy2fT6Z7WqFDqRgHijXQwjDgzUpXh3/1fuL+G45vKx7bdbYmsq0rBGDX/
=Wiy5
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 2 years ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 59054-done@debbugs.gnu.org)
87iljqsaau.fsf@gnu.org
Hi,

"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

Toggle quote (7 lines)
> From 3ad8ae184ad83f6106cfec251468bcd822c09f78 Mon Sep 17 00:00:00 2001
> From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
> Date: Sat, 5 Nov 2022 19:47:07 +0300
> Subject: [PATCH] gnu: Add guile-png.
>
> * gnu/packages/guile-xyz.scm (guile-png): New variable.

[...]

Toggle quote (2 lines)
> + (native-inputs (list autoconf automake pkg-config texinfo texlive))

Applied, but without the unnecessary 4 GiB ‘texlive’ dependency. :-)

Toggle quote (3 lines)
> + (synopsis "PNG file parsing library for Guile")

Nice!

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59054@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59054
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help