[PATCH] gnu: Add fuzzel.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Ludovic Courtès
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
K
K
kiasoc5 wrote on 5 Nov 2022 04:44
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221105034438.23962-1-kiasoc5@disroot.org
This patch avoids building fuzzel with bundled nanosvg and uses librsvg instead.

* gnu/packages/xdisorg.scm (fuzzel): New variable.
---
gnu/packages/xdisorg.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 8e70050850..8c33b70fcb 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2919,6 +2919,46 @@ (define-public j4-dmenu-desktop
(home-page "https://github.com/enkore/j4-dmenu-desktop")
(license license:gpl3+)))
+(define-public fuzzel
+ (package
+ (name "fuzzel")
+ (version "1.8.2")
+ (home-page "https://codeberg.org/dnkl/fuzzel")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d6xy4q5s8p5ckvd9wy3zzj9gh7nh9v1qhn3938b1wfhfzjdzrg6"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:build-type "release"
+ #:configure-flags
+ #~(list "-Denable-cairo=enabled"
+ "-Dpng-backend=libpng"
+ "-Dsvg-backend=librsvg")))
+ (native-inputs
+ (list pkg-config scdoc tllist))
+ (inputs
+ (list cairo
+ fcft
+ fontconfig
+ libpng
+ libxkbcommon
+ librsvg ;; if librsvg is not used, bundled nanosvg is used
+ pixman
+ wayland
+ wayland-protocols))
+ (synopsis "Wayland-native application launcher")
+ (description
+ "@command{foot} is a Wayland-native application launcher, similar to
+rofi's drun mode. It has Emacs key bindings and remembers frequently launched
+applications. The font and colors can be configured.")
+ (license (list license:expat ;; fuzzel
+ license:zlib)))) ;; bundled nanosvg
+
(define-public wofi
(package
(name "wofi")

base-commit: a65cd830084b20f95d39f565ea5cd0da8e8b09ad
--
2.38.0
K
K
kiasoc5 wrote on 13 Nov 2022 01:38
(address . 59039@debbugs.gnu.org)
0d105880-62aa-46b3-0525-bbf19e400098@disroot.org
On 11/4/22 23:44, kiasoc5 wrote:
Toggle quote (1 lines)
> This patch avoids building fuzzel with bundled nanosvg and uses librsvg instead.
It turns out some other projects by dnkl in Guix (such as fnott) do not
unbundle nanosvg.

In that case it may be better to use the bundled nanosvg for fuzzel too.

WDYT?
L
L
Ludovic Courtès wrote on 15 Nov 2022 11:53
Re: bug#59039: [PATCH] gnu: Add fuzzel.
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 59039@debbugs.gnu.org)
87k03wmqua.fsf_-_@gnu.org
Hi,

kiasoc5 <kiasoc5@disroot.org> skribis:

Toggle quote (7 lines)
> On 11/4/22 23:44, kiasoc5 wrote:
>> This patch avoids building fuzzel with bundled nanosvg and uses librsvg instead.
> It turns out some other projects by dnkl in Guix (such as fnott) do
> not unbundle nanosvg.
>
> In that case it may be better to use the bundled nanosvg for fuzzel too.

Unless it causes technical problems, for instance because the bundled
version is patched and somewhat specific, the policy in Guix is to
always unbundle.

Ludo’.
L
L
Ludovic Courtès wrote on 15 Nov 2022 11:55
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 59039-done@debbugs.gnu.org)
87fsekmqqj.fsf@gnu.org
Hi,

kiasoc5 <kiasoc5@disroot.org> skribis:

Toggle quote (4 lines)
> This patch avoids building fuzzel with bundled nanosvg and uses librsvg instead.
>
> * gnu/packages/xdisorg.scm (fuzzel): New variable.

Passed through ‘guix style’ and applied.

At some point we should prolly move Wayland things to their own file;
I don’t see how we ended up putting it all in xdisorg.scm. :-)

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59039@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59039
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch