(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
This patch avoids building fuzzel with bundled nanosvg and uses librsvg instead.
* gnu/packages/xdisorg.scm (fuzzel): New variable.
---
gnu/packages/xdisorg.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)
Toggle diff (55 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 8e70050850..8c33b70fcb 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2919,6 +2919,46 @@ (define-public j4-dmenu-desktop
(home-page "https://github.com/enkore/j4-dmenu-desktop")
(license license:gpl3+)))
+(define-public fuzzel
+ (package
+ (name "fuzzel")
+ (version "1.8.2")
+ (home-page "https://codeberg.org/dnkl/fuzzel")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d6xy4q5s8p5ckvd9wy3zzj9gh7nh9v1qhn3938b1wfhfzjdzrg6"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:build-type "release"
+ #:configure-flags
+ #~(list "-Denable-cairo=enabled"
+ "-Dpng-backend=libpng"
+ "-Dsvg-backend=librsvg")))
+ (native-inputs
+ (list pkg-config scdoc tllist))
+ (inputs
+ (list cairo
+ fcft
+ fontconfig
+ libpng
+ libxkbcommon
+ librsvg ;; if librsvg is not used, bundled nanosvg is used
+ pixman
+ wayland
+ wayland-protocols))
+ (synopsis "Wayland-native application launcher")
+ (description
+ "@command{foot} is a Wayland-native application launcher, similar to
+rofi's drun mode. It has Emacs key bindings and remembers frequently launched
+applications. The font and colors can be configured.")
+ (license (list license:expat ;; fuzzel
+ license:zlib)))) ;; bundled nanosvg
+
(define-public wofi
(package
(name "wofi")
base-commit: a65cd830084b20f95d39f565ea5cd0da8e8b09ad
--
2.38.0