[PATCH 0/1] gnu: python-glymur: Update to 0.12.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 5 Nov 2022 00:11
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221104231154.13547-1-sharlatanus@gmail.com
Hi Guix team,

python-glymur updated to the latest version with simplify package by using
pyproject-build-system.

Toggle quote (3 lines)
> ./pre-inst-env guix build python-glymur --rounds=2
> /gnu/store/jjp6y8r82n8q0kcq2cj7g10zdxnzvq4i-python-glymur-0.12.0

Sharlatan Hellseher (1):
gnu: python-glymur: Update to 0.12.0

gnu/packages/python-xyz.scm | 34 +++++++++-------------------------
1 file changed, 9 insertions(+), 25 deletions(-)


base-commit: 3a227cff367e5b5415624adcb15eed124ac7768d
--
2.38.0
S
S
Sharlatan Hellseher wrote on 5 Nov 2022 00:13
[PATCH 1/1] gnu: python-glymur: Update to 0.12.0
(address . 59030@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221104231337.13672-1-sharlatanus@gmail.com
* gnu/packages/python-xyz.scm (python-glymur): Update to 0.12.0
[build-system]: python-build-system -> pyproject-build-system
[arguments]: Drop redundant phases
[native-inputs]: Remove python-pypa-build
---
gnu/packages/python-xyz.scm | 34 +++++++++-------------------------
1 file changed, 9 insertions(+), 25 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 19bbea7d42..3adbede1b0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1153,7 +1153,7 @@ (define-public python-pyprind
(define-public python-glymur
(package
(name "python-glymur")
- (version "0.10.1")
+ (version "0.12.0")
(source
(origin
(method git-fetch) ; no tests data in PyPi package
@@ -1162,8 +1162,8 @@ (define-public python-glymur
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1cq9r8vzwvds1kasy5gc2rxw034jh9l43rraps1n739072pfz6qg"))))
- (build-system python-build-system)
+ (base32 "03nny8k42yxdyw7sjv43szmg23x3rqplbaf7m0a0lpvwla1dl78i"))))
+ (build-system pyproject-build-system)
(arguments
(list
#:phases
@@ -1184,29 +1184,13 @@ (define-public python-glymur
" elif libname == \"c\":\n"
" path = \""
(search-input-file inputs "/lib/libc.so.6") "\"\n")))))
- ;; TODO: implement as a feature of python-build-system (PEP-621,
- ;; PEP-631, PEP-660)
- (replace 'build
+ (add-before 'check 'disable-failing-tests
(lambda _
- (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)
- ;; ZIP does not support timestamps before 1980.
- (setenv "SOURCE_DATE_EPOCH" "315532800")
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; Failing test due to inability of
- ;; ctypes.util.find_library() to determine library path,
- ;; which is patched above.
- (delete-file "tests/test_config.py")
- (invoke "python" "-m" "pytest" "-vv" "tests")))))))
- (native-inputs
- (list python-pypa-build python-pytest))
+ ;; Failing test due to inability of
+ ;; ctypes.util.find_library() to determine library path,
+ ;; which is patched above.
+ (delete-file "tests/test_config.py"))))))
+ (native-inputs(list python-pytest))
(inputs
(list openjpeg ; glymur/lib/openjp2.py
libtiff)) ; glymur/lib/tiff.py
--
2.38.0
C
C
Christopher Baines wrote on 6 Nov 2022 16:02
Re: [bug#59030] [PATCH 0/1] gnu: python-glymur: Update to 0.12.0
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
871qqggm2p.fsf@cbaines.net
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (12 lines)
> python-glymur updated to the latest version with simplify package by using
> pyproject-build-system.
>
>> ./pre-inst-env guix build python-glymur --rounds=2
>> /gnu/store/jjp6y8r82n8q0kcq2cj7g10zdxnzvq4i-python-glymur-0.12.0
>
> Sharlatan Hellseher (1):
> gnu: python-glymur: Update to 0.12.0
>
> gnu/packages/python-xyz.scm | 34 +++++++++-------------------------
> 1 file changed, 9 insertions(+), 25 deletions(-)

Thanks, I've pushed this to master as
9315fcc21120ddc1343454bd29d0538a1b1287b7.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNnzT5fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdcUw//X1XPXYm6xoHuRkVwZNmyRtTqkSNxVV/U
SK7jFQYCA3XEmbxrjLqcc4k79goC7mP5wK8vhu5/0K0T+1H9xigUOZ01UrpuO2T4
8UqBcxPO7LHDpXu3OGolJ9CecCIUlMtxEhsCqdAgdxdX2J83ryTB9CxBqkqO9Soe
O2Kbx/V5tKpk7DXlO845M8D+Qkp+8Hb9DooUNT++OytSYjJ+Z7BReKZ6+YyFbgvL
P8j15zGN75mK/9aXqad/CFLmVt0ZUe0NV4Dv73n9m25bGyHPTYkCKIAi/vFZ+q1r
BnRDF4kVgyN2/DdrwWMre7mdlPb8c26bZSMKjrmpsYPeHPDYS/MWxL+pji+gk63J
UpLA6wcWuwg9Er1knULmoDJGFOxWLmAcvSbiLv56+7tOmP8juLR5buQfRJPtPSqk
5bv25/kE57p/un3jTHyY+VtA33r2yth0QWI0C4YqueopfML4bl6jrhu9cx1vWgP7
mWRKx40SJhhlJtShVHHFNS4x8t//W12hAmfh8KaXcSWCNegUgv05w1fiASDGGGaJ
t5hZXwpXGEUh6iieYzhWvvW0VAB45AJUiMZeDadBvy7zI4agAgZBIB6GnylZ7/c5
GTdBNqwEWFlduWZrVLZeT4LNppYJGNA6gU2BFE3zVSf8s2QH8hVN2sb6XyAjIex9
k2FERqyXdcU=
=Y35o
-----END PGP SIGNATURE-----

?