[PATCH 0/1] gnu: cl-xmls: Update to 3.2.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221104203458.13870-1-sharlatanus@gmail.com
Hi Guix team,

This patch includes updated version of Common Lisp xmls package. I uses the
latest tag and enables ECL tests.

Toggle quote (5 lines)
> ./pre-inst-env guix build sbcl-xmls ecl-xmls cl-xmls --rounds=2
> /gnu/store/wi91acqhkghfissc3q28s53s9mijznad-cl-xmls-3.2.0
> /gnu/store/9s8fn4hb0g5aq7xa94h4iknlmj33gf72-ecl-xmls-3.2.0
> /gnu/store/gvg43p3ia80d8vq19yydw1i8812lg8fc-sbcl-xmls-3.2.0

Sharlatan Hellseher (1):
gnu: cl-xmls: Update to 3.2.0

gnu/packages/lisp-xyz.scm | 48 ++++++++++++++++-----------------------
1 file changed, 20 insertions(+), 28 deletions(-)


base-commit: 3a227cff367e5b5415624adcb15eed124ac7768d
--
2.38.0
Sharlatan Hellseher wrote 2 years ago
[PATCH 1/1] gnu: cl-xmls: Update to 3.2.0
(address . 59025@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221104230444.12730-1-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (sbcl-xmls): Update to 3.2.0
[package]{version}: Use the latest upstream tag over commit.

* gnu/packages/lisp-xyz.scm (ecl-xmls): Enable tests. Issue is resolved
upstream which allows to enable tests for ECL implementation
---
gnu/packages/lisp-xyz.scm | 48 ++++++++++++++++-----------------------
1 file changed, 20 insertions(+), 28 deletions(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 556ac41afc..7894b13dc5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13427,41 +13427,33 @@ (define-public ecl-lambda-fiddle
(sbcl-package->ecl-package sbcl-lambda-fiddle))
(define-public sbcl-xmls
- (let ((commit "18546f0850b1338e03997ffd1696add1cb1800d1") ;; no tagged branch
- (revision "1"))
- (package
- (name "sbcl-xmls")
- (version (git-version "3.0.2" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rpgoldman/xmls")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1lmvfml2ldbb1wkhm25jqqk2bhwsz52hhcgljbnzj1xr8xhc3anp"))))
- (native-inputs
- (list sbcl-fiveam))
- (build-system asdf-build-system/sbcl)
- (home-page "https://github.com/rpgoldman/xmls")
- (synopsis "Non-validating XML parser for Common Lisp")
- (description "Xmls is a self-contained, easily embedded parser that
+ (package
+ (name "sbcl-xmls")
+ (version "3.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rpgoldman/xmls")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10406sgap9kdaip7blxldnv6kabiczd6890jgic4pacsrfx6jypk"))))
+ (native-inputs
+ (list sbcl-fiveam))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/rpgoldman/xmls")
+ (synopsis "Non-validating XML parser for Common Lisp")
+ (description "Xmls is a self-contained, easily embedded parser that
recognizes a useful subset of the XML spec. It provides a simple mapping from
XML to Lisp structures or s-expressions and back.")
- (license license:bsd-2))))
+ (license license:bsd-2)))
(define-public cl-xmls
(sbcl-package->cl-source-package sbcl-xmls))
(define-public ecl-xmls
- (let ((pkg (sbcl-package->ecl-package sbcl-xmls)))
- (package
- (inherit pkg)
- (arguments
- (substitute-keyword-arguments (package-arguments pkg)
- ;; Upstream doesn't have a test suite adapted for ECL.
- ((#:tests? _ #f) #f))))))
+ (sbcl-package->ecl-package sbcl-xmls))
(define-public sbcl-geco
(let ((commit "db13c9384491092975f46f6a837ccdc04681a93a")
--
2.38.0
Guillaume Le Vaillant wrote 2 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 59025-done@debbugs.gnu.org)
87v8nt1u3w.fsf@kitej
Patch pushed as 2211f50ec1ebcf5f880454b4133ac40e41abac21.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY2ZSUw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9dRgD/QjmFj2/F74n1HF88Oi2Xn9OJ2rJpF9NbSRWS
ZiH+KhIA/2J+Hoq9Qll60jzo4xhI7Ibf5BkTQ/elkgo+ygesHlV1
=kSbg
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 59025@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 59025
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help