[PATCH 0/1] gnu: Add hu.dwim.graphviz

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221101213308.31091-1-sharlatanus@gmail.com
Hi Guix team!

Please review Graphviz bindings for Common Lisp.

Toggle quote (5 lines)
> ./pre-inst-env guix build sbcl-hu.dwim.graphviz cl-hu.dwim.graphviz ecl-hu.dwim.graphviz --rounds=2
> /gnu/store/mwdc8x4lrdy90hvmg2z9qqka82wkl3b9-ecl-hu.dwim.graphviz-0.0.0-1.31522ca
> /gnu/store/cx038vn0rqswpnnaw77k3ay0lmi4q5wp-cl-hu.dwim.graphviz-0.0.0-1.31522ca
> /gnu/store/fkb2a7801hq1lfqlfic12wkwrp6yhxgm-sbcl-hu.dwim.graphviz-0.0.0-1.31522ca

Sharlatan Hellseher (1):
gnu: Add hu.dwim.graphviz

gnu/packages/lisp-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)


base-commit: d0917d778284ee7d70bc80b0538e3b4ae67870f4
--
2.37.3
Sharlatan Hellseher wrote 2 years ago
[PATCH 1/1] gnu: Add hu.dwim.graphviz
(address . 58953@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221101213423.31223-1-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (ecl-hu.dwim.graphviz, cl-hu.dwim.graphviz,
sbcl-hu.dwim.graphviz): New variables.
---
gnu/packages/lisp-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 80a35f9dd1..bc80d930e1 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -84,6 +84,7 @@ (define-module (gnu packages lisp-xyz)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
@@ -1868,6 +1869,46 @@ (define-public cl-hu.dwim.asdf
(define-public ecl-hu.dwim.asdf
(sbcl-package->ecl-package sbcl-hu.dwim.asdf))
+(define-public sbcl-hu.dwim.graphviz
+ (let ((commit "31522ca8b9a04d535b7cec20ef24d8bf3b26d52b")
+ (revision "1"))
+ (package
+ (name "sbcl-hu.dwim.graphviz")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hu-dwim/hu.dwim.graphviz")
+ (commit commit)))
+ (file-name (git-file-name "sbcl-hu.dwim.graphviz" version))
+ (sha256
+ (base32 "0cz5g7d6817ajypp876k9m65sxxlf42x4bg04ya73aqci5s1vjwy"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-graphviz-lib-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "source/package.lisp"
+ (("libgvc.so")
+ (search-input-file inputs "/lib/libgvc.so"))))))))
+ (native-inputs
+ (list sbcl-hu.dwim.common sbcl-hu.dwim.stefil))
+ (inputs
+ (list graphviz sbcl-cffi sbcl-metabang-bind))
+ (home-page "https://github.com/hu-dwim/hu.dwim.graphviz")
+ (synopsis "Graphviz layouting using CFFI bindings")
+ (description
+ "This package provides CFFI bindigs to Graphviz library in Common Lisp.")
+ (license license:public-domain))))
+
+(define-public cl-hu.dwim.graphviz
+ (sbcl-package->cl-source-package sbcl-hu.dwim.graphviz))
+
+(define-public ecl-hu.dwim.graphviz
+ (sbcl-package->ecl-package sbcl-hu.dwim.graphviz))
+
(define-public sbcl-babel
;; No release since 2014.
(let ((commit "f892d0587c7f3a1e6c0899425921b48008c29ee3")
--
2.37.3
Guillaume Le Vaillant wrote 2 years ago
Re: [bug#58953] [PATCH 0/1] gnu: Add hu.dwim.graphviz
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 58953-done@debbugs.gnu.org)
87iljwku3b.fsf@kitej
Patch pushed as 53c8cbb31428322e16c255f73fb7f7670ef7f8aa.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY2PLqA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8VHQD/W3ixoBz/c7pOpkSjgsrBR1iYcL9tUj2bgrwb
w8ACBvcA/RX4CZt1e0UbyL3kq1FMVi3GWXnuZh1AlHfSXNCbQDSx
=w2Z6
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58953@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58953
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help