[PATCH] gnu: strawberry: Remove trailing #t from phases and snippet.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 2 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20221101000716.6746-1-mike@rohleder.de
* gnu/packages/music.scm (strawberry)[arguments]<#:phases>: Remove trailing #t.
[snippet]: Likewise.
---
gnu/packages/music.scm | 9 +++------
1 file changed, 3 insertions(+), 6 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index d493b09f07..c8dd415523 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -504,8 +504,7 @@ (define-public strawberry
(find-files "3rdparty"
(lambda (file stat)
(string-match "^3rdparty/[^/]*$" file))
- #:directories? #t))
- #t))))
+ #:directories? #t))))))
(build-system cmake-build-system)
(arguments
`(#:test-target "run_strawberry_tests"
@@ -516,15 +515,13 @@ (define-public strawberry
(let ((out (assoc-ref outputs "out"))
(gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
(wrap-program (string-append out "/bin/strawberry")
- `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))
- #t)))
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))))))
(add-before 'check 'pre-check
(lambda* (#:key inputs #:allow-other-keys)
(let ((xorg-server (assoc-ref inputs "xorg-server")))
(system (format #f "~a/bin/Xvfb :1 &" xorg-server))
(setenv "DISPLAY" ":1")
- (setenv "HOME" (getcwd))
- #t))))))
+ (setenv "HOME" (getcwd))))))))
(native-inputs
`(("gettext" ,gettext-minimal)
("googletest" ,googletest)
--
2.38.0
Christopher Baines wrote 2 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)
87cza4kjrt.fsf@cbaines.net
Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (6 lines)
> * gnu/packages/music.scm (strawberry)[arguments]<#:phases>: Remove trailing #t.
> [snippet]: Likewise.
> ---
> gnu/packages/music.scm | 9 +++------
> 1 file changed, 3 insertions(+), 6 deletions(-)

Thanks! Pushed to master as 318581c5fc8f7716ad65d670eb7654a03a0e785d.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNj/+ZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeS6g/+IdlwNgNySe373iXkdhvCvS6j+eht36xE
zrEpoa2rAMt994yjZDID++ZlJidkI3eT/6nh6ez2gGSSneOQet1s9E8VSAWsblgB
0dsOghUDfaCOEOkirPwbk0TCgof+bsrTzI8tL3ZnNjiS0YueInxReF6XrMzhCqux
ufjVdlDJW/iMYBB8ud5G3eDw/OXzeXtPkWG2un33+wtzAfDOehuIV0UaweUcZjFJ
sRKLS3N+lGxlhCZvWRt3JB8ubg+FqEhNVauCMZKM3tV3Kv6kKQemvcqHH6H9WcYl
E8WIWMRaLaf75Rg/8pmssEUCXhvCHuvVSNmPolDngeexixW7Ye4YImjhEm8eVGwA
tj4FchET43xMM5sRJp6bqpraKJ5d/Khw3yc8Q16Ve79ymI87i/VWE9aWTehw9Um+
ROt04famqxj5Kz9utBuZTDvZBFekXSJKphYyUZbf1q+fIXi6gDiOq3g7O8MDajgy
aadZOrh7A/0RGaWA7SMnwjaeMCM/XFNRZEYppoLaFIG3cVsPf0go3uKli6aw/xnI
XoT3AUmUsH1BXU4J6jfMJ5QVa6S6jNtot0bLHqvytBPmWumRnu+2F5GWJQStLCxg
SKEy1+9C2EQxu/Go1nYgiqbceEPfzJVyoIGGrc+SGSK/8cUopa53EXsU2tMjaB22
tyYsRtpIC+g=
=iAe1
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 58939@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58939
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help