[PATCH 0/2]: Gnu: Add Siril

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 30 Oct 2022 22:53
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221030215313.2543-1-sharlatanus@gmail.com
Hi Guix team!

New day new Astronomical package :)

This patch series adds SERIL and one missing dependence librtprocess.

Regards,
Oleg

Toggle quote (1 lines)
> ./pre-inst-env guix build siril librtprocess --rounds=2
/gnu/store/x1mrvx8svyjhcg7mgn1sin5gg5r1y335-librtprocess-0.12.0
/gnu/store/1vjkdy6d098x44vd4a24619h4gn9nwdy-siril-1.0.6

Sharlatan Hellseher (2):
gnu: Add librtprocess
gnu: Add siril

gnu/packages/astronomy.scm | 42 ++++++++++++++++++++++++++++++++++++++
gnu/packages/photo.scm | 24 ++++++++++++++++++++++
2 files changed, 66 insertions(+)


base-commit: 5b87c7c1d2a978d68b4175b9d5de249530ff9e81
--
2.37.3
S
S
Sharlatan Hellseher wrote on 30 Oct 2022 22:56
[PATCH 1/2] gnu: Add librtprocess
(address . 58907@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221030215652.2822-1-sharlatanus@gmail.com
* gnu/packages/photo.scm (librtprocess): New variable.
---
gnu/packages/photo.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 642694bda1..2dfc445dfd 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020. 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -807,3 +808,26 @@ (define-public rawtherapee
formats are supported, including Pentax Pixel Shift, Canon Dual-Pixel, and those
from Foveon and X-Trans sensors.")
(license license:gpl3+)))
+
+(define-public librtprocess
+ (package
+ (name "librtprocess")
+ (version "0.12.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/CarVac/librtprocess")
+ (commit version)))
+ (sha256
+ (base32
+ "0v0zwbdbc1fn7iy6wi0m6zgb86qdx1ijnv548d0ydbr8cm4klnpz"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ ;; No tests
+ (list #:tests? #f))
+ (home-page "https://github.com/CarVac/librtprocess")
+ (synopsis "Highly optimized library for processing RAW images")
+ (description
+ "This package provides RawTherapee's highly optimized RAW processing routines.")
+ (license license:gpl3)))
--
2.37.3
S
S
Sharlatan Hellseher wrote on 30 Oct 2022 22:56
[PATCH 2/2] gnu: Add siril
(address . 58907@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20221030215652.2822-2-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (siril): New variable.
---
gnu/packages/astronomy.scm | 42 ++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (89 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index dd27f4e530..82156142e6 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -33,6 +33,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages flex)
@@ -44,12 +45,14 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
+ #:use-module (gnu packages image-processing)
#:use-module (gnu packages libusb)
#:use-module (gnu packages lua)
#:use-module (gnu packages maths)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages netpbm)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pretty-print)
#:use-module (gnu packages python)
@@ -61,6 +64,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages time)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
@@ -72,6 +76,7 @@ (define-module (gnu packages astronomy)
#:use-module (guix build-system cmake)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix gexp)
@@ -591,6 +596,43 @@ (define-public sextractor
crowded star fields.")
(license license:gpl3+)))
+(define-public siril
+ (package
+ (name "siril")
+ (version "1.0.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/free-astro/siril")
+ (commit version)))
+ (sha256
+ (base32
+ "0iqxb5zmjyygg4b6lwlq8z82mngxg7kjjpahhzk52m0cypfq0l18"))
+ (file-name (git-file-name name version))))
+ (build-system meson-build-system)
+ (native-inputs (list cmake git glib libconfig pkg-config))
+ (inputs (list cfitsio
+ exiv2
+ fftwf
+ gsl
+ gtk+
+ json-glib
+ libraw
+ librtprocess
+ opencv))
+ (home-page "https://siril.org/")
+ (synopsis "Image processing software for amateur astronomy")
+ (description
+ "This package provides an astronomical image processing tool - SIRIL. It is
+specially tailored for noise reduction and improving the signal/noise ratio of
+an image from multiple captures, as required in astronomy. SIRIL can align
+automatically or manually, stack and enhance pictures from various file formats,
+even image sequence files (films and SER files). It works well with limited
+system resources, like in embedded platforms, but is also very fast when run on
+more powerful computers and provides conversion to FITS from a large number of
+image formats.")
+ (license license:gpl3)))
+
(define-public splash
(package
(name "splash")
--
2.37.3
L
L
Ludovic Courtès wrote on 14 Nov 2022 12:21
Re: bug#58907: [PATCH 0/2]: Gnu: Add Siril
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 58907-done@debbugs.gnu.org)
878rkdrdbd.fsf@gnu.org
Hi!

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (3 lines)
> gnu: Add librtprocess
> gnu: Add siril

I change the licenses to ‘gpl3+’ because both have source file headers
that read “or any later version”.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58907@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58907
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch