[PATCH] gnu: Add clojure-data-csv.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Fabio Natali
Owner
unassigned
Submitted by
Fabio Natali
Severity
normal

Debbugs page

Fabio Natali wrote 2 years ago
(address . guix-patches@gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
92627730c0e5e47ceb8c64c3c8b595add32f7515.1667157599.git.me@fabionatali.com
* gnu/packages/clojure.scm (clojure-data-csv): New variable.
---
gnu/packages/clojure.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
index 622e43ac48..ad6d2dd49f 100644
--- a/gnu/packages/clojure.scm
+++ b/gnu/packages/clojure.scm
@@ -373,6 +373,31 @@ (define-public clojure-data-codec
is on par with Java implementations, e.g., Apache commons-codec.")
(license license:epl1.0)))
+(define-public clojure-data-csv
+ (package
+ (name "clojure-data-csv")
+ (version "1.0.1")
+ (home-page "https://github.com/clojure/data.csv")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mh1qli6xrw4s3yj9cxxh50z4m7z08indj3ya30znkhi4xsphii2"))))
+ (build-system clojure-build-system)
+ (arguments
+ '(#:source-dirs '("src/main/clojure")
+ #:test-dirs '("src/test/clojure" "src/test/resources")
+ #:doc-dirs '()))
+ (synopsis "Clojure library for reading and writing CSV data")
+ (description "@code{data.csv} is a Clojure library for reading and writing
+CSV data. @code{data.csv} follows the RFC4180 specification but is more
+relaxed.")
+ (license license:epl1.0)))
+
(define-public clojure-data-xml
(package
(name "clojure-data-xml")
--
2.38.0
Fabio Natali wrote 2 years ago
(address . 58902@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
8421f5810f4d58156e57d2b80c360702daca5874.1667248769.git.me@fabionatali.com
* gnu/packages/clojure.scm (clojure-data-csv): New variable.
---
Hi, please ignore my previous patch as that was not correctly tested. This one
should be fine - hopefully. :) Thanks, best, Fabio.

gnu/packages/clojure.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
index 622e43ac48..dbbe2049e4 100644
--- a/gnu/packages/clojure.scm
+++ b/gnu/packages/clojure.scm
@@ -373,6 +373,31 @@ (define-public clojure-data-codec
is on par with Java implementations, e.g., Apache commons-codec.")
(license license:epl1.0)))
+(define-public clojure-data-csv
+ (package
+ (name "clojure-data-csv")
+ (version "1.0.1")
+ (home-page "https://github.com/clojure/data.csv")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mh1qli6xrw4s3yj9cxxh50z4m7z08indj3ya30znkhi4xsphii2"))))
+ (build-system clojure-build-system)
+ (arguments
+ '(#:source-dirs '("src/main/clojure")
+ #:test-dirs '("src/test/clojure")
+ #:doc-dirs '()))
+ (synopsis "Clojure library for reading and writing CSV data")
+ (description "@code{data.csv} is a Clojure library for reading and writing
+CSV data. @code{data.csv} follows the RFC4180 specification but is more
+relaxed.")
+ (license license:epl1.0)))
+
(define-public clojure-data-xml
(package
(name "clojure-data-xml")
--
2.38.0
Ludovic Courtès wrote 2 years ago
(name . Fabio Natali)(address . me@fabionatali.com)(address . 58902-done@debbugs.gnu.org)
87edu5rdo9.fsf_-_@gnu.org
Hi,

Fabio Natali <me@fabionatali.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/clojure.scm (clojure-data-csv): New variable.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58902@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58902
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help