[PATCH] gnu: Add r-deco, r-decomplexdisease, r-decomptumor2sig, r-deconrnaseq and r-decontam.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
fdbfe6a8cf93421e8855d1844fa3856d@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-deco, r-decomplexdisease, r-decomptumor2sig, r-deconrnaseq and r-decontam): New variables.
Unrelated patches, added in the alphabetical order.
All the best,
Mădălin Ionel Patrașcu!
Attachment: file
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 2/5] gnu: Add r-decomplexdisease.
(address . 58879@debbugs.gnu.org)
20221029231608.13909-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-decomplexdisease): New variable.
---
gnu/packages/bioconductor.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 2f2268e5e6..809ba69bc3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3117,6 +3117,39 @@ (define-public r-deco
related to higher deregulation levels.")
(license (license:fsdg-compatible "GPL (>=3)"))))
+(define-public r-decomplexdisease
+ (package
+ (name "r-decomplexdisease")
+ (version "1.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DEComplexDisease" version))
+ (sha256
+ (base32
+ "09a967x1rnv7byjwh29ngjhs67rgg27zblmlzx6pyqlwy5jsp89d"))))
+ (properties `((upstream-name . "DEComplexDisease")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocparallel
+ r-complexheatmap
+ r-deseq2
+ r-edger
+ r-rcpp
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/DEComplexDisease")
+ (synopsis "Investigations of complex diseases by bi-clustering analysis")
+ (description
+ "@code{DEComplexDisease} is designed to find the @acronym{DEGs, Differential
+Expressed Genes} for complex disease, which is characterized by the heterogeneous
+genomic expression profiles. Different from the established DEG analysis tools,
+it does not assume the patients of complex diseases to share the common DEGs.
+By applying a bi-clustering algorithm, @code{DEComplexDisease} finds the DEGs
+shared by as many patients. Applying the @code{DEComplexDisease} analysis
+results, users are possible to find the patients affected by the same mechanism
+based on the shared signatures.")
+ (license license:gpl3)))
+
(define-public r-deconvr
(package
(name "r-deconvr")
--
2.38.0
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 4/5] gnu: Add r-deconrnaseq.
(address . 58879@debbugs.gnu.org)
20221029231608.13909-4-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-deconrnaseq): New variable.
---
gnu/packages/bioconductor.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7f6ba37bf8..ce95a9e5af 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3193,6 +3193,33 @@ (define-public r-decomptumor2sig
to the mutation load of the tumor.")
(license license:gpl2)))
+(define-public r-deconrnaseq
+ (package
+ (name "r-deconrnaseq")
+ (version "1.38.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DeconRNASeq" version))
+ (sha256
+ (base32
+ "10smk88srxm58hli0fhkdfd6l5z02q58xc9mww39gkn71y0127k6"))))
+ (properties `((upstream-name . "DeconRNASeq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ggplot2
+ r-limsolve
+ r-pcamethods))
+ (home-page "https://bioconductor.org/packages/DeconRNASeq")
+ (synopsis
+ "Deconvolution of heterogeneous tissue samples for mRNA-Seq data")
+ (description
+ "@code{DeconSeq} is an R package for deconvolution of heterogeneous tissues
+based on mRNA-Seq data. It models the expression levels from heterogeneous cell
+populations in mRNA-Seq as the weighted average of expression from different
+constituting cell types and predicted cell type proportions of single expression
+profiles.")
+ (license license:gpl2)))
+
(define-public r-deconvr
(package
(name "r-deconvr")
--
2.38.0
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 3/5] gnu: Add r-decomptumor2sig.
(address . 58879@debbugs.gnu.org)
20221029231608.13909-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-decomptumor2sig): New variable.
---
gnu/packages/bioconductor.scm | 43 +++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 809ba69bc3..7f6ba37bf8 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3150,6 +3150,49 @@ (define-public r-decomplexdisease
based on the shared signatures.")
(license license:gpl3)))
+(define-public r-decomptumor2sig
+ (package
+ (name "r-decomptumor2sig")
+ (version "2.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "decompTumor2Sig" version))
+ (sha256
+ (base32
+ "04hg9bbga2s8scjxfd8wjlmr45nzzvh8d6gr0w929sybx4nj2qz6"))))
+ (properties `((upstream-name . "decompTumor2Sig")))
+ (build-system r-build-system)
+ (inputs (list perl)) ;script/extractSpecColumns.pl
+ (propagated-inputs
+ (list r-biocgenerics
+ r-biostrings
+ r-bsgenome-hsapiens-ucsc-hg19
+ r-data-table
+ r-genomeinfodb
+ r-genomicfeatures
+ r-genomicranges
+ r-ggplot2
+ r-ggseqlogo
+ r-gridextra
+ r-matrix
+ r-plyr
+ r-quadprog
+ r-readxl
+ r-s4vectors
+ r-summarizedexperiment
+ r-txdb-hsapiens-ucsc-hg19-knowngene
+ r-variantannotation))
+ (native-inputs (list r-knitr))
+ (home-page "https://rmpiro.net/decompTumor2Sig/")
+ (synopsis "Decomposition of individual tumors into mutational signatures")
+ (description
+ "The package uses quadratic programming for signature refitting, i.e., to
+decompose the mutation catalog from an individual tumor sample into a set of given
+mutational signatures (either Alexandrov-model signatures or Shiraishi-model
+signatures), computing weights that reflect the contributions of the signatures
+to the mutation load of the tumor.")
+ (license license:gpl2)))
+
(define-public r-deconvr
(package
(name "r-deconvr")
--
2.38.0
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 5/5] gnu: Add r-decontam.
(address . 58879@debbugs.gnu.org)
20221029231608.13909-5-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-decontam): New variable.
---
gnu/packages/bioconductor.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ce95a9e5af..e1175e46f1 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3220,6 +3220,33 @@ (define-public r-deconrnaseq
profiles.")
(license license:gpl2)))
+(define-public r-decontam
+ (package
+ (name "r-decontam")
+ (version "1.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "decontam" version))
+ (sha256
+ (base32
+ "1g9hcfcfnpq6z21069yw0pyzncwznmvxb2xalg4y6y1604dy98q9"))))
+ (properties `((upstream-name . "decontam")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ggplot2
+ r-reshape2))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/benjjneb/decontam")
+ (synopsis
+ "Identification of the contaminants in marker-gene and metagenomics data")
+ (description
+ "This package offers simple statistical identification of contaminating
+sequence features in marker-gene or metagenomics data. Works on any kind of
+feature derived from environmental sequencing data (e.g. ASVs, OTUs, taxonomic
+groups, MAGs,...). Requires DNA quantitation data or sequenced negative control
+samples.")
+ (license license:artistic2.0)))
+
(define-public r-deconvr
(package
(name "r-deconvr")
--
2.38.0
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 1/5] gnu: Add r-deco.
(address . 58879@debbugs.gnu.org)
20221029231608.13909-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-deco): New variable.
---
gnu/packages/bioconductor.scm | 42 +++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b8535250f9..2f2268e5e6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3075,6 +3075,48 @@ (define-public r-decipher
biological sequences.")
(license license:gpl3)))
+(define-public r-deco
+ (package
+ (name "r-deco")
+ (version "1.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "deco" version))
+ (sha256
+ (base32
+ "18n5zgln33c79jbjzjlivs8ihyg8zci6minfqlvagxgzcpa67k0m"))))
+ (properties `((upstream-name . "deco")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ade4
+ r-annotationdbi
+ r-biobase
+ r-biocparallel
+ r-biocstyle
+ r-cluster
+ r-foreign
+ r-gdata
+ r-ggplot2
+ r-gplots
+ r-gridextra
+ r-limma
+ r-locfit
+ r-made4
+ r-rcolorbrewer
+ r-reshape2
+ r-scatterplot3d
+ r-sfsmisc
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/fjcamlab/deco")
+ (synopsis "Decomposing heterogeneous cohorts using omic data profiling")
+ (description
+ "The package discovers differential features in hetero- and homogeneous omic
+data by a two-step method including subsampling @code{LIMMA} and @code{NSCA}.
+@code{DECO} reveals feature associations to hidden subclasses not exclusively
+related to higher deregulation levels.")
+ (license (license:fsdg-compatible "GPL (>=3)"))))
+
(define-public r-deconvr
(package
(name "r-deconvr")

base-commit: ac51b9c86d58cfdb13ee643a2fdc8e979939a260
--
2.38.0
Ricardo Wurmus wrote 2 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 58879-done@debbugs.gnu.org)
87h6zjerrq.fsf@elephly.net
Applied all with minor changes (indentation, license, description).

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58879@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58879
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help