* gnu/packages/bioconductor.scm (r-decomplexdisease): New variable.
---
gnu/packages/bioconductor.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
Toggle diff (46 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 2f2268e5e6..809ba69bc3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3117,6 +3117,39 @@ (define-public r-deco
related to higher deregulation levels.")
(license (license:fsdg-compatible "GPL (>=3)"))))
+(define-public r-decomplexdisease
+ (package
+ (name "r-decomplexdisease")
+ (version "1.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DEComplexDisease" version))
+ (sha256
+ (base32
+ "09a967x1rnv7byjwh29ngjhs67rgg27zblmlzx6pyqlwy5jsp89d"))))
+ (properties `((upstream-name . "DEComplexDisease")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocparallel
+ r-complexheatmap
+ r-deseq2
+ r-edger
+ r-rcpp
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/DEComplexDisease")
+ (synopsis "Investigations of complex diseases by bi-clustering analysis")
+ (description
+ "@code{DEComplexDisease} is designed to find the @acronym{DEGs, Differential
+Expressed Genes} for complex disease, which is characterized by the heterogeneous
+genomic expression profiles. Different from the established DEG analysis tools,
+it does not assume the patients of complex diseases to share the common DEGs.
+By applying a bi-clustering algorithm, @code{DEComplexDisease} finds the DEGs
+shared by as many patients. Applying the @code{DEComplexDisease} analysis
+results, users are possible to find the patients affected by the same mechanism
+based on the shared signatures.")
+ (license license:gpl3)))
+
(define-public r-deconvr
(package
(name "r-deconvr")
--
2.38.0