[PATCH] gnu: Add onedrive.

  • Done
  • quality assurance status badge
Details
One participant
  • Efraim Flashner
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 29 Oct 2022 22:50
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
47607d2a13da204c339a98f998a9d3d1c5b0fd25.1667076594.git.efraim@flashner.co.il
* gnu/packages/sync.scm (onedrive): New variable.
---
gnu/packages/sync.scm | 65 ++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 64 insertions(+), 1 deletion(-)

Toggle diff (103 lines)
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 8c174c98ba..8330b96dd7 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015-2020, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2021 Ludovic Courtès <ludo@gnu.org>
@@ -31,6 +31,8 @@ (define-module (gnu packages sync)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
#:use-module (guix build-system qt)
+ #:use-module (guix gexp)
+ #:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix packages)
@@ -38,10 +40,12 @@ (define-module (gnu packages sync)
#:use-module (gnu packages acl)
#:use-module (gnu packages adns)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages dlang)
#:use-module (gnu packages documentation)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
@@ -359,6 +363,65 @@ (define-public owncloud-client
silently and reliably flow across to every other.")
(license license:gpl2+)))
+(define-public onedrive
+ (package
+ (name "onedrive")
+ (version "2.4.21")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abraunegg/onedrive")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04rnkc6ap9mkghvlj102f2gvnjqg3bs4vw9q3wm869fsflnm3599"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "--enable-completions"
+ "--enable-notifications"
+ (string-append "--with-zsh-completion-dir="
+ #$output "/share/zsh/site-functions")
+ (string-append "--with-fish-completion-dir="
+ #$output "/share/fish/vendor_completions.d"))
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'link-to-external-libraries
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "DCFLAGS" (string-append
+ ;; The default linker is ld.gold.
+ "--linker=\"\" "
+ ;; Only link necessary libraries.
+ "-L--as-needed "))))
+ (add-after 'configure 'adjust-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("-L/gnu") "-Wl,-rpath=/gnu")
+ (("-O ") "-O2 "))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./onedrive" "--version")))))))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list bash-minimal
+ curl-minimal
+ ldc
+ libnotify
+ sqlite))
+ (home-page "https://abraunegg.github.io")
+ (synopsis "Client for OneDrive")
+ (description "OneDrive Client which supports OneDrive Personal, OneDrive for
+Business, OneDrive for Office365 and SharePoint and fully supports Azure
+National Cloud Deployments. It supports one-way and two-way sync capabilities
+and securely connects to Microsoft OneDrive services.")
+ (license license:gpl3)))
+
(define-public lsyncd
(package
(name "lsyncd")

base-commit: 34e6c5d4280d67729bbd8cdae333ca5e0bd580f5
--
2.38.0
E
E
Efraim Flashner wrote on 15 Nov 2022 09:26
(address . 58876-done@debbugs.gnu.org)
Y3NNMGvb8XeXRkz2@3900XT
Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmNzTTAACgkQQarn3Mo9
g1ENBw//fwk7GN3qUnqAa+pm0StBSNJnTiWWDqy1lp6npz2kkYbol/6teNfdVJM/
8IrEn9rsKNAKsOTGbKAZ55w9G3Sf9fLNAFEMWmwmcRxZ3pFD3wUaSeCZKznR2AST
Q5cpYoiWhj7AjTrbVzb7oE9SsmHdosBJdKQFfQhRasZJ0fYQIZ/O//njRo80aYv6
PN5At2vV0LpQh7dfPZdHBx/fNpnQXW24dyFQcefSlICgJIQ4z9BXPccSwVdWkoYa
cWnXbf2/rJl2NdSVfSuAZN8Vr10xoHhqbjUQqL8sUr13QBIjl32eomq0aFm+FHEm
ytJTvh0B9V1bb2G4YWrrxcKLAJB6RPNfRps9SD5lhKbFkWIibMrFXEni3jEBNeNv
nDmkp1UjUqQju9BGRaoPpB8E7zDACZ5+uBWvwgKBbDRutDmFWSTJ4p39NLzjhGnm
zIZZGQQsWfJFV97/tNRIFdMK5Mf902vvtNnq8chP/vhXtlHZP9NfVPY/aZ4QiQqB
mQsvqZeVlzszdYX+u/QDfgFe2JZGak7jGtPtfdWCKFbEFkdqb1fBU4jauy9LzE/R
5PBORJNNoCaqz1NG45mp8Hu8BzM93SygG4uHdlKYe/GyTYPQLKSgnnI3VBi+tw+/
dxHWWFoTvRosDG2Lt5Y5OkCVpgYhMiPfxjQYOQ1Le9fqogKbi4A=
=+8gL
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58876@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58876
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch