[PATCH 5/5] python-gaphor: New package

  • Open
  • quality assurance status badge
Details
2 participants
  • jgart
  • Jacob Hrbek
Owner
unassigned
Submitted by
Jacob Hrbek
Severity
normal
J
J
Jacob Hrbek wrote on 29 Oct 2022 18:59
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
m215aoQQvrbYbejl7Z2HT-TVKoR_7NYfYaPUUh7PL7iGbTziS2NN1IJe9HTbI2BiEjEe-I6gYZEPmDOdJUuToyCAoDkVxDWpa-oHKqKZf2M=@rixotstudio.cz
Whee
Attachment: file
J
J
Jacob Hrbek wrote on 29 Oct 2022 19:08
[PATCH 1/4] python-gaphas: New package
(address . 58868@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20221029170753.26674-1-kreyren@rixotstudio.cz
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8343f9e907..fcfea2d99c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30854,6 +30854,27 @@ (define-public python-langcodes
install @code{python-language-data}.")
(license license:expat)))

+(define-public python-gaphas
+ (package
+ (name "python-gaphas")
+ (version "3.8.2")
+ (synopsis "Gaphas is a GTK+ based diagramming widget")
+ (description "Gaphas is a GTK+ based diagramming widget")
+ (home-page "https://gaphas.readthedocs.io")
+ (license license:asl2.0)
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "gaphas" version))
+ (sha256
+ (base32
+ "0ikaz455g8cfr7h66xlksim8kala3h0g36ij5zcz76vhyd3f1baa"))))
+ (build-system python-build-system)
+ (inputs (list python-pycairo ;pycairo<2.0.0,>=1.20.0
+ python-pygobject)) ;PyGObject<4.0.0,>=3.38.0
+ (arguments
+ ;; FIXME: python-build-system needs update for the check to work: 'Testing via this command is deprecated and will be removed in a future version. Users looking for a generic test entry point independent of test runner are encouraged to use tox'
+ `(#:tests? #f))))
+
(define-public python-geomet
(package
(name "python-geomet")
--
2.37.3
J
J
Jacob Hrbek wrote on 29 Oct 2022 19:08
[PATCH 2/4] python-darkdetect: New package
(address . 58868@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20221029170753.26674-2-kreyren@rixotstudio.cz
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fcfea2d99c..6818b50d8e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4481,6 +4481,24 @@ (define-public python-daemon
;; Only setup.py is gpl3+, everything else is apache 2.0 licensed.
(license (list license:asl2.0 license:gpl3+))))

+(define-public python-darkdetect
+ (package
+ (name "python-darkdetect")
+ (version "0.7.1")
+ (home-page "http://github.com/albertosottile/darkdetect")
+ (synopsis "Detect OS Dark Mode from Python")
+ (description "Detect OS Dark Mode from Python")
+ (license license:bsd-3)
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "darkdetect" version))
+ (sha256
+ (base32
+ "04whykmwrrw3k6084g4r2iwl063p4ckwkzxv2svdscj42gskrgj7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)))) ; AttributeError: python: undefined symbol: objc_getClass
+
(define-public python-anytree
(package
(name "python-anytree")
--
2.37.3
J
J
Jacob Hrbek wrote on 29 Oct 2022 19:08
[PATCH 3/4] python-better-exceptions: New package
(address . 58868@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20221029170753.26674-3-kreyren@rixotstudio.cz
---
gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6818b50d8e..d9abe8b1d4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9696,6 +9696,25 @@ (define-public python-beautifulsoup4
converts incoming documents to Unicode and outgoing documents to UTF-8.")
(license license:expat)))

+(define-public python-better-exceptions
+ (package
+ (name "python-better-exceptions")
+ (version "0.3.3")
+ (synopsis "Pretty and helpful exceptions, automatically")
+ (description "Pretty and helpful exceptions, automatically")
+ (home-page "https://github.com/qix-/better-exceptions")
+ (license license:expat)
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "better_exceptions" version))
+ (sha256
+ (base32
+ "0fs5nfg7xdbx5hb1h1148kax68g9wn0h7cclx3k08psd8hcbrrp4"))))
+ (build-system python-build-system)
+ (arguments
+ ;; FIXME: python-build-system needs update for the check to work: 'Testing via this command is deprecated and will be removed in a future version. Users looking for a generic test entry point independent of test runner are encouraged to use tox'
+ `(#:tests? #f))))
+
(define-public python-soupsieve
(package
(name "python-soupsieve")
--
2.37.3
J
J
Jacob Hrbek wrote on 29 Oct 2022 19:08
[PATCH 4/4] python-gaphor: New package
(address . 58868@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20221029170753.26674-4-kreyren@rixotstudio.cz
---
gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d9abe8b1d4..cff0879a4d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30912,6 +30912,41 @@ (define-public python-gaphas
;; FIXME: python-build-system needs update for the check to work: 'Testing via this command is deprecated and will be removed in a future version. Users looking for a generic test entry point independent of test runner are encouraged to use tox'
`(#:tests? #f))))

+(define-public python-gaphor
+ (package
+ (name "python-gaphor")
+ (version "2.12.1")
+ (synopsis "Gaphor is the simple modeling tool written in Python")
+ (description "Gaphor is the simple modeling tool written in Python")
+ (home-page "https://gaphor.org")
+ (license license:asl2.0)
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "gaphor" version))
+ (sha256
+ (base32
+ "0hls6fd6vkz4dslr8agy0dpjmbyprj41r4vgp7nwr3ijcjcnwaph"))))
+ (build-system python-build-system)
+ (inputs (list python-tinycss2 ;tinycss2<2.0.0,>=1.0.2
+ python-pycairo ;pycairo<2.0,>=1.18
+ python-jedi ;jedi<0.19.0,>=0.18.1
+ python-generic ;generic<2.0.0,>=1.0.0
+ python-gaphas ;gaphas<4.0.0,>=3.1.0
+ python-darkdetect ;darkdetect<0.8.0,>=0.5.1
+ python-better-exceptions ;better-exceptions<0.4.0,>=0.3.3
+ python-pygobject ;PyGObject<4.0,>=3.30
+ python-exceptiongroup ;exceptiongroup<2.0.0,>=1.0.0-rc.5
+ ;; Required for 'check' and/or 'sanity-check' phase
+ pango ;gi.require_version("Pango", "1.0")
+ gtk+
+ gtksourceview
+ libadwaita))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ ;; FIXME: Both 'check' and 'sanity-check' phases removed due to 'TypeError: must be an interface' hypothesis that it's trying to launch a window during a check phase which is not possible due to how guix works
+ (delete 'check)
+ (delete 'sanity-check))))))
+
(define-public python-geomet
(package
(name "python-geomet")
--
2.37.3
J
J
Jacob Hrbek wrote on 29 Oct 2022 19:10
Re: [PATCH 1/4] python-gaphas: New package
(address . 58868@debbugs.gnu.org)
oSsnuhkykAmHyasgX7C_RLYKjnwIPQ1EuGeaZkRBBHCs0p52VI7iM7pZx5Ev6ZJVAcgE1xwv2yDr-8EyLMq7jeVcaAs3xfDSMlq1h84eVyM=@rixotstudio.cz
The dependencies and the package itself builds, but it doesn't run and I don't know how to fix it..

CC mentors

-- Jacob "Kreyren" Hrbek

Sent with Proton Mail secure email.

------- Original Message -------
On Saturday, October 29th, 2022 at 7:08 PM, Jacob Hrbek <kreyren@rixotstudio.cz> wrote:


Toggle quote (40 lines)
> ---
> gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
> 1 file changed, 21 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 8343f9e907..fcfea2d99c 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -30854,6 +30854,27 @@ (define-public python-langcodes
> install @code{python-language-data}.")
> (license license:expat)))
>
> +(define-public python-gaphas
> + (package
> + (name "python-gaphas")
> + (version "3.8.2")
> + (synopsis "Gaphas is a GTK+ based diagramming widget")
> + (description "Gaphas is a GTK+ based diagramming widget")
> + (home-page "https://gaphas.readthedocs.io")
> + (license license:asl2.0)
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "gaphas" version))
> + (sha256
> + (base32
> + "0ikaz455g8cfr7h66xlksim8kala3h0g36ij5zcz76vhyd3f1baa"))))
> + (build-system python-build-system)
> + (inputs (list python-pycairo ;pycairo<2.0.0,>=1.20.0
>
> + python-pygobject)) ;PyGObject<4.0.0,>=3.38.0
>
> + (arguments
> + ;; FIXME: python-build-system needs update for the check to work: 'Testing via this command is deprecated and will be removed in a future version. Users looking for a generic test entry point independent of test runner are encouraged to use tox'
> + `(#:tests? #f))))
> +
> (define-public python-geomet
> (package
> (name "python-geomet")
> --
> 2.37.3
J
J
Jacob Hrbek wrote on 29 Oct 2022 19:16
[PATCH 1/5] python-generic: New Package
(address . 58868@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20221029171559.3332-1-kreyren@rixotstudio.cz
---
gnu/packages/python-xyz.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1c2f9d7b73..8343f9e907 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30874,6 +30874,23 @@ (define-public python-geomet
versa. Extended WKB/WKT are also supported.")
(license license:asl2.0)))

+(define-public python-generic
+ (package
+ (name "python-generic")
+ (version "1.1.0")
+ (home-page "https://generic.readthedocs.io/")
+ (synopsis "Generic programming library for Python")
+ (description "Generic programming library for Python")
+ (license license:bsd-3)
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "generic" version))
+ (sha256
+ (base32
+ "1q0gjinxyl3wingag6fk5fv5l098ng5skz8himk3wj6r9fh3pppz"))))
+ (build-system python-build-system)
+ (inputs (list python-exceptiongroup)))) ;; Needed for 'sanity-check' phase
+
(define-public python-bsdiff4
(package
(name "python-bsdiff4")
--
2.37.3
J
J
Jacob Hrbek wrote on 29 Oct 2022 19:17
(address . 58868@debbugs.gnu.org)
xTwYP9r1Z4npYz2tn0Hj7YWj81wyOORKPd6OiBfHosN3ossvikgvFudVqIK6UAlfhPhZZKeIe3ehv-8333w0F7eLgendzFhJfjXvwIuP7hE=@rixotstudio.cz
missed one patch

-- Jacob "Kreyren" Hrbek

Sent with Proton Mail secure email.

------- Original Message -------
On Saturday, October 29th, 2022 at 7:16 PM, Jacob Hrbek <kreyren@rixotstudio.cz> wrote:


Toggle quote (34 lines)
> ---
> gnu/packages/python-xyz.scm | 17 +++++++++++++++++
> 1 file changed, 17 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 1c2f9d7b73..8343f9e907 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -30874,6 +30874,23 @@ (define-public python-geomet
> versa. Extended WKB/WKT are also supported.")
> (license license:asl2.0)))
>
> +(define-public python-generic
> + (package
> + (name "python-generic")
> + (version "1.1.0")
> + (home-page "https://generic.readthedocs.io/")
> + (synopsis "Generic programming library for Python")
> + (description "Generic programming library for Python")
> + (license license:bsd-3)
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "generic" version))
> + (sha256
> + (base32
> + "1q0gjinxyl3wingag6fk5fv5l098ng5skz8himk3wj6r9fh3pppz"))))
> + (build-system python-build-system)
> + (inputs (list python-exceptiongroup)))) ;; Needed for 'sanity-check' phase
> +
> (define-public python-bsdiff4
> (package
> (name "python-bsdiff4")
> --
> 2.37.3
J
Re: [PATCH 5/5] python-gaphor: New package
(address . 58868@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
87ikxpomaz.fsf@dismail.de
Hi Jacob,

Thanks for the contribution!

Would you be interested in sending an update for 4.0 for gaphor?


--
Best regards,
jgart
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 58868@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58868
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch