---
gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
Toggle diff (46 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d9abe8b1d4..cff0879a4d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30912,6 +30912,41 @@ (define-public python-gaphas
;; FIXME: python-build-system needs update for the check to work: 'Testing via this command is deprecated and will be removed in a future version. Users looking for a generic test entry point independent of test runner are encouraged to use tox'
`(#:tests? #f))))
+(define-public python-gaphor
+ (package
+ (name "python-gaphor")
+ (version "2.12.1")
+ (synopsis "Gaphor is the simple modeling tool written in Python")
+ (description "Gaphor is the simple modeling tool written in Python")
+ (home-page "https://gaphor.org")
+ (license license:asl2.0)
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "gaphor" version))
+ (sha256
+ (base32
+ "0hls6fd6vkz4dslr8agy0dpjmbyprj41r4vgp7nwr3ijcjcnwaph"))))
+ (build-system python-build-system)
+ (inputs (list python-tinycss2 ;tinycss2<2.0.0,>=1.0.2
+ python-pycairo ;pycairo<2.0,>=1.18
+ python-jedi ;jedi<0.19.0,>=0.18.1
+ python-generic ;generic<2.0.0,>=1.0.0
+ python-gaphas ;gaphas<4.0.0,>=3.1.0
+ python-darkdetect ;darkdetect<0.8.0,>=0.5.1
+ python-better-exceptions ;better-exceptions<0.4.0,>=0.3.3
+ python-pygobject ;PyGObject<4.0,>=3.30
+ python-exceptiongroup ;exceptiongroup<2.0.0,>=1.0.0-rc.5
+ ;; Required for 'check' and/or 'sanity-check' phase
+ pango ;gi.require_version("Pango", "1.0")
+ gtk+
+ gtksourceview
+ libadwaita))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ ;; FIXME: Both 'check' and 'sanity-check' phases removed due to 'TypeError: must be an interface' hypothesis that it's trying to launch a window during a check phase which is not possible due to how guix works
+ (delete 'check)
+ (delete 'sanity-check))))))
+
(define-public python-geomet
(package
(name "python-geomet")