[PATCH] gnu: Add python-neovim-remote.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • ギャラ
Owner
unassigned
Submitted by
ギャラ
Severity
normal

Debbugs page

ギャラ wrote 2 years ago
(address . guix-patches@gnu.org)(name . ギャラ)(address . me@gyara.moe)
9d3e8bde70c662e08f4af3cf41f29dbae38d30ae.1667007347.git.me@gyara.moe
* gnu/packages/vim.scm (python-neovim-remote): New variable.
---
gnu/packages/vim.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index ed24c39be2..20ca44e9cb 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -40,6 +40,7 @@ (define-module (gnu packages vim)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (gnu packages)
#:use-module (gnu packages acl)
#:use-module (gnu packages admin) ; For GNU hostname
@@ -924,6 +925,25 @@ (define-public python-pynvim
through its msgpack-rpc API.")
(license license:asl2.0)))
+(define-public python-neovim-remote
+ (package
+ (name "python-neovim-remote")
+ (version "2.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "neovim-remote" version))
+ (sha256
+ (base32
+ "00kxlb3f1k7iaxzpsr07scavmnyg8c1jmicmr13mfk2lcdac6g2b"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-psutil python-pynvim))
+ (home-page "https://github.com/mhinz/neovim-remote")
+ (synopsis "Control nvim processes using `nvr` commandline tool")
+ (description "This package provide a `nvr` command, which can open File
+in remote nvim. Also allow opening files from within :terminal without
+starting a nested nvim process.")
+ (license license:expat)))
+
(define-public vim-guix-vim
(package
(name "vim-guix-vim")
--
2.38.0
Christopher Baines wrote 2 years ago
(name . ギャラ)(address . me@gyara.moe)
87y1spisc4.fsf@cbaines.net
ギャラ via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (5 lines)
> * gnu/packages/vim.scm (python-neovim-remote): New variable.
> ---
> gnu/packages/vim.scm | 20 ++++++++++++++++++++
> 1 file changed, 20 insertions(+)

Looks good to me, I've pushed this to master as
8139322b8adf4d51badb598b123de600b2ab1682.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNmQQtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfqHBAAuaWgywCLdfSBLOENOEIOif1IHfzEpO+N
r24ZfLuT2USuOjUFCyG/gWjA3+fVAKRwmnRw/r/RVYSO0JBG5s49IZF6yp6saoZI
wz/QGee2CF2pY1qjtDjU0HWJ0G/uA/Cmk0PVqsUKrvYc8BGtji5baFwqq8NXGLNn
A497P6kBOvzBG18ssjC/kAGUiDVlsSHnv63s6crK9nxzweUKFnktnubJBldwpuOX
iTp7WWYZn8ZbuM69CtW483f5vPqeryd0vcale2uYA5GQtCTPSQK9apsCSEWfNgmG
9/Yw1zWC4GKmIIquGl/RSO0MhaDfDYZsV/TCVqC+aPpw7orTkXFhEQIQjUlP79di
oblAgpkhrg534xD63rdAfqntZhC+RQSjoX7OB1urrejV19d+s8j7CwBuFNsRqavS
7b89CCZ0FjaVxmyuke81WrYgpdt8/fcbKGKGSF31q/BlDNORzt5BgJasKxdXIMp/
hOSitaas7eEFpPq0JHYkIDrJpyFdKeLspndE7e3OnxpZJjnaFH60W1yXZiBZlfkl
kzGVPSiE6YEdXZwgdLr/nt2uj/r7xW811o7DEK4NqsxapsUpCzsQu9FgopLd1e2q
b7T//ddvaNPbYnK4DwQXBS67nd8DCNKA88xPO/60Gla8QWBuT4nNPt67E4pAmull
bPqExfwWoc0=
=VZSj
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 58851@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58851
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help