repl ignores modules from the channel added to time-machine

  • Open
  • quality assurance status badge
Details
3 participants
  • alexander barakin (aka sash-kan)
  • Ludovic Courtès
  • zimoun
Owner
unassigned
Submitted by
alexander barakin (aka sash-kan)
Severity
normal
A
A
alexander barakin (aka sash-kan) wrote on 28 Oct 2022 18:27
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
13761666972940@mail.yandex.ru
Attachment: file
## current configuration:
$ guix describe --format=channels
(list (channel
(name 'guix)
(branch "master")
(commit
"a0751e3250dfea7e52468c8090e18c3118d93a60")
(introduction
(make-channel-introduction
"9edb3f66fd807b096b48283debdcddccfea34bad"
(openpgp-fingerprint
"BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A 54FA")))))

## add guix-hpc channel (for illustration purposes only; you can use any other channel):
$ cat channels.scm
(list
(channel
(name 'guix-hpc)
(channel
(name 'guix)
(branch "master")
(commit
"a0751e3250dfea7e52468c8090e18c3118d93a60")
(introduction
(make-channel-introduction
"9edb3f66fd807b096b48283debdcddccfea34bad"
(openpgp-fingerprint
"BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A 54FA")))))

## both channels - guix and guix-hpc - are available:
$ guix time-machine --channels=channels.scm -- describe
guix a0751e3
branch: master
commit: a0751e3250dfea7e52468c8090e18c3118d93a60
guix-hpc 1a6af9f
branch: master
commit: 1a6af9f0154f57dc5a31bf535bb09db63e3a8d03

## but repl does not see guix-hpc modules:
$ guix time-machine --channels=channels.scm -- repl
...
scheme@(guix-user)> (use-modules (airbus solvers))
While compiling expression:
no code for module (airbus solvers)
scheme@(guix-user)> %load-path
$1 = ("/gnu/store/dfm3k2qc0s4f8vi5il3gvrr0650p65k3-guix-module-union/share/guile/site/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/site/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/site" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile" "/home/user/.guix-profile/share/guile/site/3.0" "/home/user/.guix-profile/share/guile/site/3.0")
A
A
alexander barakin (aka sash-kan) wrote on 28 Oct 2022 20:28
Re: bug#58841: Acknowledgement (repl ignores modules from the channel added to time-machine)
(address . 58841@debbugs.gnu.org)
20221028182837.lhekfbub2deshbia@barak.in
explanation:

## current configuration:
$ guix describe --format=channels
(list (channel
(name 'guix)
(branch "master")
(commit
"a0751e3250dfea7e52468c8090e18c3118d93a60")
(introduction
(make-channel-introduction
"9edb3f66fd807b096b48283debdcddccfea34bad"
(openpgp-fingerprint
"BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A 54FA")))))

## add guix-hpc channel (for illustration purposes only; you can use any other channel):
$ cat channels.scm
(list
(channel
(name 'guix-hpc)
(channel
(name 'guix)
(branch "master")
(commit
"a0751e3250dfea7e52468c8090e18c3118d93a60")
(introduction
(make-channel-introduction
"9edb3f66fd807b096b48283debdcddccfea34bad"
(openpgp-fingerprint
"BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A 54FA")))))

## both channels - guix and guix-hpc - are available:
$ guix time-machine --channels=channels.scm -- describe
guix a0751e3
branch: master
commit: a0751e3250dfea7e52468c8090e18c3118d93a60
guix-hpc 1a6af9f
branch: master
commit: 1a6af9f0154f57dc5a31bf535bb09db63e3a8d03

## but repl does not see guix-hpc modules:
$ guix time-machine --channels=channels.scm -- repl
...
scheme@(guix-user)> (use-modules (airbus solvers))
While compiling expression:
no code for module (airbus solvers)
scheme@(guix-user)> %load-path
$1 = ("/gnu/store/dfm3k2qc0s4f8vi5il3gvrr0650p65k3-guix-module-union/share/guile/site/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/site/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/site" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile" "/home/user/.guix-profile/share/guile/site/3.0" "/home/user/.guix-profile/share/guile/site/3.0")

--
wbr, alexander barakin aka sash-kan.
--
i will be very thankful to you if you will use order,
that natural for the human:
first question, then the answer.
-----BEGIN PGP SIGNATURE-----

iF0EABECAB0WIQTy+QZ2YvBaypi4qLpb8Ov2Kx8BwAUCY1wfVQAKCRBb8Ov2Kx8B
wHkmAJ9jUuKe+16clXRJWBrpnkJgkWdmlwCfRboWRe7xR/bVfGOeqIHBw+fap7g=
=igdZ
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 5 Nov 2022 11:31
Re: bug#58841: repl ignores modules from the channel added to time-machine
(name . alexander barakin (aka sash-kan))(address . alex@barak.in)(address . 58841@debbugs.gnu.org)
87bkpllmk5.fsf@gnu.org
Hi Alexander,

"alexander barakin (aka sash-kan)" <alex@barak.in> skribis:

Toggle quote (9 lines)
> ## but repl does not see guix-hpc modules:
> $ guix time-machine --channels=channels.scm -- repl
> ...
> scheme@(guix-user)> (use-modules (airbus solvers))
> While compiling expression:
> no code for module (airbus solvers)
> scheme@(guix-user)> %load-path
> $1 = ("/gnu/store/dfm3k2qc0s4f8vi5il3gvrr0650p65k3-guix-module-union/share/guile/site/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/site/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/site" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile" "/home/user/.guix-profile/share/guile/site/3.0" "/home/user/.guix-profile/share/guile/site/3.0")

Currently you have to start with:

(use-modules (gnu packages))

This will set up ‘%load-path’ so that channel modules become visible.
Let me know if it works for you!

This is a bug we should fix.

HTH,
Ludo’.
A
A
alexander barakin (aka sash-kan) wrote on 5 Nov 2022 12:19
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 58841@debbugs.gnu.org)
20221105111920.z5em355j4j5qcel6@barak.in
On Sat, Nov 05, 2022 at 11:31:38AM +0100, Ludovic Courtès wrote:
Toggle quote (8 lines)
>
> Currently you have to start with:
>
> (use-modules (gnu packages))
>
> This will set up ‘%load-path’ so that channel modules become visible.
> Let me know if it works for you!

yes, it works. thank you!

Toggle quote (2 lines)
> This is a bug we should fix.

it would be nice.
or at least mention it in the documentation.

--
wbr, alexander barakin aka sash-kan.
--
i will be very thankful to you if you will use order,
that natural for the human:
first question, then the answer.
-----BEGIN PGP SIGNATURE-----

iF0EABECAB0WIQTy+QZ2YvBaypi4qLpb8Ov2Kx8BwAUCY2ZGuAAKCRBb8Ov2Kx8B
wDabAJ4icCNOjHpLF25X29zDfAXvgPkxxwCdGwhh8g4vPlXQDn5aGAExX80zP1g=
=tEIO
-----END PGP SIGNATURE-----


A
A
alexander barakin (aka sash-kan) wrote on 5 Nov 2022 13:04
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 58841@debbugs.gnu.org)
20221105120403.p3adgot5rov24m4m@barak.in
On Sat, Nov 05, 2022 at 11:31:38AM +0100, Ludovic Courtès wrote:
Toggle quote (3 lines)
>
> This is a bug we should fix.

btw, "shell" behaves similarly - only sees the "system" channel:

$ guix time-machine --channels=channels.scm -- shell -- guix describe
guix shell: warning: no packages specified; creating an empty
environment
Generation 18 Oct 25 2022 15:24:49 (current)
guix a0751e3
branch: master
commit: a0751e3250dfea7e52468c8090e18c3118d93a60

can this also be considered a bug? if so, is it worth sending a separate
bug report?

--
wbr, alexander barakin aka sash-kan.
--
i will be very thankful to you if you will use order,
that natural for the human:
first question, then the answer.
-----BEGIN PGP SIGNATURE-----

iF0EABECAB0WIQTy+QZ2YvBaypi4qLpb8Ov2Kx8BwAUCY2ZRMgAKCRBb8Ov2Kx8B
wAzpAJ0c5eAm7LF+T2AANQsHCb3xI59QKgCeO9qEDcfILwGzr/lbaiPmWa4m+zg=
=aAbp
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 5 Nov 2022 18:36
(name . alexander barakin (aka sash-kan))(address . alex@barak.in)(address . 58841@debbugs.gnu.org)
87pme1jobd.fsf@gnu.org
"alexander barakin (aka sash-kan)" <alex@barak.in> skribis:

Toggle quote (9 lines)
> On Sat, Nov 05, 2022 at 11:31:38AM +0100, Ludovic Courtès wrote:
>>
>> This is a bug we should fix.
>
> btw, "shell" behaves similarly - only sees the "system" channel:
>
> $ guix time-machine --channels=channels.scm -- shell -- guix describe
> guix shell: warning: no packages specified; creating an empty

This command is running ‘guix describe’ with the ‘guix’ command that
happens to be in $PATH; in addition, the ‘shell’ bit does nothing, as
shown by the warning above.

What you probably meant is:

guix time-machine -C channels.scm -- describe

HTH,
Ludo’.
Z
Z
zimoun wrote on 21 Jan 2023 17:18
(address . 58841@debbugs.gnu.org)
865ycz3lpg.fsf@gmail.com
Hi Ludo,

On Sat, 05 Nov 2022 at 11:31, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (9 lines)
> Currently you have to start with:
>
> (use-modules (gnu packages))
>
> This will set up ‘%load-path’ so that channel modules become visible.
> Let me know if it works for you!
>
> This is a bug we should fix.

Ah, I thought it was expected. :-) Well, my ~/.guile looks like:

Toggle snippet (11 lines)
(use-modules
(ice-9 readline)
(ice-9 format)
(ice-9 pretty-print)

(guix)
(gnu packages)
(gnu packages base))
(activate-readline)

so it avoids me this kind of annoyance.

Well, do we open another ticket or just retitle this one?


Cheers,
simon
S
S
Simon Tournier wrote on 17 Feb 2023 16:49
(address . 58841@debbugs.gnu.org)
87v8k047i2.fsf@gmail.com
Hi Ludo,

On sam., 05 nov. 2022 at 11:31, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (5 lines)
> This will set up ‘%load-path’ so that channel modules become visible.
> Let me know if it works for you!
>
> This is a bug we should fix.


Cheers,
simon
?