(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
## current configuration:
$ guix describe --format=channels
(list (channel
(name 'guix)
(branch "master")
(commit
"a0751e3250dfea7e52468c8090e18c3118d93a60")
(introduction
(make-channel-introduction
"9edb3f66fd807b096b48283debdcddccfea34bad"
(openpgp-fingerprint
"BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A 54FA")))))
## add guix-hpc channel (for illustration purposes only; you can use any other channel):
$ cat channels.scm
(list
(channel
(name 'guix-hpc)
(channel
(name 'guix)
(branch "master")
(commit
"a0751e3250dfea7e52468c8090e18c3118d93a60")
(introduction
(make-channel-introduction
"9edb3f66fd807b096b48283debdcddccfea34bad"
(openpgp-fingerprint
"BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A 54FA")))))
## both channels - guix and guix-hpc - are available:
$ guix time-machine --channels=channels.scm -- describe
guix a0751e3
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: a0751e3250dfea7e52468c8090e18c3118d93a60
guix-hpc 1a6af9f
repository URL: https://gitlab.inria.fr/guix-hpc/guix-hpc.git
branch: master
commit: 1a6af9f0154f57dc5a31bf535bb09db63e3a8d03
## but repl does not see guix-hpc modules:
$ guix time-machine --channels=channels.scm -- repl
...
scheme@(guix-user)> (use-modules (airbus solvers))
While compiling expression:
no code for module (airbus solvers)
scheme@(guix-user)> %load-path
$1 = ("/gnu/store/dfm3k2qc0s4f8vi5il3gvrr0650p65k3-guix-module-union/share/guile/site/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/site/3.0" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile/site" "/gnu/store/1jgcbdzx2ss6xv59w55g3kr3x4935dfb-guile-3.0.8/share/guile" "/home/user/.guix-profile/share/guile/site/3.0" "/home/user/.guix-profile/share/guile/site/3.0")