[PATCH] gnu: Add r-dmwr2 and r-debcam.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
4e23676adf3142d98f2120e6da966f18@mdc-berlin.de
* gnu/packages/cran.scm (r-dmwr2): New variable.
* gnu/packages/bioconductor.scm (r-debcam): New variable.
All the best!
Mădălin Ionel Patrașcu
Attachment: file
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 1/2] gnu: Add r-dmwr2.
(address . 58828@debbugs.gnu.org)
20221028050235.5355-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-dmwr2): New variable.
---
gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f969da5b3c..eb4532a62a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -402,6 +402,36 @@ (define-public r-dixontest
Gaussian quadrature for a numerical solution.")
(license license:gpl3)))
+(define-public r-dmwr2
+ (package
+ (name "r-dmwr2")
+ (version "0.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "DMwR2" version))
+ (sha256
+ (base32
+ "1vzfbz2k05j8r2hpig3d2grb99rnnh2s1sviii3prcyqicxfh0i9"))))
+ (properties `((upstream-name . "DMwR2")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-class
+ r-dbi
+ r-dplyr
+ r-quantmod
+ r-readr
+ r-rpart
+ r-xts
+ r-zoo))
+ (home-page "https://github.com/ltorgo/DMwR2")
+ (synopsis
+ "Functions and data for the second edition of \"Data Mining with R\"")
+ (description
+ "This package provides functions and data accompanying the second edition
+of the book \"Data Mining with R, learning with case studies\" by Luis Torgo,
+published by CRC Press.")
+ (license license:gpl2+)))
+
(define-public r-emdist
(package
(name "r-emdist")

base-commit: ac51b9c86d58cfdb13ee643a2fdc8e979939a260
--
2.38.0
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 2/2] gnu: Add r-debcam.
(address . 58828@debbugs.gnu.org)
20221028050235.5355-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-debcam): New variable.
---
gnu/packages/bioconductor.scm | 40 +++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b8535250f9..994b3b0137 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -48,6 +48,7 @@ (define-module (gnu packages bioconductor)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages image)
+ #:use-module (gnu packages java)
#:use-module (gnu packages maths)
#:use-module (gnu packages netpbm)
#:use-module (gnu packages python)
@@ -3051,6 +3052,45 @@ (define-public r-dearseq
set analyses, and can deal with repeated or longitudinal data.")
(license license:gpl2)))
+(define-public r-debcam
+ (package
+ (name "r-debcam")
+ (version "1.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "debCAM" version))
+ (sha256
+ (base32
+ "1ynz57kkxl8nx80zhh1vhhydqb5n6r9d7p69f0k9nj8rp4hdgng7"))))
+ (properties `((upstream-name . "debCAM")))
+ (build-system r-build-system)
+ (inputs (list openjdk))
+ (propagated-inputs
+ (list r-apcluster
+ r-biobase
+ r-biocparallel
+ r-corpcor
+ r-dmwr2
+ r-geometry
+ r-nmf
+ r-nnls
+ r-pcapp
+ r-rjava
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/debCAM")
+ (synopsis "Deconvolution by convex analysis of mixtures")
+ (description
+ "This package is an R implementation for fully unsupervised deconvolution
+of complex tissues. @code{DebCAM} provides basic functions to perform unsupervised
+deconvolution on mixture expression profiles by @acronym{CAM, Convex Analysis
+of Mixtures} and some auxiliary functions to help understand the subpopulation-
+specific results. It also implements functions to perform supervised deconvolution
+based on prior knowledge of molecular markers, S matrix or A matrix. Combining
+molecular markers from CAM and from prior knowledge can achieve semi-supervised
+deconvolution of mixtures.")
+ (license license:gpl2)))
+
(define-public r-decipher
(package
(name "r-decipher")
--
2.38.0
Ricardo Wurmus wrote 2 years ago
Re: [bug#58828] [PATCH 1/2] gnu: Add r-dmwr2.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 58828-done@debbugs.gnu.org)
87o7twf5tp.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-dmwr2): New variable.

Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58828@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58828
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help