[PATCH] gnu: Add r-dama and r-damefinder.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
91ee903b139e44e9a75ec5fd17386b0c@mdc-berlin.de
* gnu/packages/bioconductor.scm ( r-dama and r-damefinder): New variables.


Unrelated patches, added in the alphabetical order.


All the best,

Mădălin-Ionel!
Attachment: file
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 2/2] gnu: Add r-damefinder.
(address . 58827@debbugs.gnu.org)
20221028025353.2281-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-damefinder): New variable.
---
gnu/packages/bioconductor.scm | 41 +++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 9f79954d8d..81918e4fe6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3036,6 +3036,47 @@ (define-public r-dama
microarray data.")
(license license:gpl2+)))
+(define-public r-damefinder
+ (package
+ (name "r-damefinder")
+ (version "1.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DAMEfinder" version))
+ (sha256
+ (base32
+ "123ra94bij0m45j2fzqr7fjipj4ld9kgk0kir1zfdbbd5h8h4mdf"))))
+ (properties `((upstream-name . "DAMEfinder")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocgenerics
+ r-biostrings
+ r-bumphunter
+ r-cowplot
+ r-genomeinfodb
+ r-genomicalignments
+ r-genomicranges
+ r-ggplot2
+ r-iranges
+ r-limma
+ r-plyr
+ r-readr
+ r-reshape2
+ r-rsamtools
+ r-s4vectors
+ r-stringr
+ r-summarizedexperiment
+ r-variantannotation))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/DAMEfinder")
+ (synopsis "Differential allelicly methylated regions")
+ (description
+ "This package offers functionality for taking methtuple or @code{bismark}
+outputs to calculate @acronym{ASM, Allele-Specific Methylation} scores and compute
+@acronym{DAMEs, Differential Allelicly MEthylated regions}. It also offers nice
+visualization of methyl-circle plots.")
+ (license license:expat)))
+
(define-public r-dearseq
(package
(name "r-dearseq")
--
2.38.0
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 1/2] gnu: Add r-dama.
(address . 58827@debbugs.gnu.org)
20221028025353.2281-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-dama): New variable.
---
gnu/packages/bioconductor.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b8535250f9..9f79954d8d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3013,6 +3013,29 @@ (define-public r-cummerbund
used visualizations.")
(license license:artistic2.0)))
+(define-public r-dama
+ (package
+ (name "r-dama")
+ (version "1.68.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "daMA" version))
+ (sha256
+ (base32
+ "1mpjvl24wsdmpgra3iasgfvy29m71318gj6j1gg6081w0n4cq72m"))))
+ (properties `((upstream-name . "daMA")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-mass))
+ (home-page "https://bioconductor.org/packages/release/bioc/html/daMA.html")
+ ;; http://www.microarrays.med.uni-goettingen.de - domain not found
+ (synopsis
+ "Efficient design and analysis of factorial two-colour microarray data")
+ (description
+ "This package contains functions for the efficient design of factorial two-
+colour microarray experiments and for the statistical analysis of factorial
+microarray data.")
+ (license license:gpl2+)))
+
(define-public r-dearseq
(package
(name "r-dearseq")

base-commit: ac51b9c86d58cfdb13ee643a2fdc8e979939a260
--
2.38.0
Ricardo Wurmus wrote 2 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 58827-done@debbugs.gnu.org)
87sfj8f5um.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-dama): New variable.

Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58827@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58827
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help