(address . bug-guix@gnu.org)
Hello,
here's the error:
```
guix/import/crate.scm:283:18: In procedure dependency-name+version:
In procedure struct-vtable: Wrong type argument in position 1 (expecting
struct): #f
```
I guess the issue is that cranelift-codegen is memoized with (mproc
"cranelift-codegen" #:version "0.68.0" #:repo #f …) , where repo is
false. but it seems to have a repo on the page?
I'll try and work towards a fix sometime next month, but I'd be glad
for some pointers.
Thank you,
Abhishek.
Backtrace:
In guix/import/utils.scm:
584:33 19 (lookup-node "cranelift-codegen" "0.68.0")
In guix/memoization.scm:
98:0 18 (mproc "cranelift-codegen" #:version "0.68.0" #:repo #f …)
In unknown file:
17 (_ #<procedure 7fe03a96c720 at guix/memoization.scm:17…> …)
In guix/import/crate.scm:
300:28 16 (crate->guix-package "cranelift-codegen" #:version _ # _ …)
292:10 15 (sort-map-dependencies _)
In srfi/srfi-1.scm:
586:29 14 (map1 _)
586:29 13 (map1 _)
586:29 12 (map1 _)
586:29 11 (map1 _)
586:29 10 (map1 _)
586:29 9 (map1 _)
586:29 8 (map1 _)
586:29 7 (map1 _)
586:29 6 (map1 _)
586:29 5 (map1 _)
586:29 4 (map1 _)
586:29 3 (map1 _)
586:29 2 (map1 _)
586:17 1 (map1 (#<<crate-dependency> id: "peepmatic" kind: no…> …))
In guix/import/crate.scm:
283:18 0 (dependency-name+version _)