guix import crate -r zellij fails

  • Open
  • quality assurance status badge
Details
2 participants
  • Abhishek Cherath
  • (
Owner
unassigned
Submitted by
Abhishek Cherath
Severity
normal
Merged with
A
A
Abhishek Cherath wrote on 26 Oct 2022 05:51
(address . bug-guix@gnu.org)
52eb36fa-3a07-489d-4fb0-1e7368a5666e@quic.us
Hello,

here's the error:

```
guix/import/crate.scm:283:18: In procedure dependency-name+version:
In procedure struct-vtable: Wrong type argument in position 1 (expecting
struct): #f
```

I guess the issue is that cranelift-codegen is memoized with (mproc
"cranelift-codegen" #:version "0.68.0" #:repo #f …) , where repo is
false. but it seems to have a repo on the page?

I'll try and work towards a fix sometime next month, but I'd be glad
for some pointers.

Thank you,
Abhishek.
Backtrace:
In guix/import/utils.scm:
584:33 19 (lookup-node "cranelift-codegen" "0.68.0")
In guix/memoization.scm:
98:0 18 (mproc "cranelift-codegen" #:version "0.68.0" #:repo #f …)
In unknown file:
17 (_ #<procedure 7fe03a96c720 at guix/memoization.scm:17…> …)
In guix/import/crate.scm:
300:28 16 (crate->guix-package "cranelift-codegen" #:version _ # _ …)
292:10 15 (sort-map-dependencies _)
In srfi/srfi-1.scm:
586:29 14 (map1 _)
586:29 13 (map1 _)
586:29 12 (map1 _)
586:29 11 (map1 _)
586:29 10 (map1 _)
586:29 9 (map1 _)
586:29 8 (map1 _)
586:29 7 (map1 _)
586:29 6 (map1 _)
586:29 5 (map1 _)
586:29 4 (map1 _)
586:29 3 (map1 _)
586:29 2 (map1 _)
586:17 1 (map1 (#<<crate-dependency> id: "peepmatic" kind: no…> …))
In guix/import/crate.scm:
283:18 0 (dependency-name+version _)
A
(
CNWS3IJYO308.1HCOET67GM1FD@guix-framework
On Thu Oct 27, 2022 at 2:31 PM BST, Abhishek Cherath wrote:
Toggle quote (2 lines)
> This is a duplicate of https://issues.guix.gnu.org/57189,

You can merge the two issues by sending the following to control@debbugs.gnu.org:

merge nnnnn nnnnn
thanks

-- (
A
A
Abhishek Cherath wrote on 29 Oct 2022 00:32
(no subject)
(address . control@debbugs.gnu.org)
1b16f8b0-9906-18c1-bf43-b03ae735ccab@quic.us
merge 57189 58785
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 58785@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58785
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch