(address . guix-patches@gnu.org)
It seems to frequently fail on i686-linux and aarch64-linux.
* gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Skip the
elements/camerabin test on i686-linux and aarch64-linux.
---
gnu/packages/gstreamer.scm | 8 ++++++++
1 file changed, 8 insertions(+)
Toggle diff (21 lines)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index a92588a9e2..c211816bf8 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -791,6 +791,14 @@ (define-public gst-plugins-bad
;; FIXME: Why is this failing.
((".*elements/dash_mpd\\.c.*") "")
+ #$@(if (member (%current-system)
+ '("i686-linux" "aarch64-linux"))
+ ;; This test is flaky:
+ ;; https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1244
+ `((("'elements/camerabin\\.c'\\]\\],")
+ "'elements/camerabin.c'], true, ],"))
+ '())
+
;; These tests are flaky and occasionally time out:
;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/932
((".*elements/curlhttpsrc\\.c.*") "")
--
2.37.3