[PATCH] gnu: gst-plugins-bad: Skip elements/camerabin test on some systems.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 25 Oct 2022 12:49
(address . guix-patches@gnu.org)
20221025104938.3474-1-mail@cbaines.net
It seems to frequently fail on i686-linux and aarch64-linux.

* gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Skip the
elements/camerabin test on i686-linux and aarch64-linux.
---
gnu/packages/gstreamer.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index a92588a9e2..c211816bf8 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -791,6 +791,14 @@ (define-public gst-plugins-bad
;; FIXME: Why is this failing.
((".*elements/dash_mpd\\.c.*") "")
+ #$@(if (member (%current-system)
+ '("i686-linux" "aarch64-linux"))
+ ;; This test is flaky:
+ ;; https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1244
+ `((("'elements/camerabin\\.c'\\]\\],")
+ "'elements/camerabin.c'], true, ],"))
+ '())
+
;; These tests are flaky and occasionally time out:
;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/932
((".*elements/curlhttpsrc\\.c.*") "")
--
2.37.3
L
L
Liliana Marie Prikler wrote on 25 Oct 2022 21:10
740b9968f34157818a34452c20db878e8095af4e.camel@gmail.com
Am Dienstag, dem 25.10.2022 um 11:49 +0100 schrieb Christopher Baines:
Toggle quote (29 lines)
> It seems to frequently fail on i686-linux and aarch64-linux.
>
> * gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Skip the
> elements/camerabin test on i686-linux and aarch64-linux.
> ---
>  gnu/packages/gstreamer.scm | 8 ++++++++
>  1 file changed, 8 insertions(+)
>
> diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
> index a92588a9e2..c211816bf8 100644
> --- a/gnu/packages/gstreamer.scm
> +++ b/gnu/packages/gstreamer.scm
> @@ -791,6 +791,14 @@ (define-public gst-plugins-bad
>                    ;; FIXME: Why is this failing.
>                    ((".*elements/dash_mpd\\.c.*") "")
>  
> +                  #$@(if (member (%current-system)
> +                                 '("i686-linux" "aarch64-linux"))
> +                         ;; This test is flaky:
> +                         ;;
> https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1244
> +                         `((("'elements/camerabin\\.c'\\]\\],")
> +                            "'elements/camerabin.c'], true, ],"))
> +                         '())
> +
>                    ;; These tests are flaky and occasionally time
> out:
>                    ;;
> https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/932
You might want to use ", see" instead of the colon and wrap the link in
angular brackets, i.e. <https://...>. Don't forget to end the sentence
with a period.
Toggle quote (1 lines)
>                    ((".*elements/curlhttpsrc\\.c.*") "")
Otherwise LGTM
L
L
Liliana Marie Prikler wrote on 26 Nov 2022 13:49
6518d042e9e5916d4711feaafef36f7fbc25c042.camel@gmail.com
Am Dienstag, dem 25.10.2022 um 21:10 +0200 schrieb Liliana Marie
Prikler:
Toggle quote (36 lines)
> Am Dienstag, dem 25.10.2022 um 11:49 +0100 schrieb Christopher
> Baines:
> > It seems to frequently fail on i686-linux and aarch64-linux.
> >
> > * gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Skip the
> > elements/camerabin test on i686-linux and aarch64-linux.
> > ---
> >  gnu/packages/gstreamer.scm | 8 ++++++++
> >  1 file changed, 8 insertions(+)
> >
> > diff --git a/gnu/packages/gstreamer.scm
> > b/gnu/packages/gstreamer.scm
> > index a92588a9e2..c211816bf8 100644
> > --- a/gnu/packages/gstreamer.scm
> > +++ b/gnu/packages/gstreamer.scm
> > @@ -791,6 +791,14 @@ (define-public gst-plugins-bad
> >                    ;; FIXME: Why is this failing.
> >                    ((".*elements/dash_mpd\\.c.*") "")
> >  
> > +                  #$@(if (member (%current-system)
> > +                                 '("i686-linux" "aarch64-linux"))
> > +                         ;; This test is flaky:
> > +                         ;;
> > https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1244
> > +                         `((("'elements/camerabin\\.c'\\]\\],")
> > +                            "'elements/camerabin.c'], true, ],"))
> > +                         '())
> > +
> >                    ;; These tests are flaky and occasionally time
> > out:
> >                    ;;
> > https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/932
> You might want to use ", see" instead of the colon and wrap the link
> in angular brackets, i.e. <https://...>.  Don't forget to end the
> sentence with a period.
>
Turns out angular brackets aren't in vogue in this file.

Pushed with a slightly altered comment.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58773@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58773
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch