[PATCH] gnu: Add python-rollbar.

  • Done
  • quality assurance status badge
Details
2 participants
  • Wamm K. D
  • Christopher Baines
Owner
unassigned
Submitted by
Wamm K. D
Severity
normal
W
W
Wamm K. D wrote on 24 Oct 2022 18:46
(address . guix-patches@gnu.org)(name . Wamm K. D)(address . jaft.r@outlook.com)
BY5PR07MB7029E1009053588362E62F2F992E9@BY5PR07MB7029.namprd07.prod.outlook.com
* gnu/packages/python-xyz.scm (python-rollbar): Add new Python SDK
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 51136d8e6e..e8ad49ecb2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31233,6 +31233,37 @@ (define-public python-pymonad
@end itemize")
(license license:bsd-3)))
+(define-public python-rollbar
+ (package
+ (name "python-rollbar")
+ (version "0.16.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "rollbar" version))
+ (sha256
+ (base32
+ "1qpd0j50wqli3867xmhwk65pm1cxjs60yg83mcvcf3kic3y3sc82"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest-runner python-unittest2))
+ (inputs (list python-requests
+ python-six
+ python-httpx
+ python-blinker
+ python-webob))
+ (home-page "https://github.com/rollbar/pyrollbar")
+ (synopsis "Notifier for exceptions, errors, and log messages to Rollbar")
+ (description "Python SDK for reporting exceptions, errors, and log messages
+to @url{https://rollbar.com/, Rollbar}.
+
+Capabilities include:
+
+@itemize @bullet
+@item Sending messages and exceptions with arbitrary context
+@item Getting back aggregates
+@item Debugging production issues
+@end itemize")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
--
2.38.0
C
C
Christopher Baines wrote on 16 Mar 2023 19:41
(name . Wamm K. D)(address . jaft.r@outlook.com)
87ttykwn8i.fsf@cbaines.net
"Wamm K. D" <jaft.r@outlook.com> writes:

Toggle quote (5 lines)
> * gnu/packages/python-xyz.scm (python-rollbar): Add new Python SDK
> ---
> gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)

Thanks for the patch. As the comment at the bottom of the file suggests,
I've moved this up and pushed it to master as
e97ab7fff7f3c9c4833272602951883bfeddba62.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmQTY11fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xd9LA//esZMifOmW7dhLL5PqQBC5TOy4z+ZBYig
KIG6k2LwAvVDsWixZnZGi/m8UBDCuCoZFQKwXeXJbjTcIclbVhJU27wpnpQIe0Yt
Y4dcmPMxx66dMWFjMYm8Sf/YZje4bzf9m/K1pygX2GQmDDXX37XmZr5r+SN2tlsL
DSlDibFNSrrt0liu0NZgrALbS5Jnwq0/gydHAnH+wyOjAlsjftQ7+uZJkiyAQ5JH
qku6f8Cn5uQ7IK9lTJrWDkWGMngNXfmupDBXv1uymZGlBwa3j5TF/xsbD2cny0le
PvQ4SlEFbmyEaB/oB2RLtEBPuXAVgE5nHwu6tDfultg+5uUrntAapGuxxzijynoi
V3/YGO7u3gCum5mP8YDmPcX3pYQWvMQ9/Aar09VCaLDsaegfX7phs56dhL6e2YlT
UZ+T5ZY80S5gQHkVMIEtclG9QtFhxryDaNKCvWTlTpKWQz5c5qrlco44ajh1IUAf
ksL9ee57VmZrLWCBjyx6T2FfNddbuvV6vB+U3HY0uQGSiirt025C/Co2ENOjZ9Sr
1+LbvkbovLeAhlc0MX/k/+3PjtLxxUyrsUZBjiwaok/uqXSXZQU51nynXZh6z9TY
OU/PiOaMw9WUwIl9FijS9MrC0NANdUttjy1rchzC3B2hHG6jq1RG9CvzgXS2Eqqi
H3wDL0M7fiU=
=/KWr
-----END PGP SIGNATURE-----

?