[PATCH] gnu: Add new variable gkermit

  • Open
  • quality assurance status badge
Details
2 participants
  • ??
  • Christopher Baines
Owner
unassigned
Submitted by
??
Severity
normal
?
(name . guix-patches)(address . guix-patches@gnu.org)
CAGNyvehWU2dq8Ke6PS90_edwoaYS1AaJG53V-f7ZzME0ViUEJQ@mail.gmail.com
add new tool for embedded developing
From b0a14ae79dfb7baafcae88ff85f50578607fb7d1 Mon Sep 17 00:00:00 2001
From: LuHui <luhux76@gmail.com>
Date: Mon, 24 Oct 2022 13:13:58 +0800
Subject: [PATCH] gnu: Add new variable gkermit

* gnu/packages/admin.scm (gkermit): Add new variable.
---
gnu/packages/admin.scm | 52 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (69 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 4539e92a8c..f6aaf007f9 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -55,6 +55,7 @@
;;; Copyright © 2022 Andreas Rammhold <andreas@rammhold.de>
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2022 LuHui <luhux76@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5646,3 +5647,54 @@ (define (install-completion shell file)
(description
"@code{doctl} provides a unified command line interface to the DigitalOcean API.")
(license license:asl2.0)))
+
+(define-public gkermit
+ (package
+ (name "gkermit")
+ (version "2.01")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KermitProject/gkermit")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0njxzwnvanrdnx6cs7y0136g2179wx8wbqk8iqxpb48dr2hg7zn1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags (list (string-append "CC="
+ ,(cc-for-target))
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'replace-hardcodepath
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (doc (string-append out "/share/doc"))
+ (man1 (string-append out "/share/man/man1"))
+ (info (string-append out "/share/info")))
+ (substitute* "makefile"
+ (("/usr/local/bin")
+ bin)
+ (("/usr/man/manl")
+ man1) ;may be a typo err?
+ (("/usr/local/doc")
+ doc)
+ (("/usr/local/info")
+ info)
+ (("CC=cc")
+ "CC ?= cc"))
+ (mkdir-p bin)
+ (mkdir-p doc)
+ (mkdir-p man1)
+ (mkdir-p info)))))))
+
+ (home-page "https://github.com/KermitProject/gkermit")
+ (synopsis "Kermit for UNIX")
+ (description
+ "Use for uploading and downloading files with Kermit protocol")
+ (license license:gpl2)))
--
2.38.0
C
C
Christopher Baines wrote on 5 Nov 2022 11:32
(name . ??)(address . luhux76@gmail.com)
87mt95k7v7.fsf@cbaines.net
?? <luhux76@gmail.com> writes:

Toggle quote (2 lines)
> add new tool for embedded developing

Thanks for the patch. I've noted two hopefully minor issues below. Would
you be able to take a look at sending an updated patch?

Toggle quote (17 lines)
> +(define-public gkermit
> + (package
> + (name "gkermit")
> + (version "2.01")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/KermitProject/gkermit")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0njxzwnvanrdnx6cs7y0136g2179wx8wbqk8iqxpb48dr2hg7zn1"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:tests? #f

From looking at the source, I guess the reason for this is that there
are no included tests to run. If that is correct, it would be good to
note the reason in a comment.

Toggle quote (35 lines)
> + #:make-flags (list (string-append "CC="
> + ,(cc-for-target))
> + (string-append "PREFIX="
> + (assoc-ref %outputs "out")))
> + #:phases (modify-phases %standard-phases
> + (delete 'configure)
> + (add-before 'build 'replace-hardcodepath
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (bin (string-append out "/bin"))
> + (doc (string-append out "/share/doc"))
> + (man1 (string-append out "/share/man/man1"))
> + (info (string-append out "/share/info")))
> + (substitute* "makefile"
> + (("/usr/local/bin")
> + bin)
> + (("/usr/man/manl")
> + man1) ;may be a typo err?
> + (("/usr/local/doc")
> + doc)
> + (("/usr/local/info")
> + info)
> + (("CC=cc")
> + "CC ?= cc"))
> + (mkdir-p bin)
> + (mkdir-p doc)
> + (mkdir-p man1)
> + (mkdir-p info)))))))
> +
> + (home-page "https://github.com/KermitProject/gkermit")
> + (synopsis "Kermit for UNIX")
> + (description
> + "Use for uploading and downloading files with Kermit protocol")
> + (license license:gpl2)))

Can you check this, at least some files I looked at weren't strict gpl2
only.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNmPCxfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdqtQ//aXTmNUjBZfguKQW9ohVUWsXPCvBhbzKK
2YTGRn740ALDU9LmmpnxdXx+0CTo/HzhnkJbU0TXlt3wOtHXjAf9PoB3FX1aaQbq
hwgwTp0jfnnZpYNhpu07kg3YYVQIiBXgqS/vOa1sDdSUlx1be9e9PVqUln3S4jUU
ayzf7D5AP7edpun9wXvOGhqjZyVgXfLMf2BNtrai1e1jPi5s7BjJkNrhCPBiHmSW
c+tJvfDA4ODUu6950wqka0DyjcyJYOmnWqaIgAxxclZnP/NfugYy2YyCLz3bHYMK
SbfCLBCR6BFjzNoBkfmeATCuohTmFB6MnduqDh356MRkEXuSL4RQa9zq9pp1VG6e
5mZWpmf++rJqXpFKJJUR7+GBSg1etBl6H2GAFO6otckRUK71JpMKzmv0mbjkmlm1
0+tCQR2Hmc4uIdnrx1vViP7sZ/YtrX+t7KLmv9CdFZgdOZto0508BhyJNS2sd7LC
rqqYgN6uquSuibxlPbuIClgdAGeSRSJcjG8iFh8yQ63IwmLOMwKxX/2t1IG5ydXz
EdZFSpj5k/qf5kge4+UAQOM7sKUeRCUln86VdRm6pjqW2Y1N7c3EdEH+lCqbYqkc
mTJEyIlY9v5urU+B2PeeBa41S4LaeVBoQt8hGdOKmGDhmIJ1/RMqNTrcgTGi5rRe
JDPZZJWcORQ=
=Gxoa
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 6 Nov 2022 14:56
tag 58754 moreinfo
(address . control@debbugs.gnu.org)
87tu3cjie3.fsf@cbaines.net
tags 58754 + moreinfo
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 58754@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58754
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch