[PATCH] gnu: Add cl-stdutils.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • jgart
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20221023140016.4274-1-jgart@dismail.de
* gnu/packages/lisp-xyz.scm (cl-stdutils, ecl-stdutils, sbcl-stdutils): New variables.
---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 224926e3ca..9c908c0bce 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -186,6 +186,39 @@ (define-public cl-alexandria
(define-public ecl-alexandria
(sbcl-package->ecl-package sbcl-alexandria))
+(define-public sbcl-stdutils
+ (let ((commit "4a4e5a4036b815318282da5dee2a22825369137b")
+ (revision "0"))
+ (package
+ (name "sbcl-stdutils")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eslick/cl-stdutils")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16vxxphqdq8264x0aanm36x9r6d3ci1gjf4vf46mwl59gcff4wcj"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments '(#:tests? #f)) ; There are no tests.
+ (inputs
+ (list sbcl-cl-fad
+ sbcl-cl-ppcre))
+ (home-page "https://github.com/eslick/cl-stdutils/")
+ (synopsis "Grab bag of Common Lisp utility functions")
+ (description
+"This package provides a grab bag of miscellaneous Common Lisp
+utilities.")
+ (license license:bsd-3))))
+
+(define-public cl-stdutils
+ (sbcl-package->cl-source-package sbcl-stdutils))
+
+(define-public ecl-stdutils
+ (sbcl-package->ecl-package sbcl-stdutils))
+
(define-public sbcl-alea
(package
(name "sbcl-alea")
--
2.38.1
G
G
Guillaume Le Vaillant wrote on 24 Oct 2022 14:22
(name . jgart)(address . jgart@dismail.de)(address . 58741-done@debbugs.gnu.org)
87mt9l76n3.fsf@kitej
Patch pushed as de50d00ca835ef7fc0e38b91c8ace114a74fcfa3.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY1aDoA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9NMgEAki+cQ/61kFnxKey9XjBNwrpBM8eyOR3TsDgY
PhpyJiQA/RbTZ/UHbBIo3Zq3dUV/Ah6isKVdzVhyjsHGMJRVprhL
=3IiR
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58741@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58741
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch