installer: backtrace page in final step

  • Done
  • quality assurance status badge
Details
One participant
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Mathieu Othacehe
Severity
normal
M
M
Mathieu Othacehe wrote on 23 Oct 2022 11:39
(address . bug-guix@gnu.org)
87mt9m2813.fsf@gnu.org
Hello,

When an error occurs in the pseudo terminal displaying the "guix system
init" command output, the backtrace is not displayed correctly and the
keyboard cannot be used (arrows, tab, enter keys) to scroll down the
backtrace or dump it.

It can easily be reproduced by introducing an error in the "run-command"
function, this way:

Toggle snippet (12 lines)
--- a/gnu/installer/utils.scm
+++ b/gnu/installer/utils.scm
@@ -184,6 +184,7 @@ (define (pause)
(((port _ ...) _ _)
(read-line port))))
+ (error 'fake)
(installer-log-line "running command ~s" command)
(define result (run-external-command-with-line-hooks
(list %display-line-hook) command

I suspect that we may need to run "newt-init" and "clear-screen" before
displaying the backtrace page.

Thanks,

Mathieu
M
M
Mathieu Othacehe wrote on 23 Oct 2022 15:38
(address . 58734-done@debbugs.gnu.org)
87zgdm8xsf.fsf@gnu.org
Toggle quote (5 lines)
> + (error 'fake)
> (installer-log-line "running command ~s" command)
> (define result (run-external-command-with-line-hooks
> (list %display-line-hook) command

Fixed with bf5e78d59fcb188d0bce02d93c93d06069178837.

Thanks,

Mathieu
Closed
?