[PATCH 0/2] gnu: python-frozendict: Update to 2.3.4.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 2 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20221023034715.5042-1-mike@rohleder.de
While working on synapse I noticed that they found a memory leak in
python-frozendict. Updating this needs a newer python-canonicaljson.

Michael Rohleder (2):
gnu: python-frozendict: Update to 2.3.4.
gnu: python-canonicaljson: Update to 1.6.3.

gnu/packages/python-xyz.scm | 37 +++++++++++++++++++++++++++++++------
1 file changed, 31 insertions(+), 6 deletions(-)


base-commit: 1f734a6f0a7db5b0e12091a0c869c5c4810ac80e
--
2.38.0
Michael Rohleder wrote 2 years ago
[PATCH 1/2] gnu: python-frozendict: Update to 2.3.4.
(address . 58729@debbugs.gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20221023035101.5317-1-mike@rohleder.de
This fixes a potential memory leak with python 3.9:

* gnu/packages/python-xyz.scm (python-frozendict): Update to 2.3.4.
[home-page]: Set to new upstream repository.
---
gnu/packages/python-xyz.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 51136d8e6e..f3ede1b417 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -79,7 +79,7 @@
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
@@ -25954,15 +25954,15 @@ (define-public python-freetype-py
(define-public python-frozendict
(package
(name "python-frozendict")
- (version "1.2")
+ (version "2.3.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "frozendict" version))
(sha256
- (base32 "0ibf1wipidz57giy53dh7mh68f2hz38x8f4wdq88mvxj5pr7jhbp"))))
+ (base32 "0y3zn57i1q5192f7l4w2z2zsy3rrx50g563msaq954r58s1v3d0m"))))
(build-system python-build-system)
- (home-page "https://github.com/slezica/python-frozendict")
+ (home-page "https://github.com/Marco-Sulla/python-frozendict")
(synopsis "Simple immutable mapping for Python")
(description
"@dfn{frozendict} is an immutable wrapper around dictionaries that
--
2.38.0
Michael Rohleder wrote 2 years ago
[PATCH 2/2] gnu: python-canonicaljson: Update to 1.6.3.
(address . 58729@debbugs.gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20221023035101.5317-2-mike@rohleder.de
* gnu/packages/python-xyz.scm (python-canonicaljson): Update to 1.6.3.
[arguments]: Add phases build, check and install to build with pep517.
Add phase loosen-requirements to build with python-setuptools-scm >3.
[native-inputs]: Add python-pypa-build, python-pytest, python-setuptools,
python-setuptools-scm.
---
gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++--
1 file changed, 27 insertions(+), 2 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f3ede1b417..d5f94d1cfb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26043,14 +26043,39 @@ (define-public python-py-cpuinfo
(define-public python-canonicaljson
(package
(name "python-canonicaljson")
- (version "1.4.0")
+ (version "1.6.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "canonicaljson" version))
(sha256
- (base32 "0c86g0vvzdcg3nrcsqnbzlfhpprc2i894p8i14hska56yl27d6w9"))))
+ (base32 "0j5lq191jkd483q6xzc16c9fahxf15lrv03mvah9ka3lq85pcnfa"))))
(build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'loosen-requirements
+ (lambda _
+ ;; Permit newer versions of setuptools_scm
+ (substitute* "pyproject.toml"
+ ((">= 2.0.0, <3") ">= 2.0.0"))))
+ (replace 'build
+ (lambda _
+ ;; ZIP does not support timestamps before 1980.
+ (setenv "SOURCE_DATE_EPOCH" "315532800")
+ (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest"))))
+ (replace 'install
+ (lambda _
+ (let ((whl (car (find-files "dist" "\\.whl$"))))
+ (invoke "pip" "--no-cache-dir" "--no-input"
+ "install" "--no-deps" "--prefix" #$output whl)))))))
+ (native-inputs
+ (list python-pypa-build python-pytest python-setuptools python-setuptools-scm))
(propagated-inputs
(list python-six python-frozendict python-simplejson))
(home-page "https://github.com/matrix-org/python-canonicaljson")
--
2.38.0
Christopher Baines wrote 2 years ago
Re: [bug#58729] [PATCH 0/2] gnu: python-frozendict: Update to 2.3.4.
(name . Michael Rohleder)(address . mike@rohleder.de)
87bkplk71i.fsf@cbaines.net
Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (10 lines)
> While working on synapse I noticed that they found a memory leak in
> python-frozendict. Updating this needs a newer python-canonicaljson.
>
> Michael Rohleder (2):
> gnu: python-frozendict: Update to 2.3.4.
> gnu: python-canonicaljson: Update to 1.6.3.
>
> gnu/packages/python-xyz.scm | 37 +++++++++++++++++++++++++++++++------
> 1 file changed, 31 insertions(+), 6 deletions(-)

Thanks for the patches! I've pushed these to master as
b3147b149c8c44f5b4fe20936438165fa449fe20.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNmQFlfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcJ6hAAgSB0UaFgqpoGgm4EzdaikNZY/zaAWRzO
gvNpG7AmaVJtTmXmqV3dKj1S0eXu5YAVlqVXHj1MzDL9+/A5RLMLCm42aV7jz4+f
cFrsQjPS9AhttQVqt1DRriwAXxfL20LbzPnuHo1uauUH/uQTrn4+ctJUMOY6/hk1
tnDU6am8rgqyt3IbE0oKI6Hl+K+GcVwZxi7FG8/VZv1a/Ly5w/hOteYAUgARJs6g
+tmXwrZmUWlasMPG7abxcZ4f8vZJJUigo+OkA9wReMOjVjV7HhfZ39ZyWhZ3+U/X
iC1LYoFqkJIJVUxXB96r8xzGtQtECBhuyDOFi9Zq46r/zByX4u56eX5wRSaC9F3s
AFOlsrdfvexnmQrstyqnFur/Rm2L2OjzZ6MB0QUKTXutK4acXdendZoKyLQs/PEC
WjGoff1sY1N5/CIMAbpMyNxc/s85i/AiT7nIlFE/Okr3PU/0G5SRzOWa8SuSrALl
9qvKCIZc8w5Wgl83gg5IwEOuJX/DIhXP5tN5KEnTtL+LSqjbZoyUhMamtXVqZY1T
O2zTpwiYAH/cyASQFYq2Vy1Q9JCSwa5kNEuSKgAcAVpVr6dvvCXY3WTHxaWQ3CIG
yPpEQLE6LRL5puyJuzxxa/9mLPdr73DQ1X+74cagdhRyFNcnGQ7bATauMIZre+gL
4sBTG6tnAcw=
=1IFk
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 58729@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58729
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help