[PATCH] gnu: emacs-plz: Patch path to curl.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal
M
M
Michael Rohleder wrote on 22 Oct 2022 20:43
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20221022184314.9448-1-mike@rohleder.de
* gnu/packages/emacs-xyz.scm (emacs-plz)[arguments]: Add phase substitute-curl-path.
---
gnu/packages/emacs-xyz.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 06ec9dd904..117c5a09aa 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17142,6 +17142,15 @@ (define-public emacs-plz
(base32 "0p0xd532xa8icysyxwqk481lr9xanmp68gf97fd9n2936gp12chv"))))
(build-system emacs-build-system)
(inputs (list curl))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'substitute-curl-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (make-file-writable "plz.el")
+ (emacs-substitute-variables "plz.el"
+ ("plz-curl-program" (search-input-file inputs "/bin/curl"))))))))
(home-page "https://github.com/alphapapa/plz.el")
(synopsis "HTTP library for Emacs")
(description
--
2.38.0
N
N
Nicolas Goaziou wrote on 30 Oct 2022 10:38
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 58722-done@debbugs.gnu.org)
87y1sxodmn.fsf@nicolasgoaziou.fr
Hello,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (3 lines)
> * gnu/packages/emacs-xyz.scm (emacs-plz)[arguments]: Add phase
> substitute-curl-path.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58722@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58722
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch