[PATCH] gnu: Add python-eris.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Christopher Baines
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20221022005529.30026-1-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-eris): New variable.

Codeberg mirror seems to get stuck on a request.

PyPi doesn't include tests.

WDYT
---
gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 706de291c9..e90dede7fa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31142,6 +31142,25 @@ (define-public python-lief
and abstract ELF, PE and MachO formats.")
(license license:asl2.0)))
+(define-public python-eris
+ (package
+ (name "python-eris")
+ (version "0.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "eris" version))
+ (sha256
+ (base32
+ "16wbmahmfzdzrsjbn8jzi79vhghrzvvlcgnym20q0v3p3i4x47pq"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-pycryptodome))
+ (home-page "https://codeberg.org/eris/python-eris")
+ (synopsis "Python implementation of ERIS")
+ (description
+"Python implementation of the Encoding for Robust Immutable Storage
+(ERIS).")
+ (license license:gpl2+)))
+
(define-public shrinkwrap
(package
(name "shrinkwrap")
--
2.38.1
C
C
Christopher Baines wrote on 3 Nov 2022 17:22
(name . jgart)(address . jgart@dismail.de)
871qqkngyl.fsf@cbaines.net
jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (11 lines)
> * gnu/packages/python-xyz.scm (python-eris): New variable.
>
> Codeberg mirror seems to get stuck on a request.
>
> PyPi doesn't include tests.
>
> WDYT
> ---
> gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
> 1 file changed, 19 insertions(+)

Hi jgart,

This seems OK to me, although the license needs checking as I mention
below.

Toggle quote (26 lines)
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 706de291c9..e90dede7fa 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -31142,6 +31142,25 @@ (define-public python-lief
> and abstract ELF, PE and MachO formats.")
> (license license:asl2.0)))
>
> +(define-public python-eris
> + (package
> + (name "python-eris")
> + (version "0.0.2")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "eris" version))
> + (sha256
> + (base32
> + "16wbmahmfzdzrsjbn8jzi79vhghrzvvlcgnym20q0v3p3i4x47pq"))))
> + (build-system python-build-system)
> + (propagated-inputs (list python-pycryptodome))
> + (home-page "https://codeberg.org/eris/python-eris")
> + (synopsis "Python implementation of ERIS")
> + (description
> +"Python implementation of the Encoding for Robust Immutable Storage
> +(ERIS)."

There's a @acronym thing you could use here.

Toggle quote (2 lines)
> + (license license:gpl2+)))

Can you check this? It seems different to me.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNj62JfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfT2A/+LFjAglEANwobowGXLyflgVtAFwEpI3X/
OuJDgO9MLx629SS2bsjIZTiWpIdaeozROQq7tFaKvbAcsSry4i064F2iKDTpVE59
sjWh+NBvMF1Y2ig7Yjc8IFw1KYEexL1CJYuT/i05BiNx4BacbV0Clp9WxmjK2HSF
yBza3tWjtF1Lz+x38cfLfg/O85khli0YRRCZP+pp79xnmwfw6hH+He1R2k4JBA4T
fPXIqYI3H6yUF8FbhvGfqgpwkWPhOFs4m2dO0Mie0xt7/ZKDrVVzQxznsC8MQAIA
004wvr1Cj/mYJf9sRUF64bINoJ/Qs1QZKyvfH3jMtYkTa0JgiscWlq595Rct3xvK
M+2mmImXWwEAnykYa+WllCPdcHLBOdol/+edWEDOqpSxfttxPVFHbKUWCFqwJY76
NXcQqTc997xvTA8Pd+eo9pieeDP0rMPfP+CMmzy0Gm9OpU0llnpcehx6AuSpPfBj
tc8BARUMefDt43QNu2wHYJH6LPawnZ19ndB1n34w8BCKyV6g1KYU+uKO0ATA4NfB
LZJ0a+XPjYodZfCj5nsSkwLetqIsNO6NoXIAxD2zF/GtYRhx75v7k47DENls3zKn
M96RJtfdItR5tUXH2Iv5Y0VPLOubVJobbBGTziwnZtR5DzqFyOJWYMKtH3jvufkC
o2eLAalCWgo=
=xMy0
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 3 Nov 2022 18:04
tag 58696 moreinfo
(address . control@debbugs.gnu.org)
87bkpootok.fsf@cbaines.net
tags 58696 + moreinfo
quit
J
J
jgart wrote on 3 Nov 2022 18:30
[PATCH v2] gnu: Add python-eris.
(address . 58696@debbugs.gnu.org)
20221103173043.11037-1-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-eris): New variable.

Hi, thanks for the review. Here's an updated patch with your requests.
---
gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 04cc2a363b..342e9c0a34 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31225,6 +31225,25 @@ (define-public python-lief
and abstract ELF, PE and MachO formats.")
(license license:asl2.0)))
+(define-public python-eris
+ (package
+ (name "python-eris")
+ (version "0.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "eris" version))
+ (sha256
+ (base32
+ "16wbmahmfzdzrsjbn8jzi79vhghrzvvlcgnym20q0v3p3i4x47pq"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-pycryptodome))
+ (home-page "https://codeberg.org/eris/python-eris")
+ (synopsis "Python implementation of ERIS")
+ (description
+"Python implementation of the @acronym{ERIS, Encoding for Robust Immutable
+Storage}.")
+ (license license:lgpl3+)))
+
(define-public shrinkwrap
(package
(name "shrinkwrap")
--
2.38.1
C
C
Christopher Baines wrote on 3 Nov 2022 18:55
(name . jgart)(address . jgart@dismail.de)(address . 58696-done@debbugs.gnu.org)
87v8nvkjmr.fsf@cbaines.net
jgart <jgart@dismail.de> writes:

Toggle quote (4 lines)
> * gnu/packages/python-xyz.scm (python-eris): New variable.
>
> Hi, thanks for the review. Here's an updated patch with your requests.

Great, pushed to master as 9560932ce04bfecdfefc5fdb8699fa1f64887286.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNkAJxfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xe/fBAAsQOl3gfGvBF4aEmwRU+eDPhIOGPVej56
hWjQcReLSSLL6Jqcoaf1NT7THlMQbfsTCpaKlcqWM1LswTU8kgIOyPoZv0FQs5wg
FQy2Gt99xGKelwl9R3MY4JedQu1XbbWze1RRaYTYMswLe8ReZPcdyRts1CgiyDde
bDKkE/WiyJmDfEznWrgWfZBqsZWppsyzKprrIZch7P6IUc8m4XdM+AeYjJsLXTV1
QQnY0gmZ8rUfQgKbDhHvYG6ut2i8SDBk0PPFEXPGto/lSto7AFGG4gHDOB8gLdKT
B4Nw4OqZiBda2l2FHM31oPJDNWdooUg3UUdsmTiUbkmwxeoGPvic3R803PzLli0j
7xCZ5B/5/mfEV1l/t8iIIrzDGfTI9FctxcjOrxxBeUbfsH/j0RjgraeBQCnx4Th0
jI5H+9/J6H9aIyXD+oImV1Akx0Qci872vr6gOEbHOs/m1cGP9WeRR938ya/VDDt/
+bZjJhB4K9kmqxzciYR2JIzqV53iwC58SbzhaNPUarmQcuk1jZo0I5w28/E2rtDS
9k+cBmwky7mv2gzgReaZq02lxAo4gNRUkRWZy6yyeRI3kPbTcp+it1ugoDkXXPBb
0O+rF68CsL+0Yi5/QW8VLf4ZrQdDswGTrX6xolArnwfjYacoo3OdCchDdzack1y4
jKVlfFTHtNQ=
=meOH
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58696@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58696
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch