[PATCH] gnu: Add synthpod

  • Done
  • quality assurance status badge
Details
3 participants
  • Sughosha
  • Christopher Baines
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Sughosha
Severity
normal
S
S
Sughosha wrote on 21 Oct 2022 13:19
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
D0Yk1G0jYgxZkFGBF0gB4894QtivLuoVpdRCHLbVBwhjvldD8HHWjjO3CZwH2rCUU_9o_Gh0hpA9brEvK2GQx-A_f2MlhTbTGWXjIK7tW-s=@proton.me
* gnu/packages/music.scm (synthpod): New variable.
---
gnu/packages/music.scm | 45 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6b37c79..6ff2c99 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -173,6 +173,7 @@
#:use-module (gnu packages sqlite)
#:use-module (gnu packages stb)
#:use-module (gnu packages tcl)
+ #:use-module (gnu packages terminals)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tex)
#:use-module (gnu packages time)
@@ -3456,6 +3457,50 @@ analogue-like user interface.")
socket or command line.")
(license license:gpl3+))))

+(define-public synthpod
+ (package
+ (name "synthpod")
+ (version "0.1.6505")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.open-music-kontrollers.ch/lv2/synthpod")
+ ;; Version is not tagged but mentioned in VERSION file.
+ (commit "8273142cd702583cb3662fbe0e2fd5d4075ee703")))
+ (sha256
+ (base32
+ "120qsd090pwkc21g9a5mm0pjb0rqn1iy4rs5lx3fs0qf3wa7k6ri"))))
+ (build-system meson-build-system)
+ ;; Fontconfig error: No writable cache directories
+ (arguments (list #:tests? #f))
+ (inputs (list alsa-lib
+ cairo
+ eudev
+ freetype
+ fontconfig
+ glew
+ glu
+ jack-1
+ libevdev
+ libinput
+ libvterm
+ lilv
+ lv2
+ pixman
+ sratom
+ xcb-util
+ xcb-util-wm
+ xcb-util-xrm
+ zita-alsa-pcmi))
+ (native-inputs (list ;lv2lint ; needed for tests
+ pkg-config))
+ (home-page "https://open-music-kontrollers.ch/lv2/synthpod/")
+ (synopsis "Nonlinear LV2 plugin container")
+ (description
+ "Synthpod is an LV2 host. It can be run as a standalone app and be used
+as a tool for live performances or general audio and event filtering.")
+ (license (list license:artistic2.0 license:gpl3+))))
+
(define-public curseradio
(let ((commit "1bd4bd0faeec675e0647bac9a100b526cba19f8d")
(revision "1"))
--
libgit2 1.4.3
C
C
Christopher Baines wrote on 25 Oct 2022 11:25
(name . Sughosha)(address . Sughosha@proton.me)
87wn8ofe0p.fsf@cbaines.net
Sughosha via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (5 lines)
> * gnu/packages/music.scm (synthpod): New variable.
> ---
> gnu/packages/music.scm | 45 +++++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 45 insertions(+)

Hey, thanks for the patch.

Toggle quote (10 lines)
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://git.open-music-kontrollers.ch/lv2/synthpod")
> + ;; Version is not tagged but mentioned in VERSION file.
> + (commit "8273142cd702583cb3662fbe0e2fd5d4075ee703")))
> + (sha256
> + (base32
> + "120qsd090pwkc21g9a5mm0pjb0rqn1iy4rs5lx3fs0qf3wa7k6ri"))))

The linter should be telling you something about the source file not
containing the package name. I'd take a look at the file-name bit in
other package sources that also use git-fetch.

Toggle quote (4 lines)
> + (build-system meson-build-system)
> + ;; Fontconfig error: No writable cache directories
> + (arguments (list #:tests? #f))

The cache directory bit is a hint, as that's often within the users home
directory. The build environment uses a non-existent home directory, but
you can change that. Quite a few packages have (setenv "HOME" "/tmp")
for the tests. Adding that looks like:

(arguments
(list
#:phases
#~(modify-phases %standard-phases
(add-before 'check 'fix-home-directory
(lambda _
;; Tests fail with: Fontconfig error: No writable cache
;; directories
(setenv "HOME" "/tmp"))))))

If you do that though, the tests still fail, seems like there's a
missing font?

starting phase `check'
ninja: Entering directory `/tmp/guix-build-synthpod-0.1.6505.drv-0/build'
ninja: no work to do.
1/9 d2tk / Test core OK 0.09s
2/9 d2tk / Test base OK 0.48s
3/9 d2tk / FiraSans-Bold.ttf FAIL 0.02s exit status 1
Toggle quote (2 lines)
>>> MALLOC_PERTURB_=67 /tmp/guix-build-synthpod-0.1.6505.drv-0/source/subprojects/d2tk/check_for_font FiraSans-Bold.ttf

4/9 d2tk / FiraCode-Light.ttf FAIL 0.03s exit status 1
Toggle quote (2 lines)
>>> MALLOC_PERTURB_=109 /tmp/guix-build-synthpod-0.1.6505.drv-0/source/subprojects/d2tk/check_for_font FiraCode-Light.tt

5/9 d2tk / FiraCode-Regular.ttf FAIL 0.03s exit status 1
Toggle quote (2 lines)
>>> MALLOC_PERTURB_=46 /tmp/guix-build-synthpod-0.1.6505.drv-0/source/subprojects/d2tk/check_for_font FiraCode-Regular.ttf

6/9 d2tk / FiraCode-Medium.ttf FAIL 0.02s exit status 1
Toggle quote (2 lines)
>>> MALLOC_PERTURB_=41 /tmp/guix-build-synthpod-0.1.6505.drv-0/source/subprojects/d2tk/check_for_font FiraCode-Medium.ttf

7/9 d2tk / FiraCode-Bold.ttf FAIL 0.02s exit status 1
Toggle quote (2 lines)
>>> MALLOC_PERTURB_=10 /tmp/guix-build-synthpod-0.1.6505.drv-0/source/subprojects/d2tk/check_for_font FiraCode-Bold.ttf

8/9 synthpod / LV2 validate OK 0.07s
9/9 synthpod / LV2 validate OK 0.07s

Summary of Failures:

3/9 d2tk / FiraSans-Bold.ttf FAIL 0.02s exit status 1
4/9 d2tk / FiraCode-Light.ttf FAIL 0.03s exit status 1
5/9 d2tk / FiraCode-Regular.ttf FAIL 0.03s exit status 1
6/9 d2tk / FiraCode-Medium.ttf FAIL 0.02s exit status 1
7/9 d2tk / FiraCode-Bold.ttf FAIL 0.02s exit status 1


Ok: 4
Expected Fail: 0
Fail: 5
Unexpected Pass: 0
Skipped: 0
Timeout: 0
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNXrEZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdnkA/+M9ctqaoibu4y+jEEpWRasfwhwj5iEP2a
uzpRuNbRPvy73xK1XFMySF+GlhVcfb47AEgwHEwCOsRl6EvfWBS7cds3E1sApVgA
mepO/GSRHwkgxmiRxB2ewyD3/iPQpPpTFAWOvnqCKE1Ajv8Uon0OMvQHW2KXagKE
ptSrcHCwEhTYlfhn7paxZ2ag0d9kdILFm8caU4WaU+cnv35G57PM1x7HMRjaM/4J
Gc41/e0U+xGdqMKOzY9SB0oOM6HvjcwW+5bPe6QwJqw700mSgqSPuidm+mrzxCMG
1bgCSSRY8TL4Dh5Rnjc9ObrecT7+z3SAp0jj2tlF+uaafFi6TPmP6j1pa9FWuVKm
8iF7I0zk0VZ5nwmDPd4k7hlpDuwd23B7bARmlBtXi00jPM7duSqU1C63UQ5ahwH1
Bp0bMsCmlZm9OT4mKq8RYbY7WFr3OrtfvLkE2sZonB8usby8aoh1XLQ5Dg6G6OBg
9ETjDRPMNbnAt7ekLqssxiswAXVuVIrHC5hHu45YToGXKPRucE1rN1slxOMeF3N4
Gm+Wgu/TuPsO8coYTtMsevmM15/r656PqrUhk4n/s/0eGCveZwchSMR+/glgI+Hb
z/rD4qPlb3CDgarCuPOdV6W2bpshClbiwKAOecY1ePxqoDDwQlBeG5S0zQJtzlY4
orl5McoBtcU=
=3P3N
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 3 Nov 2022 17:14
tag 58681 moreinfo
(address . control@debbugs.gnu.org)
878rks3thl.fsf@cbaines.net
tags 58681 + moreinfo
quit
S
S
Sughosha wrote on 6 Jan 2023 15:27
[PATCH v2] gnu: Add synthpod.
(name . 58681@debbugs.gnu.org)(address . 58681@debbugs.gnu.org)
viBIyjXrR5hk6JOKsOJtvmpCguAiY9amM-YvHUZOWE0OBXGs08fLEZvRy1rvFRUQJ44qQ_LRwnKQq6IpVb3vSEQq0djnk0SVmYTumrE1rhA=@proton.me
Sorry for the delay. Here is the fix with tests enabled and updated to newer version.

* gnu/packages/music.scm (synthpod): New public variable.
---
gnu/packages/music.scm | 54 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (74 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5be767a138..3d0722274c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -174,6 +174,7 @@ (define-module (gnu packages music)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages stb)
#:use-module (gnu packages tcl)
+ #:use-module (gnu packages terminals)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tex)
#:use-module (gnu packages time)
@@ -3517,6 +3518,59 @@ (define-public mod-host
socket or command line.")
(license license:gpl3+))))
+(define-public synthpod
+ (package
+ (name "synthpod")
+ (version "0.1.6507")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.open-music-kontrollers.ch/lv2/synthpod")
+ ;; Version is not tagged but mentioned in VERSION file.
+ (commit "6e84a075ea8fea95094dcbc2b30f968717a81960")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1chazkdxjgjzfxqmlk4ywhilkj9l3bybd9xghjg9r67df2diqhbs"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'fix-home-directory
+ (lambda _
+ ;; Tests fail with: Fontconfig error: No writable cache
+ ;; directories
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs (list lilv)) ;required for lv2info
+ (inputs (list alsa-lib
+ cairo
+ eudev
+ freetype
+ font-fira-code
+ font-fira-sans
+ fontconfig
+ glew
+ glu
+ jack-1
+ libevdev
+ libinput
+ libvterm
+ lv2
+ pixman
+ sratom
+ xcb-util
+ xcb-util-wm
+ xcb-util-xrm
+ zita-alsa-pcmi))
+ (native-inputs (list pkg-config))
+ (home-page "https://open-music-kontrollers.ch/lv2/synthpod/")
+ (synopsis "Nonlinear LV2 plugin container")
+ (description
+ "Synthpod is an LV2 host. It can be run as a standalone app and be used
+as a tool for live performances or general audio and event filtering.")
+ (license (list license:artistic2.0 license:gpl3+))))
+
(define-public curseradio
(let ((commit "1bd4bd0faeec675e0647bac9a100b526cba19f8d")
(revision "1"))
--
2.38.1
R
R
Ricardo Wurmus wrote on 22 Jan 2023 23:58
(address . 58681@debbugs.gnu.org)(name . Sughosha)(address . Sughosha@proton.me)
87bkmqf9z4.fsf@elephly.net
Hi,

I made these changes:
Toggle diff (94 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ca058638f2..f2f5289dba 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -44,7 +44,7 @@
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
-;;; Copyright © 2022 Sughosha <sughosha@disroot.org>
+;;; Copyright © 2022, 2023 Sughosha <sughosha@disroot.org>
;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
@@ -3566,44 +3566,53 @@ (define-public synthpod
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://git.open-music-kontrollers.ch/lv2/synthpod")
- ;; Version is not tagged but mentioned in VERSION file.
- (commit "6e84a075ea8fea95094dcbc2b30f968717a81960")))
+ (url "https://git.open-music-kontrollers.ch/lv2/synthpod")
+ ;; Version is not tagged but mentioned in VERSION file.
+ (commit "6e84a075ea8fea95094dcbc2b30f968717a81960")))
(file-name (git-file-name name version))
(sha256
- (base32
- "1chazkdxjgjzfxqmlk4ywhilkj9l3bybd9xghjg9r67df2diqhbs"))))
+ (base32
+ "1chazkdxjgjzfxqmlk4ywhilkj9l3bybd9xghjg9r67df2diqhbs"))))
(build-system meson-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
- (add-before 'check 'fix-home-directory
+ (add-after 'unpack 'patch-references
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* '("bin/synthpod_ui"
+ "bin/synthpod_d2tk")
+ (("lv2info") (search-input-file inputs "/bin/lv2info"))
+ ((" synthpod_sandbox_x11")
+ (string-append " " #$output "/bin/synthpod_sandbox_x11")))))
+ (add-before 'check 'set-home-directory
(lambda _
;; Tests fail with: Fontconfig error: No writable cache
;; directories
(setenv "HOME" "/tmp"))))))
- (propagated-inputs (list lilv)) ;required for lv2info
- (inputs (list alsa-lib
- cairo
- eudev
- freetype
- font-fira-code
- font-fira-sans
- fontconfig
- glew
- glu
- jack-1
- libevdev
- libinput
- libvterm
- lv2
- pixman
- sratom
- xcb-util
- xcb-util-wm
- xcb-util-xrm
- zita-alsa-pcmi))
+ (inputs
+ (list alsa-lib
+ cairo
+ eudev
+ freetype
+ font-fira-code
+ font-fira-sans
+ fontconfig
+ glew
+ glu
+ grep
+ jack-2
+ libevdev
+ libinput
+ libvterm
+ lilv ;for lv2info
+ lv2
+ pixman
+ sratom
+ xcb-util
+ xcb-util-wm
+ xcb-util-xrm
+ zita-alsa-pcmi))
(native-inputs (list pkg-config))
(home-page "https://open-music-kontrollers.ch/lv2/synthpod/")
(synopsis "Nonlinear LV2 plugin container")
It avoids propagation of lilv and patches synthpod_ui to look for other
executables in a known location.

We should probably also wrap the scripts to set PATH to where “grep”,
“coreutils”, “sed”, and “gawk” are found, but I wasn’t able to add (gnu
packages gawk) to the imports of (gnu packages music).

Unfortunately, the program crashes because it can’t find the LV2 files
for Synthpod itself:

Toggle snippet (15 lines)
$ /gnu/store/pp3rysfcssf3kigh01mrz7jc16dgp51p-synthpod-0.1.6507/bin/synthpod_ui
error: failed to open file /home/rekado/.lv2/Synthpod_default.preset.lv2/manifest.ttl (No such file or directory)
lilv_world_load_file(): error: Error loading file `file:///home/rekado/.lv2/Synthpod_default.preset.lv2/manifest.ttl'
lilv_world_load_bundle(): error: Error reading file:///home/rekado/.lv2/Synthpod_default.preset.lv2/manifest.ttl
Plugin not found.
Synthpod 0.1.6507
Copyright (c) 2015-2016 Hanspeter Portner (dev@open-music-kontrollers.ch)
Released under Artistic License 2.0 by Open Music Kontrollers
error: failed to open file /home/rekado/dev/gx/branches/master/manifest.ttl (No such file or directory)
lilv_world_load_file(): error: Error loading file `file:///home/rekado/dev/gx/branches/master/manifest.ttl'
lilv_world_load_bundle(): error: Error reading file:///home/rekado/dev/gx/branches/master/manifest.ttl
lilv_plugins_get_by_uri failed
Segmentation fault

These probably should be looked up in $out/lib/synthpod/lv2 instead of
searching the LV2 path.

--
Ricardo
S
S
Sughosha wrote on 23 Jan 2023 22:10
(address . 58681@debbugs.gnu.org)(address . rekado@elephly.net)
eliH3oT8t2wMrICbqjyWfhr8eefnVpUx9vKeXY_6nsIBZHz0dhZrvKeOcNxZpgHvzzUV75pEj6ExLKDcmJGMz_zxz5KTbJty6VbXsQZJpXQ=@proton.me
Thanks for reviewing the patch and improving it.

Toggle quote (1 lines)
> We should probably also wrap the scripts to set PATH to where “grep”,
“coreutils”, “sed”, and “gawk” are found, but I wasn’t able to add (gnu
packages gawk) to the imports of (gnu packages music).

This is not the only package requiring such basic programs like "sed",
"grep" etc but not wrapped or listed in inputs. The other such package that
I am aware of is ardour, which also requires these programs. I tried
running ardour in a guix shell with --emulate-fhs, then found that ardour
could not start because these programs were not found in the PATH. So I am
not sure if it is required to add these programs to inputs or to wrap them.

Toggle quote (1 lines)
> Unfortunately, the program crashes because it can’t find the LV2 files
for Synthpod itself:

I fixed it partially. The binaries are confusing. `synthpod_ui` seems like
not to be run manually. The way that I found to run the ui is
`synthpod_alsa -g` or `synthpod_jack -g`.

Strangely, with the attatched new v3 patch, the program starts only if
installed to guix profile (or maybe something else like guix home, not
tested). Just by building, the program searches for "manifest.ttl" file
in the current working directory and fails to start.


Sughosha
From a2ae9de66366bf00c9a384f5c7be8b0be17b0a02 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Mon, 23 Jan 2023 22:02:42 +0100
Subject: [PATCH v3] gnu: Add synthpod.

* gnu/packages/music.scm (synthpod): New variable.
---
gnu/packages/music.scm | 68 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 67 insertions(+), 1 deletion(-)

Toggle diff (95 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 65bb6d29f7..5c446330fa 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -44,7 +44,7 @@
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
-;;; Copyright © 2022 Sughosha <sughosha@disroot.org>
+;;; Copyright © 2022, 2023 Sughosha <sughosha@proton.me>
;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
@@ -174,6 +174,7 @@ (define-module (gnu packages music)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages stb)
#:use-module (gnu packages tcl)
+ #:use-module (gnu packages terminals)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tex)
#:use-module (gnu packages time)
@@ -3558,6 +3559,71 @@ (define-public mod-host
socket or command line.")
(license license:gpl3+))))
+(define-public synthpod
+ (package
+ (name "synthpod")
+ (version "0.1.6507")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.open-music-kontrollers.ch/lv2/synthpod")
+ ;; Version is not tagged but mentioned in VERSION file.
+ (commit "6e84a075ea8fea95094dcbc2b30f968717a81960")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1chazkdxjgjzfxqmlk4ywhilkj9l3bybd9xghjg9r67df2diqhbs"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-references
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* '("bin/synthpod_ui"
+ "bin/synthpod_d2tk")
+ (("lv2info") (search-input-file inputs "/bin/lv2info"))
+ ((" synthpod_sandbox_x11")
+ (string-append " " #$output "/bin/synthpod_sandbox_x11")))
+ (substitute* "bin/synthpod_bin.c"
+ (("%s/.lv2") (string-append #$output "/lib/lv2"))
+ ((", home_dir") ""))))
+ (add-before 'check 'set-home-directory
+ (lambda _
+ ;; Tests fail with: Fontconfig error: No writable cache
+ ;; directories
+ (setenv "HOME" "/tmp"))))))
+ (inputs (list alsa-lib
+ cairo
+ eudev
+ freetype
+ font-fira-code
+ font-fira-sans
+ fontconfig
+ glew
+ glu
+ jack-2
+ libvterm
+ lilv
+ lv2
+ libevdev
+ libinput
+ libvterm
+ lv2
+ pixman
+ sratom
+ xcb-util
+ xcb-util-wm
+ xcb-util-xrm
+ zita-alsa-pcmi))
+ (native-inputs (list pkg-config))
+ (home-page "https://open-music-kontrollers.ch/lv2/synthpod/")
+ (synopsis "Nonlinear LV2 plugin container")
+ (description
+ "Synthpod is an LV2 host. It can be run as a standalone app and be used
+as a tool for live performances or general audio and event filtering.")
+ (license (list license:artistic2.0 license:gpl3+))))
+
(define-public curseradio
(let ((commit "1bd4bd0faeec675e0647bac9a100b526cba19f8d")
(revision "1"))
--
2.39.1
R
R
Ricardo Wurmus wrote on 25 Jan 2023 00:24
(name . Sughosha)(address . Sughosha@proton.me)(address . 58681-done@debbugs.gnu.org)
87r0vjcy60.fsf@elephly.net
Sughosha <Sughosha@proton.me> writes:

Toggle quote (13 lines)
> Thanks for reviewing the patch and improving it.
>
>> We should probably also wrap the scripts to set PATH to where “grep”,
> “coreutils”, “sed”, and “gawk” are found, but I wasn’t able to add (gnu
> packages gawk) to the imports of (gnu packages music).
>
> This is not the only package requiring such basic programs like "sed",
> "grep" etc but not wrapped or listed in inputs. The other such package that
> I am aware of is ardour, which also requires these programs. I tried
> running ardour in a guix shell with --emulate-fhs, then found that ardour
> could not start because these programs were not found in the PATH. So I am
> not sure if it is required to add these programs to inputs or to wrap them.

To me this means that we should also fix ardour, not that we should
ignore the problem in other packages :)

Toggle quote (12 lines)
>> Unfortunately, the program crashes because it can’t find the LV2 files
> for Synthpod itself:
>
> I fixed it partially. The binaries are confusing. `synthpod_ui` seems like
> not to be run manually. The way that I found to run the ui is
> `synthpod_alsa -g` or `synthpod_jack -g`.
>
> Strangely, with the attatched new v3 patch, the program starts only if
> installed to guix profile (or maybe something else like guix home, not
> tested). Just by building, the program searches for "manifest.ttl" file
> in the current working directory and fails to start.

That’s odd, but perhaps it’s the default of an LV2 library that synthpod
uses.

The patch looks good enough to me, so I applied it. Feel free to
revisit it at a later point to address the remaining minor issues.

Thank you!

--
Ricardo
Closed
?