Matthew James Kraai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Matthew James Kraai)(address . kraai@ftbfs.org)
* gnu/packages/python-xyz.scm (s3cmd)[arguments]: Add a new 'hide-wrapping
phase.
---
gnu/packages/python-xyz.scm | 7 +++++++
1 file changed, 7 insertions(+)
The Commands section of `s3cmd --help`'s output displays `.s3cmd-real` instead
of `s3cmd` in the commands (e.g., `.s3cmd-real mb s3://BUCKET`). This makes
it display `s3cmd` instead (e.g., `s3cmd mb s3://BUCKET`).
Toggle diff (20 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 32bd986a12..81fa89fec2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16222,6 +16222,13 @@ (define-public s3cmd
(sha256
(base32 "0rdgwwmmp8mdxc84bxq6k9a7v7z2qgc3df47djzs2b84gw81dglx"))))
(build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'hide-wrapping
+ (lambda _
+ (substitute* "s3cmd"
+ (("optparser\\.get_prog_name\\(\\)") "\"s3cmd\"")))))))
(inputs
(list python-dateutil
python-magic))
--
2.38.0