[PATCH 0/7]: gnu: Astopy: Fix build and update to 5.1

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 19 Oct 2022 22:19
(address . guix-patches@gnu.org)
CAO+9K5pL5wU4QKhWJoUyC_RKekxsYoN+vaaAGkEUg3n-NxB36w@mail.gmail.com
Hi Guix team!
As reported in https://issues.guix.gnu.org/58586Astropy stopped building
after latest staging->master merge, here is a series of patches which updates
vital dependencies of Astropy and update Astropy itself to 5.1. It also
includes upgrade of some dependent where possible with easy win.
These list of packages dropped using setup.py and migrated to pyproject.toml
which require pack missing inputs and update phases:
- python-cdflib
- python-asdf requies
- python-asdf-astropy
- python-gwcs
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
S
S
Sharlatan Hellseher wrote on 19 Oct 2022 22:22
[PATCH 1/7]: gnu: Add pytest-7.1
(address . 58645@debbugs.gnu.org)
CAO+9K5puHyw=+o5RJ04Vyqg5JGHE34ftAYNW19s6pEtT4b0nwA@mail.gmail.com
Sharlatan Hellseher (7):
gnu: Add pytest-7.1
gnu: pytest-astropy: Update to 0.10.0
gnu: pytest-astropy-header: Update to 0.2.2
gnu: astropy: Update to 5.1
gnu: photutils: Update to 1.5.0
gnu: astopy-healpix: Update to 0.7
gnu: regions: Update to 0.6
gnu/packages/astronomy.scm | 20 ++++++++++----------
gnu/packages/check.scm | 23 +++++++++++++++++++++++
gnu/packages/python-check.scm | 10 +++++-----
3 files changed, 38 insertions(+), 15 deletions(-)
base-commit: 3bb145b6e2a8c84e7739ead9ae76dc4d42bb9850
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 6c53ebd8ced19eb6a79744219d585040547cd59d Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Tue, 18 Oct 2022 22:49:22 +0100
Subject: [PATCH 1/7] gnu: Add pytest-7.1

* gnu/packages/check.scm (python-pytest-7.1): New variable.
---
gnu/packages/check.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 9768e5f8a4..3d320e9c70 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 David Elsing <david.elsing@posteo.net>
+;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1093,6 +1094,28 @@ (define-public python-pytest
(define-public python-pytest-6 python-pytest)
+;; Astropy started using hard dependencies for Pytest 7+, which might
+;; happen for some other projects. It could be set as default in staging.
+(define-public python-pytest-7.1
+ (package
+ (inherit python-pytest)
+ (version "7.1.3")
+ (name "python-pytest")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest" version))
+ (sha256
+ (base32
+ "0f8c31v5r2kgjixvy267n0nhc4xsy65g3n9lz1i1377z5pn5ydjg"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments python-pytest)
+ ((#:phases phases #~%standard-phases)
+ #~(modify-phases #$phases
+ (add-before 'build 'pretend-version
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))))))))
+
(define-public python-pytest-bootstrap
(package
(inherit python-pytest)
--
2.37.3
S
S
Sharlatan Hellseher wrote on 19 Oct 2022 22:23
[PATCH 2/7]: gnu: pytest-astropy: Update to 0.10.0
(address . 58645@debbugs.gnu.org)
CAO+9K5rCUHAS8KEyZtE_B2YwK0M8qb0p4Nbuy7PiE5h3yhOhQw@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 4c9f9058ae1689101076e2d42eb102780dbe1134 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Tue, 18 Oct 2022 22:58:27 +0100
Subject: [PATCH 2/7] gnu: pytest-astropy: Update to 0.10.0

* gnu/packages/python-check.scm (python-pytest-astropy): Update to 0.10.0
---
gnu/packages/python-check.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 2358e7448d..e3b8ede9f0 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
-;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021-2022 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
@@ -455,13 +455,13 @@ (define-public python-pytest-astropy-header
(define-public python-pytest-astropy
(package
(name "python-pytest-astropy")
- (version "0.8.0")
+ (version "0.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-astropy" version))
(sha256
- (base32 "18j6z6y2fvykmcs5z0mldhhaxxn6wzpnhlm2ps7m8r5z5kmh1631"))))
+ (base32 "04g2rh261s3s6ym8mwi4iv2a6anbgwvwzcvkyilfck6yxrncdqw5"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; there are no tests
--
2.37.3
S
S
Sharlatan Hellseher wrote on 19 Oct 2022 22:25
[PATCH 3/7]: gnu: pytest-astropy-header: Update to 0.2.2
(address . 58645@debbugs.gnu.org)
CAO+9K5rjDbAbqiTxsbCQtVR=6gre==+sLCfoF1Am=90WcS9DDw@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 4104b73dbec432ae264d4f05beaaba34796ae62b Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Tue, 18 Oct 2022 23:01:56 +0100
Subject: [PATCH 3/7] gnu: pytest-astropy-header: Update to 0.2.2

* gnu/packages/python-check.scm (python-pytest-astropy-header): Update
to 0.2.2
---
gnu/packages/python-check.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index e3b8ede9f0..e7828990c1 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -432,13 +432,13 @@ (define-public python-pytest-ordering
(define-public python-pytest-astropy-header
(package
(name "python-pytest-astropy-header")
- (version "0.1.2")
+ (version "0.2.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-astropy-header" version))
(sha256
- (base32 "1y87agr324p6x5gvhziymxjlw54pyn4gqnd49papbl941djpkp5g"))))
+ (base32 "046v4arinv8b5jz05pvhnc0n1aqqndwvhlsl635ahxabr40i32bp"))))
(build-system python-build-system)
(native-inputs
(list python-pytest python-setuptools-scm))
--
2.37.3
S
S
Sharlatan Hellseher wrote on 19 Oct 2022 22:25
[PATCH 4/7]: gnu: astropy: Update to 5.1
(address . 58645@debbugs.gnu.org)
CAO+9K5ow_mUxi5HwNQBu_hiQz6YRuJyYuqYVbfcHNCyGrF2tog@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 8606589d1b80fc22611b677b4d4d8f3de5355dcc Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Tue, 18 Oct 2022 23:15:56 +0100
Subject: [PATCH 4/7] gnu: astropy: Update to 5.1

* gnu/packages/astronomy.scm (python-astropy): Update to 5.1
---
gnu/packages/astronomy.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index aaa9207e0e..7001f96ed2 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -879,13 +879,13 @@ (define-public celestia-gtk
(define-public python-astropy
(package
(name "python-astropy")
- (version "5.0.1")
+ (version "5.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "astropy" version))
(sha256
- (base32 "09wh589ywjsgjvi76v2d2zqd9sri0461rrnml0b0pah5lbkcv0k3"))
+ (base32 "0zkv3ddzlxx21i796azfbqxrqnsxn83vsczscv577iyzxp3v5c8x"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -948,7 +948,7 @@ (define-public python-astropy
python-ipython
python-jplephem
python-objgraph
- python-pytest
+ python-pytest-7.1
python-pytest-astropy
python-pytest-xdist
python-setuptools-scm
--
2.37.3
S
S
Sharlatan Hellseher wrote on 19 Oct 2022 22:26
[PATCH 5/7]: gnu: photuils: Update to 1.5.0
(address . 58645@debbugs.gnu.org)
CAO+9K5pJ+N=dDtb5kTQjfEEncAzu8rOLHXfzi44PVEVj5NqZBw@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From c8a40801055b83564ddfb8d62eefc554c17a2810 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Tue, 18 Oct 2022 23:19:21 +0100
Subject: [PATCH 5/7] gnu: photutils: Update to 1.5.0

* gnu/packages/astronomy.scm (python-photutils): Update to 1.5.0
---
gnu/packages/astronomy.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 7001f96ed2..54c41f9a0c 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1125,13 +1125,13 @@ (define-public python-ephem
(define-public python-photutils
(package
(name "python-photutils")
- (version "1.3.0")
+ (version "1.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "photutils" version))
(sha256
- (base32 "1a8djakaya6w5iv9237gkcz39brqzgrfs2wqrl0izi1s85cfdymn"))))
+ (base32 "129n268wnziprrv09f7y6f98cj1vh1bzp7ygsna10h3ilnjplkq1"))))
(build-system python-build-system)
(arguments
`(#:test-target "pytest"
--
2.37.3
S
S
Sharlatan Hellseher wrote on 19 Oct 2022 22:29
[PATCH 6/7]: gnu: astropy-healpix: Update to 0.7
(address . 58645@debbugs.gnu.org)
CAO+9K5r1Q_7FwO+O4Y0-Aq-m8=h7wpvfiSa2CAo_v7eOADwTtw@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From c2d5e3056a0522f7df62d5802256613bca916429 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Tue, 18 Oct 2022 23:34:18 +0100
Subject: [PATCH 6/7] gnu: astopy-healpix: Update to 0.7

* gnu/packages/astronomy.scm (astopy-healpix): Update to 0.7
[source]: pypy-uri changed from astopy-healpix to astopy_healpix.
---
gnu/packages/astronomy.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 54c41f9a0c..c91ba3e487 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -974,13 +974,13 @@ (define-public python-astropy
(define-public python-astropy-healpix
(package
(name "python-astropy-healpix")
- (version "0.6")
+ (version "0.7")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "astropy-healpix" version))
+ (uri (pypi-uri "astropy_healpix" version))
(sha256
- (base32 "1436ml03xkmvx4afzbhfj67ab91418sz1w3lq1b18r43qchnd6j0"))))
+ (base32 "1n1svmd41iv944zf4anbnsigd47zr4dfjf49vrc7m6928gmq9hw8"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.37.3
S
S
Sharlatan Hellseher wrote on 19 Oct 2022 22:29
[PATCH 7/7]: gnu: regions: Update to 0.6
(address . 58645@debbugs.gnu.org)
CAO+9K5q6=440TgDQ6S0O_cFG3gnwzJ2GP4DJ=ktGiSzFg76jPA@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From b7dc2383e33be7432a4b3286987313ba482a592d Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Tue, 18 Oct 2022 23:39:17 +0100
Subject: [PATCH 7/7] gnu: regions: Update to 0.6

* gnu/packages/astronomy.scm (python-regions): Update to 0.6 which fixed
failing tests.
---
gnu/packages/astronomy.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c91ba3e487..c491f63863 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1192,13 +1192,13 @@ (define-public python-pyvo
(define-public python-regions
(package
(name "python-regions")
- (version "0.5")
+ (version "0.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "regions" version))
(sha256
- (base32 "1bjrcjchbw3xw1a26d5g198lh7vxpp9m5sal58r7f8mmr1d8g2dc"))))
+ (base32 "0p95bxxw4dgd16rh1yj7zvfbijk52dqvqj20nj6q8kr5ms08acl0"))))
(build-system python-build-system)
(arguments
`(#:test-target "pytest"
--
2.37.3
L
L
Liliana Marie Prikler wrote on 22 Oct 2022 13:55
3e8791e04ac0532113a75183419f4c2fff5bcf60.camel@gmail.com
Am Mittwoch, dem 19.10.2022 um 21:29 +0100 schrieb Sharlatan Hellseher:
Toggle quote (4 lines)
> --
> … ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
> ????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
> ?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
Pushed this and the rest of the series with some adjustments in the
commit messages.
Closed
?