[PATCH core-updates 0/2] build/gnu: Support compressing non-numeric man sections.

  • Done
  • quality assurance status badge
Details
2 participants
  • Lilah Tascheter
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Lilah Tascheter
Severity
normal
L
L
Lilah Tascheter wrote on 19 Oct 2022 17:24
(address . guix-patches@gnu.org)(name . Lilah Tascheter)(address . lilah@lunabee.space)
cover.1666192557.git.lilah@lunabee.space
The regex currently used by compress-documentation to compress manpages only
supports numeric man sections, which sometimes isn't the case (eg
man-pages-posix section 0p). Guix compiles with this change, but I haven't been
able to actually test packages with it due to these patches rebuilding
everything.

I'm not sure if something similar should be done for the infopage regex? I'm not
familiar with it.

Lilah Tascheter (2):
build/gnu: Support compressing non-numeric man sections.
gnu: man-pages-posix: Remove redundant manpage compression.

gnu/packages/man.scm | 8 ++++----
guix/build/gnu-build-system.scm | 2 +-
2 files changed, 5 insertions(+), 5 deletions(-)


base-commit: 511d584906c6304a3dc6ffcf7096bb14c6bee222
--
2.37.3
L
L
Lilah Tascheter wrote on 19 Oct 2022 17:27
[PATCH core-updates 1/2] build/gnu: Support compressing non-numeric man sections.
(address . 58638@debbugs.gnu.org)(name . Lilah Tascheter)(address . lilah@lunabee.space)
0056846d80b8fd7d0dba7604891bc6c65f550f8b.1666192557.git.lilah@lunabee.space
* guix/build/gnu-build-system.scm (compress-documentation)
[maybe-compress]: Expand regex to include man sections with alphabetic
suffixes.
---
guix/build/gnu-build-system.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index d84411c090..8f2997b4da 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -675,7 +675,7 @@ (define* (compress-documentation #:key outputs
(define (maybe-compress output)
(maybe-compress-directory (string-append output "/share/man")
- "\\.[0-9]+$")
+ "\\.[0-9]+[:alpha:]*$")
(maybe-compress-directory (string-append output "/share/info")
"\\.info(-[0-9]+)?$"))
--
2.37.3
L
L
Lilah Tascheter wrote on 19 Oct 2022 17:27
[PATCH core-updates 2/2] gnu: man-pages-posix: Remove redundant manpage compression.
(address . 58638@debbugs.gnu.org)(name . Lilah Tascheter)(address . lilah@lunabee.space)
26ddd60b3813d01749cee5d51d14fd5c762903c7.1666192557.git.lilah@lunabee.space
* gnu/packages/man.scm (man-pages-posix)[arguments]: Don't run build
phase.
---
gnu/packages/man.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 9a3297fcaf..b56262d832 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -315,11 +315,11 @@ (define-public man-pages-posix
(build-system gnu-build-system)
(arguments
`(#:tests? #f
- ;; The compress-documentation phase doesn't pick up on our manpages as
- ;; its regex doesn't support trailing letters, so manually compress.
- #:make-flags ,#~(list (string-append "prefix=" #$output) "gz")
+ #:make-flags ,#~(list (string-append "prefix=" #$output))
#:license-file-regexp "POSIX-COPYRIGHT"
- #:phases (modify-phases %standard-phases (delete 'configure))))
+ ;; The build phase only compresses documentation, which we already do.
+ #:phases (modify-phases %standard-phases (delete 'configure)
+ (delete 'build))))
(home-page "https://www.kernel.org/doc/man-pages/")
(synopsis "Man pages from the POSIX.1-2013 standard")
(description
--
2.37.3
M
M
Maxim Cournoyer wrote on 20 Jan 21:31 +0100
(name . Lilah Tascheter)(address . lilah@lunabee.space)(address . 58638-done@debbugs.gnu.org)
87msszeogf.fsf@gmail.com
Hi,

Lilah Tascheter <lilah@lunabee.space> writes:

Toggle quote (3 lines)
> * gnu/packages/man.scm (man-pages-posix)[arguments]: Don't run build
> phase.

Applied this series, thanks!

--
Thanks,
Maxim
Closed
?