[PATCH] gnu: Add cl-trivial-sockets.

  • Done
  • quality assurance status badge
Details
2 participants
  • cage
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
cage
Severity
normal

Debbugs page

cage wrote 2 years ago
(address . guix-patches@gnu.org)
Y1ANNICmUdMBQbjK@shimizu.casa.net
---
gnu/packages/lisp-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f23b4a70bb..50f2f91a77 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4057,6 +4057,37 @@ (define-public cl-usocket
(define-public ecl-usocket
(sbcl-package->ecl-package sbcl-usocket))

+(define-public sbcl-trivial-sockets
+ (package
+ (name "sbcl-trivial-sockets")
+ (version "0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/usocket/trivial-sockets.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "cl-usocket" version))
+ (sha256
+ (base32
+ "0xj9x5z3psxqap9c29qz1xswx5fiqxyzd35kmbw2g6z08cgb7nd0"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:tests? #f
+ #:asd-systems '("trivial-sockets")))
+ (home-page "https://github.com/usocket/trivial-sockets")
+ (synopsis "Simple socket library for Common Lisp")
+ (description
+ "This library is a portable socket interface that allows CL programs to
+open connected (client) stream sockets to network service.")
+ (license license:x11)))
+
+(define-public cl-trivial-sockets
+ (sbcl-package->cl-source-package sbcl-trivial-sockets))
+
+(define-public ecl-trivial-sockets
+ (sbcl-package->ecl-package sbcl-trivial-sockets))
+
(define-public sbcl-s-xml
(package
(name "sbcl-s-xml")
--
2.34.0
Guillaume Le Vaillant wrote 2 years ago
(name . cage)(address . cage-dev@twistfold.it)(address . 58635-done@debbugs.gnu.org)
87bkq6ud7h.fsf@kitej
Patch pushed as 4716cea6256523a8ecf90a426d675bfb7620f3e4 with a few
modifications. I didn't add the ecl-* variant because according to
"trivial-sockets.asd" the support for ECL is not implemented.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY1ECog8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/xVQD9HG13TQMSMIAPo90CkAOouT99IxSELCvIuGSl
aSbBQzsBAJGa807oeoRAiKLff4RMkpPk/dL1zl5PmqNhuNdyKM65
=WN4H
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58635@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58635
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help