[PATCH] gnu: Add emacs-org-cliplink.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Nicolas Goaziou
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20221018235724.17839-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-org-cliplink): New variable.
---
gnu/packages/emacs-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f02f48c01..c41e7ce127 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33477,6 +33477,41 @@ (define-public emacs-vundo
the buffer you want to undo. An undo tree buffer should pop up.")
(license license:gpl3+)))
+(define-public emacs-org-cliplink
+ (let ((commit "13e0940b65d22bec34e2de4bc8cba1412a7abfbc")
+ (revision "0"))
+ (package
+ (name "emacs-org-cliplink")
+ (version (git-version "20201126" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/rexim/org-cliplink")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1avyiw8vlv4n1r7zqvc6wjlsz7jl2pqaprzpm782gzp0c999pssl"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-geiser-racket-binary
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "org-cliplink-transport.el"
+ (("curl\")")
+ (string-append (search-input-file inputs "bin/curl") "\")"))))))))
+ (inputs (list curl))
+ (home-page "https://github.com/rexim/org-cliplink/")
+ (synopsis "Insert org-mode links from the clipboard")
+ (description
+"@code{emacs-org-cliplink} provides a simple command that takes a URL
+from the clipboard and inserts an org-mode link with a title of a page
+found by the URL into the current buffer.")
+ (license license:expat))))
+
(define-public emacs-project-x
;; There is no proper release.
;; The base version is extracted from the README.org.
--
2.38.0
N
N
Nicolas Goaziou wrote on 21 Oct 2022 10:02
(name . jgart via Guix-patches via)(address . guix-patches@gnu.org)
871qr1hads.fsf@nicolasgoaziou.fr
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-org-cliplink): New variable.

Thank you. Applied with the following changes.

Toggle quote (7 lines)
> +(define-public emacs-org-cliplink
> + (let ((commit "13e0940b65d22bec34e2de4bc8cba1412a7abfbc")
> + (revision "0"))
> + (package
> + (name "emacs-org-cliplink")
> + (version (git-version "20201126" revision commit))

Base version is actually "0.2", according to Version keyword in the main
file.

Toggle quote (3 lines)
> + (arguments
> + (list

I also activated tests.

Toggle quote (4 lines)
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-after 'unpack 'patch-geiser-racket-binary

The name of the phase looks like a copy-pasta typo. I overlooked it.
I'll fix it in a subsequent commit.

Toggle quote (8 lines)
> + (lambda* (#:key inputs #:allow-other-keys)
> + (substitute* "org-cliplink-transport.el"
> + (("curl\")")
> + (string-append (search-input-file inputs "bin/curl") "\")"))))))))
> + (inputs (list curl))
> + (home-page "https://github.com/rexim/org-cliplink/")
> + (synopsis "Insert org-mode links from the clipboard")

org-mode -> Org mode

Toggle quote (3 lines)
> + (description
> +"@code{emacs-org-cliplink} provides a simple command that takes a URL

emacs-org-cliplink is the internal name of the Guix variable bound to
the package definition. The project is actually org-cliplink or (as
a matter of taste) Org Cliplink.

Toggle quote (2 lines)
> +from the clipboard and inserts an org-mode link with a title of a page

Again : org-mode -> Org mode.

Regards,
--
Nicolas Goaziou
J
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
20221021113318.GB10328@dismail.de
On Fri, 21 Oct 2022 10:02:55 +0200 Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
Toggle quote (3 lines)
> The name of the phase looks like a copy-pasta typo. I overlooked it.
> I'll fix it in a subsequent commit.

Sorry about that! I overlooked it also.

I'll be more careful next time! Thanks for reviewing.

all best,

jgart
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58616@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58616
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch