(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
* gnu/packages/emacs-xyz.scm (emacs-org-cliplink): New variable.
---
gnu/packages/emacs-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
Toggle diff (48 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f02f48c01..c41e7ce127 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33477,6 +33477,41 @@ (define-public emacs-vundo
the buffer you want to undo. An undo tree buffer should pop up.")
(license license:gpl3+)))
+(define-public emacs-org-cliplink
+ (let ((commit "13e0940b65d22bec34e2de4bc8cba1412a7abfbc")
+ (revision "0"))
+ (package
+ (name "emacs-org-cliplink")
+ (version (git-version "20201126" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/rexim/org-cliplink")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1avyiw8vlv4n1r7zqvc6wjlsz7jl2pqaprzpm782gzp0c999pssl"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-geiser-racket-binary
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "org-cliplink-transport.el"
+ (("curl\")")
+ (string-append (search-input-file inputs "bin/curl") "\")"))))))))
+ (inputs (list curl))
+ (home-page "https://github.com/rexim/org-cliplink/")
+ (synopsis "Insert org-mode links from the clipboard")
+ (description
+"@code{emacs-org-cliplink} provides a simple command that takes a URL
+from the clipboard and inserts an org-mode link with a title of a page
+found by the URL into the current buffer.")
+ (license license:expat))))
+
(define-public emacs-project-x
;; There is no proper release.
;; The base version is extracted from the README.org.
--
2.38.0