[PATCH 1/2] gnu: Add python-watchpoints.

  • Done
  • quality assurance status badge
Details
One participant
  • jgart
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(name . Guix Patches)(address . guix-patches@gnu.org)
20221018183633.GB16996@dismail.de

J
[PATCH 1/2] gnu: Add python-objprint.
(address . 58615@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20221018234250.17292-1-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-objprint): New variable.
---
gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f215f40915..5d1fa0c97f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31142,6 +31142,36 @@ (define-public python-lief
and abstract ELF, PE and MachO formats.")
(license license:asl2.0)))
+(define-public python-objprint
+ (package
+ (name "python-objprint")
+ (version "0.2.2")
+ ;; The tests are not included in the PyPI archive.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gaogaotiantian/objprint")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jh9swg4cag2vxyzrjmsdmdrak6zhlgg8fjsnmmis8dm8bb41fq9"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-v")))))))
+ (home-page "https://github.com/gaogaotiantian/objprint")
+ (synopsis "Print Python objects in human readable format")
+ (description
+"This package provides a library that can print Python objects in human
+readable format.")
+ (license license:asl2.0)))
+
(define-public python-pymonad
(package
(name "python-pymonad")
--
2.38.0
J
[PATCH 2/2] gnu: Add python-watchpoints.
(address . 58615@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20221018234250.17292-2-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-watchpoints): New variable.
---
gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5d1fa0c97f..9cf0946d66 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31172,6 +31172,36 @@ (define-public python-objprint
readable format.")
(license license:asl2.0)))
+(define-public python-watchpoints
+ (package
+ (name "python-watchpoints")
+ (version "0.2.5")
+ ;; The tests are not included in the PyPI archive.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gaogaotiantian/watchpoints")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0d88vgjc99qp6wl3c3m3z2dyx46zb9vgfhwzwvbshay8g11fnfjp"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-v")))))))
+ (native-inputs (list python-pytest python-pandas))
+ (propagated-inputs (list python-objprint))
+ (home-page "https://github.com/gaogaotiantian/watchpoints")
+ (synopsis "Monitor read and write on variables")
+ (description
+"@code{python-watchpoints} monitors read and write on variables.")
+ (license license:asl2.0)))
+
(define-public python-pymonad
(package
(name "python-pymonad")
--
2.38.0
J
(address . 58615-done@debbugs.gnu.org)
ee21b61042da4702e4ba2808bc5d1f73878c636c@dismail.de
Closing. Feel free to reopen if working on it.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58615@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58615
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch