[PATCH] gnu: ardour: Update to 7.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Sughosha
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Sughosha
Severity
normal

Debbugs page

Sughosha wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
f-fsv5NdhTxS5XT2J52-cUTkXTZoA5hS9Cdas5Akn1y0VOwF-LIesj66uLDbHcr8Osj2x6TVssyYmY7AAfObo4pvvUqCrSeJptGnKSUlu-M=@proton.me
* gnu/packages/audio.scm (ardour): Update to 7.0.
---
gnu/packages/audio.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 55ef9f7f10..d489733bd1 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -633,7 +633,7 @@ (define (ardour-rpath-phase major-version)
(define-public ardour
(package
(name "ardour")
- (version "6.9")
+ (version "7.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -651,7 +651,7 @@ (define-public ardour
#t)))
(sha256
(base32
- "0vlcbd70y0an881zv87kc3akmaiz4w7whsy3yaiiqqjww35jg1mm"))
+ "1xzgcd2d8zzgx3s9sr3kcxl3vz3vfr5l1xs9qpjplmk22dfj8b08"))
(file-name (string-append name "-" version))))
(build-system waf-build-system)
(arguments
@@ -701,6 +701,7 @@ (define-public ardour
flac
glibmm
gtkmm-2
+ hicolor-icon-theme
jack-1
libarchive
libart-lgpl
--
2.38.0
Sughosha wrote 2 years ago
[PATCHES v2] gnu: ardour: Use system libraries and install man page
(name . 58613@debbugs.gnu.org)(address . 58613@debbugs.gnu.org)
BzZ8zOrs3BY0a6fL-AM7yVV_ADH80Gas78FCfFVlg9n2h4b8TmCrrySG--IFJZkUSsJzog3RWyk_37KbQ2RXjaCKixhatMUAXovemUgqIxk=@proton.me
Empty Message
From 641a18d7b3e1bd0089b451150ad82417de7d3bb1 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Thu, 20 Oct 2022 08:19:41 +0200
Subject: [PATCH v2 1/2] gnu: Add qm-dsp

* gnu/packages/audio.scm (qm-dsp): New variable.
---
gnu/packages/audio.scm | 60 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 60 insertions(+)

Toggle diff (80 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index d489733bd1..516c5d57da 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -144,6 +144,7 @@ (define-module (gnu packages audio)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (ice-9 regex)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
@@ -614,6 +615,65 @@ (define-public aubio
streams from live audio.")
(license license:gpl3+)))
+(define-public qm-dsp
+ (package
+ (name "qm-dsp")
+ (version "1.7.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/c4dm/qm-dsp")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1vkb1xr2hjcaw88gig7rknlwsx01lm0w94d2z0rk5vz9ih4fslvv"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ `(,(string-append "-f" (assoc-ref %build-inputs "source") "/build/"
+ (if ,(string-match "x86_64-linux"
+ (or (%current-target-system)
+ (%current-system)))
+ "linux/Makefile.linux64"
+ (if ,(string-match "i686-linux"
+ (or (%current-target-system)
+ (%current-system)))
+ "linux/Makefile.linux32"
+ (if ,(string-match "mingw32"
+ (or (%current-target-system)
+ (%current-system)))
+ "mingw32/Makefile.mingw32"
+ "general/Makefile.inc"))))
+ ,(string-append "CC=" ,(cc-for-target)))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib"))
+ (include (string-append out "/include")))
+ (install-file "libqm-dsp.a" lib)
+ (mkdir-p include)
+ (for-each
+ (lambda (dir)
+ (for-each
+ (lambda (file)
+ (if (directory-exists? file)
+ (mkdir-p (string-append include "/" file))
+ (if (string-suffix? ".h" file)
+ (copy-file file (string-append include "/" file))
+ #t)))
+ (find-files dir #:directories? #t)))
+ '("base" "dsp" "ext" "hmm" "maths" "thread"))))))
+ #:test-target "tests"))
+ (home-page "https://code.soundsoftware.ac.uk/projects/qm-dsp")
+ (synopsis "C++ library of functions for DSP and Music Informatics purposes")
+ (description
+ "QM-DSP is a C++ library of functions for DSP and Music Informatics
+purposes developed at Queen Mary, University of London.")
+ (license license:gpl2+)))
+
(define (ardour-rpath-phase major-version)
`(lambda* (#:key outputs #:allow-other-keys)
(let ((libdir (string-append (assoc-ref outputs "out")
--
2.38.0
From 14dd0806ee58cc2b05f06bd28118419ff9623319 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Thu, 20 Oct 2022 13:10:53 +0200
Subject: [PATCH v2 2/2] gnu: ardour: Use system libraries and install man page

* gnu/packages/audio.scm (ardour)
[arguments]: Use external libraries and install man page.
[inputs]: Add fluidsynth, hidapi, libltc and qm-dsp.
---
gnu/packages/audio.scm | 21 +++++++++++++++------
1 file changed, 15 insertions(+), 6 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 516c5d57da..b3e8074f09 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -715,11 +715,12 @@ (define-public ardour
(file-name (string-append name "-" version))))
(build-system waf-build-system)
(arguments
- `(#:configure-flags '("--cxx11" ; required by gtkmm
+ `(#:configure-flags '("--cxx11" ; required by gtkmm
"--optimize"
- "--no-phone-home" ; don't contact ardour.org
- "--freedesktop" ; build .desktop file
- "--test") ; build unit tests
+ "--no-phone-home" ; don't contact ardour.org
+ "--freedesktop" ; build .desktop file
+ "--test" ; build unit tests
+ "--use-external-libs") ; use system libraries
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-rpath-in-LDFLAGS
@@ -745,7 +746,11 @@ (define-public ardour
(install-file (string-append "build/gtk2_ardour/ardour"
ver ".appdata.xml")
(string-append share "/appdata/")))
- #t)))
+ #t))
+ (add-after 'install 'install-man-page
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "ardour.1" (string-append (assoc-ref outputs "out")
+ "/share/man/man1")))))
#:test-target "test"))
(inputs
(list alsa-lib
@@ -759,14 +764,17 @@ (define-public ardour
fftw
fftwf
flac
+ fluidsynth
glibmm
gtkmm-2
hicolor-icon-theme
+ hidapi
jack-1
libarchive
libart-lgpl
libgnomecanvasmm
liblo
+ libltc
libogg
libsamplerate
libsndfile
@@ -796,7 +804,8 @@ (define-public ardour
("gettext" ,gettext-minimal)
("itstool" ,itstool)
("perl" ,perl)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("qm-dsp" ,qm-dsp)))
(home-page "https://ardour.org")
(synopsis "Digital audio workstation")
(description
--
2.38.0
Ricardo Wurmus wrote 2 years ago
[PATCH] gnu: ardour: Update to 7.0
(address . 58613-done@debbugs.gnu.org)
87v8niyafz.fsf@elephly.net
Thank you for the patches! I’ve split the last one and made a few
changes to the qm-dsp package.

All applied, so I’m closing this.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58613@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58613
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help